#richfaces Meeting

Meeting started by balunasj_mtg at 14:03:16 UTC (full logs).

Meeting summary

  1. Git migration follow up (balunasj_mtg, 14:03:40)
    1. I have split formatting to two parts - Java and other resources (lfryc, 14:04:50)
    2. Java sources are already formatted using JBoss Community formatter settings ( RF-11019 ) (lfryc, 14:05:33)
    3. and it already passed CI builds (lfryc, 14:05:44)
    4. I have also enabled Checkstyle on all of the modules (lfryc, 14:06:11)
    5. There are differences between IDE format profiles - most notably NetBeans (balunasj_mtg, 14:12:46)
    6. ACTION: lfryc Add a suggestion to our contributing pages about IDE format (balunasj_mtg, 14:13:25)
    7. JBoss Community checkstyle is less strict than Richfaces (balunasj_mtg, 14:13:51)
    8. ACTION: lfryc Create a new IDE setup - suggest JBoss Tools an Eclipse, include IDEA, and not suggest netbeans ( be sure to state why ) (balunasj_mtg, 14:17:43)
    9. formatted code will be integrated into richfaces master branch at Thu, Jun 2 (lfryc, 14:25:08)
    10. Formatters for other resources (CSS, XHTML, XML, JavaScript) are not so compatible as Java source code (lfryc, 14:27:37)
    11. details are here: https://issues.jboss.org/browse/RF-11020 (lfryc, 14:28:04)
    12. IDEA: I think the best we can do is what seam does, and state what the resource file rules are (balunasj_mtg, 14:29:22)
    13. AGREED: for non-java resources the only thing we can do state the requirements in our IDE settings page (balunasj_mtg, 14:32:22)
    14. some of the resources wouldn't be formatted (because tests are expecting specific format) (lfryc, 14:34:11)

  2. 4.1 Planning (balunasj_mtg, 14:37:29)
    1. I've reviewed the existing jira's, and added some that we missing for the 4.1 release. (balunasj_mtg, 14:37:53)
    2. https://issues.jboss.org/browse/RF/fixforversion/12315856 (balunasj_mtg, 14:38:07)
    3. there is still some more clean up todo, and next I'll need to work on resource allocations and timing. (balunasj_mtg, 14:38:40)
    4. ACTION: balunasj_mtg Will complete jira review and discuss resource allocation and timing for the tasks in the dev forums (balunasj_mtg, 14:39:16)
    5. I've also created a 4.1.0.M2 jira release (balunasj_mtg, 14:39:37)
    6. as some of these will impact time requirements (balunasj_mtg, 14:40:50)
    7. Lets start with the ListShuttle and PickList (balunasj_mtg, 14:41:25)
    8. http://community.jboss.org/message/607988#607988 (balunasj_mtg, 14:41:28)
    9. the primary goals for 4.1 is to; combine picklist and listShuttle (balunasj_mtg, 14:43:39)
    10. this would include simplifying some of the requirements as well (balunasj_mtg, 14:44:14)
    11. ACTION: bleathem lfryc: Review the ListShuttle document and post thoughts (balunasj_mtg, 14:48:36)
    12. We also need to determine if we want to keep ListShuttle or PickList for the name? (balunasj_mtg, 14:51:51)
    13. AGREED: We can create a poll for the name (balunasj_mtg, 14:53:06)
    14. I'm going to skip OrderingList for now because it is closely related to the first two (balunasj_mtg, 14:53:15)
    15. next up is editor - this is another component that we ran out of time for in 4.0 (balunasj_mtg, 14:53:40)
    16. The trick here is that we need to spend some time to investigate the proper implementation to integrate with (balunasj_mtg, 14:54:14)
    17. the editor component is one of the few that we need to package a 3rd party impl with. (balunasj_mtg, 14:54:44)
    18. ACTION: lfryc Editor component assigned to lfryc - first step if flushing out the jira with sub-tasks for the investigation, then creating wiki page for more detailed requirement review. (balunasj_mtg, 14:58:17)
    19. last for now since we are running low on time is notify component from Bernard (balunasj_mtg, 14:58:48)
    20. this component is one of a perfect candidate for moving from sandbox into the core project. (balunasj_mtg, 14:59:14)
    21. ACTION: balunasj_mtg Define sub-tatsks for the review, and migration of notify component to the core suite. (balunasj_mtg, 15:00:34)


Meeting ended at 15:03:59 UTC (full logs).

Action items

  1. lfryc Add a suggestion to our contributing pages about IDE format
  2. lfryc Create a new IDE setup - suggest JBoss Tools an Eclipse, include IDEA, and not suggest netbeans ( be sure to state why )
  3. balunasj_mtg Will complete jira review and discuss resource allocation and timing for the tasks in the dev forums
  4. bleathem lfryc: Review the ListShuttle document and post thoughts
  5. lfryc Editor component assigned to lfryc - first step if flushing out the jira with sub-tasks for the investigation, then creating wiki page for more detailed requirement review.
  6. balunasj_mtg Define sub-tatsks for the review, and migration of notify component to the core suite.


Action items, by person

  1. balunasj_mtg
    1. balunasj_mtg Will complete jira review and discuss resource allocation and timing for the tasks in the dev forums
    2. balunasj_mtg Define sub-tatsks for the review, and migration of notify component to the core suite.
  2. bleathem
    1. bleathem lfryc: Review the ListShuttle document and post thoughts
  3. lfryc
    1. lfryc Add a suggestion to our contributing pages about IDE format
    2. lfryc Create a new IDE setup - suggest JBoss Tools an Eclipse, include IDEA, and not suggest netbeans ( be sure to state why )
    3. bleathem lfryc: Review the ListShuttle document and post thoughts
    4. lfryc Editor component assigned to lfryc - first step if flushing out the jira with sub-tasks for the investigation, then creating wiki page for more detailed requirement review.


People present (lines said)

  1. balunasj_mtg (98)
  2. lfryc (50)
  3. bleathem (11)
  4. jbott (2)
  5. jbossbot (2)
  6. ppitonak (1)
  7. jjamrich (1)


Generated by MeetBot 0.1.4.