14:03:16 <balunasj_mtg> #startmeeting
14:03:16 <jbott> Meeting started Wed Jun  1 14:03:16 2011 UTC.  The chair is balunasj_mtg. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:16 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:03:40 <balunasj_mtg> #topic Git migration follow up
14:04:08 <balunasj_mtg> lfryc: please let us know what the current status is, and how the code formatting is going?
14:04:50 <lfryc> #info I have split formatting to two parts - Java and other resources
14:04:59 <balunasj_mtg> good idea
14:05:33 <lfryc> #info Java sources are already formatted using JBoss Community formatter settings ( RF-11019 )
14:05:34 <jbossbot> jira [RF-11019] Refine formatting and checkstyle rules for Java [Coding In Progress (Unresolved) Sub-task, Major, Lukáš Fryč] https://issues.jboss.org/browse/RF-11019
14:05:44 <lfryc> #info and it already passed CI builds
14:06:11 <lfryc> #info I have also enabled Checkstyle on all of the modules
14:06:12 <balunasj_mtg> Excellent! that was one of my questions
14:06:38 <lfryc> I had to do some changes into formatter settings
14:06:48 <lfryc> and I would like to share some thought on IDE compatibility
14:06:54 <balunasj_mtg> please
14:07:29 <lfryc> for Java, it is less painful than with another resources, but still I can't agree that JBoss Comuunity settings is painless between IDEs
14:08:11 <lfryc> Eclipse / IDEA is more or less compatible, but Netbeans has quite less settings for code style and thus I discourage to use them for regular developers
14:08:29 <balunasj_mtg> lfryc: what type of differences are you seeing?
14:09:14 <lfryc> they cannot preserve white spaces between fields and types, also much less settings for comment style
14:09:49 <lfryc> but this is also problem for keeping source code clean by the point of view of SCM
14:09:51 <balunasj_mtg> ok ic - do the checkstyle currently enforce that?
14:10:16 <lfryc> but all of the IDEs generates checkstyle-compatible code
14:10:42 <lfryc> (just reformats some of the code which looks nasty in SCM
14:11:16 <lfryc> JBoss Community checkstyle is also much less strict than former RichFaces one
14:11:35 <balunasj_mtg> ok so we should not enforce what IDE, but we can suggest
14:11:57 <lfryc> yes, but another situation is in resources, I have some concerns there
14:12:09 <balunasj_mtg> lfryc: lets wrap up and agree with java first
14:12:46 <balunasj_mtg> #info There are differences between IDE format profiles - most notably NetBeans
14:13:25 <balunasj_mtg> #action lfryc Add a suggestion to our contributing pages about IDE format
14:13:51 <balunasj_mtg> #info JBoss Community checkstyle is less strict than Richfaces
14:14:03 <balunasj_mtg> lfryc: have you switched to jboss checkstyle?
14:14:10 <balunasj_mtg> lfryc: what are your thoughts here?
14:14:11 <lfryc> balunasj_mtg: yes
14:14:47 <lfryc> balunasj_mtg: it is much cleaner than RichFaces one - it uses standard modules instead of TreeWalkers
14:14:57 <balunasj_mtg> lfryc: ok good - one less thing to manage on our side
14:16:05 <lfryc> balunasj_mtg: I have also inspected the usage of Checkstyle plugins in IDEs - the best support seems to be in Eclipse, then IDEA, only Netbeans has basic support
14:16:26 <lfryc> balunasj_mtg: I would like to write new articlers on IDE setup
14:17:00 <balunasj_mtg> lfryc: ok so it is consistent then - we'll suggest JBoss Tools an Eclipse, include IDEA, and not suggest netbeans ( be sure to state why )
14:17:02 <lfryc> because it is not trivial (maybe it is for experts with given IDE, but I found it non-straightforward in IDEA and Netbeans)
14:17:20 <lfryc> balunasj_mtg: ok
14:17:27 <bleathem> are you guys using eclipse?
14:17:43 <balunasj_mtg> #action lfryc Create a new IDE setup - suggest JBoss Tools an Eclipse, include IDEA, and not suggest netbeans ( be sure to state why )
14:18:03 <balunasj_mtg> bleathem: I use IDEA more now, but have JBoss Tools as well.
14:18:09 <balunasj_mtg> bleathem: how about you?
14:18:33 <bleathem> Netbeans has been a good fit for what I've been doing lately, but I'm not committed to the IDE
14:19:03 <lfryc> balunasj_mtg: I had to change formatters settings, differentiates it from JBoss Community ones a little
14:19:16 <lfryc> not sure we should push that settings back
14:19:49 <lfryc> there settings was about interoperability between IDEs
14:19:52 <balunasj_mtg> bleathem: I've never used netbeans ( at least not for years )
14:19:53 <lfryc> *these
14:20:09 <balunasj_mtg> lfryc: What settings are you referring to?
14:21:16 <balunasj_mtg> bleathem: from the sounds of it the concern would be keeping the format consistent with netbeans.
14:21:28 <balunasj_mtg> bleathem: Perhaps you know something more there.
14:21:42 <ppitonak> balunasj_mtg: lfryc will be back soon
14:21:50 <balunasj_mtg> ppitonak: ok
14:21:59 <bleathem> I looked into it when Seam went through it's code format change just recently
14:22:06 * lfryc is back
14:22:13 <bleathem> the configurability is indeed weak as lfryc is pointing out
14:22:16 <balunasj_mtg> bleathem: we based our format on there.
14:22:51 <balunasj_mtg> lfryc: When do you think you will have the formatted code updated in RichFaces git repos ?
14:23:28 <bleathem> I'm fine with using a different IDE - I'd rather be using what the majority of the team is using at this point
14:23:41 <lfryc> balunasj_mtg: I expect it tomorrow
14:24:05 <lfryc> as I said, Java code is ready, but needs to finish resources
14:24:12 <lfryc> I can also integrate it in two steps
14:24:13 <balunasj_mtg> please use meetbot for that
14:24:18 <lfryc> #
14:25:08 <lfryc> #info formatted code will be integrated into richfaces master branch at Thu, Jun 2
14:25:42 <balunasj_mtg> It is up to you about the two phases
14:25:50 <balunasj_mtg> if you would rather do it all at once that is fine
14:26:13 <lfryc> sure
14:26:27 <lfryc> can we discuss other resources?
14:26:40 <balunasj_mtg> #into moving onto discuss non-java resources formatting
14:26:45 <balunasj_mtg> lfryc: sure :-)
14:27:37 <lfryc> #info Formatters for other resources (CSS, XHTML, XML, JavaScript) are not so compatible as Java source code
14:27:37 <balunasj_mtg> What is going on with the non-java resources?
14:27:53 * balunasj_mtg not surprised after looking a bit last week
14:27:57 <jjamrich> balunasj_mtg, note that you wrote into instead of info few lines above
14:28:04 <lfryc> #info details are here: https://issues.jboss.org/browse/RF-11020
14:28:05 <jbossbot> jira [RF-11020] Define and verify CSS, JavaScript and XHTML formatting rules [Coding In Progress (Unresolved) Sub-task, Major, Lukáš Fryč] https://issues.jboss.org/browse/RF-11020
14:28:58 <balunasj_mtg> lfryc: I think the best we can do is what seam does - say what the rules are
14:29:22 <balunasj_mtg> #idea I think the best we can do is what seam does, and state what the resource file rules are
14:29:55 <lfryc> balunasj_mtg: yes, but IDEs differs too much, for example when you tried to reformat XHTML file in Netbeans, you got changes of most of the code against Eclipse
14:30:24 <lfryc> balunasj_mtg: and also we cannot keep consistency by enforcing rules with checkstyle here
14:30:36 <balunasj_mtg> We might have to keep the rules there looser - like with seam - 4 spaces, no tabs, line limites
14:30:42 <balunasj_mtg> and thats it
14:31:23 <balunasj_mtg> Agree?
14:31:41 <lfryc> balunasj_mtg: I agree.. I will also mention these settings in articles about IDE settings
14:32:04 <bleathem> something to look at when reviewing pull requests
14:32:22 <balunasj_mtg> #agreed for non-java resources the only thing we can do state the requirements in our IDE settings page
14:32:31 <balunasj_mtg> bleathem: yup
14:33:01 <balunasj_mtg> lfryc: do you think you'll have the non-java resources updates tomorrow as well?
14:33:23 <lfryc> balunasj_mtg: yes, I'm going to integrate them tomorrow as well
14:33:46 <balunasj_mtg> bleathem: Looks like you'll get to start fresh with formatted code, git, and IDE settings wiki page :-)
14:33:53 <balunasj_mtg> lfryc: Excellent!
14:34:11 <lfryc> #info some of the resources wouldn't be formatted (because tests are expecting specific format)
14:34:33 <balunasj_mtg> lfryc: I've been waiting to set up my end until the reformat  - so I'll look more after
14:34:41 <balunasj_mtg> s/end/env
14:34:41 <bleathem> yes, and with git too!  excellent way to start!  thanks lfryc!!
14:34:53 <balunasj_mtg> exactly - thanks lfryc!
14:35:30 <lfryc> balunasj_mtg: I would like to discuss more on separation of components module later on since we have opportunity to do that now
14:36:19 <balunasj_mtg> lfryc: "later on" in this meeting?  if so I would suggest a dev forum topic with an outline of your thinking - I get concerned over fragmentations and release build complexities with too many modules.
14:36:52 <balunasj_mtg> We need to move on to 4.1 items at this point
14:36:58 <lfryc> sure
14:37:06 <lfryc> just leave it after you will import the code base into IDEs
14:37:06 <balunasj_mtg> lfryc: cool thanks
14:37:29 <balunasj_mtg> #topic 4.1 Planning
14:37:53 <balunasj_mtg> #info I've reviewed the existing jira's, and added some that we missing for the 4.1 release.
14:38:07 <balunasj_mtg> #link https://issues.jboss.org/browse/RF/fixforversion/12315856
14:38:40 <balunasj_mtg> #info there is still some more clean up todo, and next I'll need to work on resource allocations and timing.
14:39:16 <balunasj_mtg> #action balunasj_mtg Will complete jira review and discuss resource allocation and timing for the tasks in the dev forums
14:39:37 <balunasj_mtg> #info I've also created a 4.1.0.M2 jira release
14:40:28 <balunasj_mtg> # info I wanted to spend some time and discuss details of the new components
14:40:50 <balunasj_mtg> #info as some of these will impact time requirements
14:41:25 <balunasj_mtg> #info Lets start with the ListShuttle and PickList
14:41:28 <balunasj_mtg> #link http://community.jboss.org/message/607988#607988
14:42:39 <balunasj_mtg> Ilya and others have already discussed some of these points and the document here is a good starting point for these components.
14:42:52 <balunasj_mtg> These are some of the most requested components that did not make 4.0
14:43:39 <balunasj_mtg> #info the primary goals for 4.1 is to; combine picklist and listShuttle
14:44:14 <balunasj_mtg> #info this would include simplifying some of the requirements as well
14:44:53 <balunasj_mtg> The ordering list is related, because it is part of the listShuttle impl.
14:45:09 <balunasj_mtg> lfryc bleathem: have either of you had a chance to review this?
14:45:26 <lfryc> balunasj_mtg: not yet
14:46:00 <bleathem> not yet either
14:46:31 <balunasj_mtg> ok - please review it and post some of your thoughts.
14:46:44 <bleathem> will do
14:47:46 <balunasj_mtg> Some of big issues from the 3.3 impl was the converter, equals, and hash requirements - it made the implementation problematic.
14:47:53 * bleathem is beginning to realize how the dev forums are a central communication tool for the team
14:48:36 <balunasj_mtg> #action bleathem lfryc: Review the ListShuttle document and post thoughts
14:49:22 <balunasj_mtg> bleathem: Yup for the most part - things we can't get to in meetings should be continued there
14:49:23 <lfryc> bleathem: yes, we are basically using Dev forums instead of Mailing lists in case of seam team
14:49:49 <balunasj_mtg> lfryc: yup - which has good, and bad points.
14:49:51 <bleathem> cool, I'll add it to the list of sites I obsess over :D
14:50:48 <balunasj_mtg> forums are more expressive, but mailing lists are easier to track and respond to ( i.e. can't use "reply all" when following the dev forums ).
14:51:04 <balunasj_mtg> bleathem: yeah - I hear you - it can get overwhelming
14:51:51 <balunasj_mtg> #info We also need to determine if we want to keep ListShuttle or PickList for the name?
14:52:02 <balunasj_mtg> but that can be determined later
14:52:37 <lfryc> can involve community to choose right name ;-)
14:53:06 <balunasj_mtg> #agreed We can create a poll for the name
14:53:15 <balunasj_mtg> #info I'm going to skip OrderingList for now because it is closely related to the first two
14:53:40 <balunasj_mtg> #info next up is editor  - this is another component that we ran out of time for in 4.0
14:54:14 <balunasj_mtg> #info The trick here is that we need to spend some time to investigate the proper implementation to integrate with
14:54:44 <balunasj_mtg> #info the editor component is one of the few that we need to package a 3rd party impl with.
14:54:44 <lfryc> balunasj_mtg: exactly
14:55:10 <lfryc> balunasj_mtg: I had never like TinyMCE, but not sure if they haven't bring something new
14:55:21 <balunasj_mtg> Tiny MCE proved to be too much of a pain, with API's changing, skinning issues, etc...
14:55:55 <balunasj_mtg> so part of this task will me reviewing existing editor impls like jqueury's and others.
14:56:19 <balunasj_mtg> We just need to keep in mind requirements like skinning, plugable formatting, etc...
14:56:31 <balunasj_mtg> lfryc: would you like to tackle this one?
14:56:48 <lfryc> balunasj_mtg: I'm really interested in it
14:57:40 <balunasj_mtg> lfryc: ok good - I've assigned it to you - first step if flushing out the jira with sub-tasks for the investigation, then creating  wiki page for more detailed requirement review.
14:58:17 <balunasj_mtg> #action lfryc Editor component assigned to lfryc - first step if flushing out the jira with sub-tasks for the investigation, then creating  wiki page for more detailed requirement review.
14:58:48 <balunasj_mtg> #info last for now since we are running low on time is notify component from Bernard
14:59:14 <balunasj_mtg> #info this component is one of a perfect candidate for moving from sandbox into the core project.
14:59:41 <balunasj_mtg> Blabno could not make it today
14:59:53 <balunasj_mtg> but I talked with him and he agrees
15:00:11 <lfryc> #agreed it should be priority to take this Bernard's excellent contribution, review it and migrate to core suite
15:00:34 <balunasj_mtg> #action balunasj_mtg Define sub-tatsks for the review, and migration of notify component to the core suite.
15:01:00 <balunasj_mtg> It should try to use this as a model ( and test-case ) of sandbox migration in general
15:01:08 <balunasj_mtg> s/it/we
15:01:51 <balunasj_mtg> I'll flush out some of the tasks around it and we'll discuss off-meeting
15:02:16 <balunasj_mtg> As expected we have run out of time - and I have another meeting now
15:03:04 <balunasj_mtg> We'll discuss the remaining items in the forums - I'll create some posts for them.
15:03:08 <balunasj_mtg> Thanks all
15:03:25 <lfryc> thank you, guys
15:03:59 <balunasj_mtg> #endmeeting