21:08:30 <lightguard_jp> #startmeeting
21:08:30 <jbott> Meeting started Wed Jun 15 21:08:30 2011 UTC.  The chair is lightguard_jp. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:08:30 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:08:53 <lightguard_jp> #topic Git Flow change target date
21:09:46 <lightguard_jp> I think we're all in agreement we want to use git flow
21:09:53 <kenfinnigan> +1
21:10:06 <lightguard_jp> We need to set a date for module conversion
21:10:21 <lightguard_jp> I'm thinking two or three weeks out.
21:10:27 <lightguard_jp> What does everyone else think?
21:10:31 <bleathem> after JAXConf for sure
21:10:52 <gastaldi> I am using git flow on Seam Reports already
21:10:52 <kenfinnigan> sounds good
21:11:08 <gastaldi> It rocks :)
21:11:47 <lightguard_jp> Okay, three weeks it is
21:12:11 <lightguard_jp> #agreed git flow conversion will be done for all modules by July 5, 2011
21:12:43 <lightguard_jp> The core devs will fix the modules that aren't done by that week
21:12:45 <mojavelinux> update contributor page should be in there too
21:12:53 <gastaldi> yeah
21:13:10 <mojavelinux> in addition, the contributor page should have some text about why and how you fork
21:13:14 <mojavelinux> that was just missing from before
21:13:29 <lightguard_jp> #info contributor page needs to be updated by July 5, 2011 to reflect the change to git flow
21:13:32 <mojavelinux> wait, sorry
21:14:18 <mojavelinux> what is missing is how to pull in changes from upstream
21:14:24 <mojavelinux> it's a minor addition
21:14:33 <mojavelinux> I think we had talked about it on the mailinglist, but it never made it to the contribute page
21:14:43 <mojavelinux> the section should be "staying up to date"
21:15:03 <lightguard_jp> #info pulling changes, and which branch to branch from need to be added to contributor page
21:15:07 <mojavelinux> though I may have heard this is automatic now...anyway, we should mention whatever reflects reality
21:15:46 <lightguard_jp> Who did the current one, was that Cody?
21:15:48 <lightguard_jp> Or Brian?
21:15:56 <kenfinnigan> think it was bleathem
21:16:05 <bleathem> it was me
21:16:16 <lightguard_jp> bleathem: Would you mind taking action item?
21:16:21 * bleathem hides
21:16:28 <jose_freitas> haha
21:16:37 <lightguard_jp> Hiding because you know I'll follow up with you huh?
21:16:38 <lightguard_jp> lol
21:17:04 <lightguard_jp> #action bleathem will update the contributor page by July 5, 2011
21:17:11 <lightguard_jp> So let it be written so let it be done
21:17:13 <lightguard_jp> :)
21:17:41 <lightguard_jp> Any further questions about git flow?
21:17:44 <gastaldi> haha, the Ten commandments
21:17:54 <lightguard_jp> Great show, great line
21:18:05 <gastaldi> cool
21:18:14 <lightguard_jp> Okay, moving on then.
21:18:17 <gastaldi> No questions
21:18:22 <lightguard_jp> #topic Design Work Group
21:18:28 <lightguard_jp> kenfinnigan: You mind talking about this one?
21:18:34 <lightguard_jp> And the ideas you sent to us?
21:18:34 <kenfinnigan> sure
21:18:51 <lightguard_jp> thanks
21:19:06 <kenfinnigan> basically we're looking to put together a small working group of us to debate/decide on major API changes and future design ideas
21:19:24 <kenfinnigan> my initial thoughts were for two co-chairs, one RH and one community elected
21:19:36 <kenfinnigan> with a min of 4-5 inc the chairs at each mtg
21:19:53 <kenfinnigan> with the pool of members for the meeting coming from the module leads and community integrator
21:20:19 <gastaldi> Cool
21:20:20 <kenfinnigan> with a couple of community member positions as well (that are not module leads already)
21:20:33 <kenfinnigan> but after reading AoC today
21:20:41 <kenfinnigan> I'm thinking we could make it a bit leaner
21:21:14 <kenfinnigan> and actually make the DWG only 5-6 members, which consist of the two co-chairs, community integrator and a couple of positions from leads/community
21:21:26 <kenfinnigan> maintaining an even balance between RH core dev and community
21:21:34 <gastaldi> #agreed
21:21:42 <kenfinnigan> got some of these ideas from Ubuntu's concept of a Technical Board
21:21:48 <jose_freitas> #agreed
21:22:00 <kenfinnigan> with at least a monthly mtg, and at most two
21:22:16 <kenfinnigan> if there are so many items that can't be dealt with in two mtgs a month
21:22:40 <kenfinnigan> then we constitute action groups that are made up of people outside the DWG to put a proposal together based on the problem domain
21:22:49 <kenfinnigan> and then the DWG will review and decide on that at a mtg
21:22:51 <lightguard_jp> BTW, these will be short meetings, no more than an hour, most likely less.
21:22:55 <kenfinnigan> all make sense?
21:23:02 <kenfinnigan> lightguard_jp: good point
21:23:03 <gastaldi> works for me
21:23:10 <kenfinnigan> these are obviously initial musings
21:23:13 <jose_freitas> it seems a good idea
21:23:16 <kenfinnigan> and are open to other ideas and thoughts
21:23:40 <mojavelinux> yep. and I think it needs to kick off with, perhaps as an input into it, the definition of seam project, which jason, rodney and I have been talking about pulling together
21:23:45 <lightguard_jp> Sounds like everyone is in agreement
21:23:48 <mojavelinux> I think that helps us understand what the DWG is aiming for
21:23:54 <mojavelinux> more like the 20,000 ft view
21:24:23 <kenfinnigan> definitely, from AoC, this group would need a well defined terms of operation, essentially, to prevent it getting stuck in mud
21:24:24 <lightguard_jp> #agreed DWG will consist of 5-6 members which consist of the two-chairs, community integrator and a couple of positions from leads / community.
21:24:31 <kenfinnigan> or trying to do what it wasn't designed for
21:24:42 <lightguard_jp> #info one chair will be a RH employee, the other will be a community elected position.
21:25:14 <gastaldi> I vote for jose_freitas as the community member :)
21:25:53 <lightguard_jp> #info send lightguard_jp your nominations for community member elections
21:25:57 <kenfinnigan> similar to the community integrator, the elected positions would have a set term
21:26:06 <gastaldi> yup
21:26:07 <kenfinnigan> but you could re-nominate for the same position
21:26:14 <gastaldi> #agreed
21:26:33 <lightguard_jp> #info we'll do a vote on Monday-Wednedsay next week. Submissions must be in before Monday
21:27:25 <lightguard_jp> Will all community spots be elected or just the co-chair?
21:27:38 <kenfinnigan> good question
21:28:02 <kenfinnigan> obviously the RH chair will be decided internally
21:28:16 <kenfinnigan> but as for the other positions, probably makes sense to nominate for them as well
21:28:30 <kenfinnigan> as we wouldn't want to just assign a lead the position and they don't want it
21:29:13 <kenfinnigan> but as an initial start, the co-chairs could seek out people they see as being appropriate for the roles and approach directly
21:29:22 <kenfinnigan> to save time and not need another round of voting
21:29:31 <kenfinnigan> that's what Ubuntu did for their first councils
21:29:50 <gastaldi> #agreed with kenfinnigan
21:30:31 <lightguard_jp> Okay, I'm good with that idea
21:31:07 <lightguard_jp> Everyone else like the idea?
21:31:28 <gastaldi> I do
21:31:54 <lightguard_jp> I think that's most people in that case
21:32:16 <lightguard_jp> #agreed the two co-chairs will will directly approach others to be on the initial DWG
21:32:21 <lightguard_jp> sbryzak: Are you here?
21:33:06 <lightguard_jp> Guess not.
21:33:34 <lightguard_jp> Are there other questions about the DWG idea?
21:34:52 <lightguard_jp> Maybe our Community Integrator can talk about the next item
21:35:05 <gastaldi> What is the next item ?
21:35:09 <lightguard_jp> #topic Combined jar
21:35:19 <gastaldi> oh
21:35:30 <lightguard_jp> IIRC it was Dan, Shane, George and myself talking about this on IRC a few days ago
21:36:07 <gastaldi> I believe Shane should have more to tell than myself :)
21:36:08 <lightguard_jp> The idea has been presented to drop the combined jar
21:36:18 <lightguard_jp> I don't think Shane is present though
21:36:36 <lightguard_jp> And to rename the impl jars to just the name of the module.
21:36:36 <gastaldi> I like the the Profile idea
21:36:53 <lightguard_jp> gastaldi: Care to explain so everyone is on board?
21:36:59 <lightguard_jp> Or on the same page rather
21:37:03 <gastaldi> Ok, I´ll try it
21:37:56 <gastaldi> After all the discussion, mojavelinux came with the idea to have a "Seam Web Profile" JAR that bundles several Seam modules altogether
21:38:25 <gastaldi> That could make easier to start running a Seam app without needing to list them separately
21:38:26 <kenfinnigan> think I saw some of that on the mailing list too
21:38:43 <gastaldi> But I think the discussion stopped there :)
21:38:45 <lightguard_jp> Might have been on the list too, I don't remember
21:39:15 <kenfinnigan> I like the idea of targeted combined jars
21:39:20 <kenfinnigan> as opposed to one for each module
21:39:29 <bleathem> can we seperate this into two issues
21:39:36 <bleathem> 1) dropping the combined jar
21:39:39 <gastaldi> There are some complaints with that, that could be discussed also. I think johnament was the first to disagree with that
21:39:40 <bleathem> 2) having profile jars
21:39:44 <jose_freitas> true
21:39:50 <gastaldi> bleathem: Agreed
21:39:50 <jose_freitas> they're two different things
21:39:52 <lightguard_jp> The current combined jars for each module is cumbersome, adds complexity and the questions remains with what we do with multiple impl modules like Reports and Cron
21:39:57 <lightguard_jp> Or Mail
21:40:00 <sbryzak> hey guys, sorry i'm late
21:40:08 <gastaldi> welcome back sbryzak !
21:40:39 <lightguard_jp> Oh cool.
21:40:43 <lightguard_jp> Just in time.
21:40:46 <gastaldi> I personally like the merged jar idea
21:40:48 <jose_freitas> couldn't we have a combined jar for modules with just one impl, and combined jars for each implementations?
21:40:52 <lightguard_jp> We're talking about the combined jar issue(s)
21:41:07 <gastaldi> jose_freitas: Yes, that´s the point
21:41:21 <kenfinnigan> jose_freitas: I think that would get too complicated
21:41:32 <kenfinnigan> and then pose problems if a module went from single to multiple impls
21:41:38 <jose_freitas> like for seam faces we could have one combined jar called seam-faces, and for seam-reporting, we could have seam-reporting-jasper, and seam-reporting-birt
21:41:49 <mojavelinux> the combined jar discussion had gotten deferred prior to the release of seam 3. my concern at that time, and still today, is that because of transitive dependencies, users will accidently include a combined jar and an individual jar (api or impl) when they start adding seam modules
21:42:07 <lightguard_jp> The current build system would be amazingly complex for that, it could be done, but I don't think that's the way we want to go
21:42:08 <mojavelinux> it's just too easy to screw it up, because maven is not giving you any warning when you have a mix
21:42:13 <sbryzak> jose_freitas: a combined jar wouldn't work in that scenario
21:42:26 <bleathem> just include any of the impls, and maven deps will bring in the api
21:42:34 <mojavelinux> the combined "stack" jars get away from this problem since you are choosing just that one thing, and nothing else (presumably)
21:42:37 <bleathem> is it more complicated than that?
21:42:40 <gastaldi> bleathem: Yeah, I could live with that
21:42:46 <mojavelinux> exactly, that's what we should be leveraging
21:42:50 <sbryzak> bleathem: that's the idea
21:43:06 <bleathem> then let's do it, the profile jars can be a seperate decision
21:43:19 <mojavelinux> yeah, and the combined jars are really just stack poms
21:43:20 <gastaldi> I believe that the number of jars is not a valid argument for this
21:43:24 <jose_freitas> I agree with that. that way we manage just one dependency
21:43:27 <mojavelinux> so they depend on the impl and api of various modules
21:43:31 <mojavelinux> again, no risk of conflict
21:43:42 <mojavelinux> we shouldn't add additional artifacts into the system (jar artifacts that is)
21:43:45 <bleathem> going from one har to 2 is not a concern, this is not exponentially scaling
21:44:00 <bleathem> ^jar, not har
21:44:02 <gastaldi> also, there could be beans.xml on both jars, so to merge them into one only would be complicated
21:44:07 <mojavelinux> besides, it doesn't really matter how many jars you have in your deployment, because in the end, it's the same number of KB
21:44:16 <gastaldi> mojavelinux: agreed
21:44:30 <mojavelinux> right, esp with AS 7's modular classloader, we will get different behavior if we mash stuff into one jar
21:44:41 <bleathem> so everyone agrees to drop the combined jar?
21:44:43 <gastaldi> God save AS7
21:44:43 <jose_freitas> the way bleathem exposed, works pefectly for both sides.
21:44:51 <gastaldi> #agreed
21:44:59 <bleathem> will we do this for the 3.1 release, or earlier?
21:45:18 <gastaldi> When is 3.1 scheduled to ?
21:45:34 <sbryzak> we'll do it for 3.1, but if any modules have a prior release we could probably do it then
21:45:39 <sbryzak> (for that module)
21:45:53 <gastaldi> well, seam reports is using that already :)
21:46:11 <bleathem> ok, so one module at a time, with all done by the 3,.1 release
21:46:24 <bleathem> sounds good to me :)
21:46:27 <sbryzak> if there's dependencies on other modules then we'll have to do another release for 3.1
21:46:41 <gastaldi> cool
21:46:47 <sbryzak> actually, no we won't.. it should "just work"
21:47:03 <gastaldi> yeah
21:47:09 <sbryzak> the bom will take care of it
21:48:09 <bleathem> the bom takes care of all
21:48:24 <bleathem> all hail the bom
21:48:36 <lightguard_jp> #agreed the combined jar will go away
21:48:45 <bleathem> who's going to do that?
21:48:48 <lightguard_jp> Are we agreed to renaming the impl jar to just the module name?
21:48:50 <bleathem> sounds like a lot of maven messy work
21:48:57 <bleathem> #agreed
21:49:10 <kenfinnigan> +1 to rename
21:49:14 <lightguard_jp> e.g. seam-mail, seam-servlet, seam-catch etc
21:49:27 <jose_freitas> +1 to rename
21:49:40 <lightguard_jp> #agreed renaming impl jars to just the name of the module
21:49:48 <bleathem> The rename should be such that people's pom's don't break if they used the combined jar previously
21:50:04 <lightguard_jp> That's part of the reason for doing it this way, yes.
21:50:06 * bleathem is participating more than he intended to
21:50:12 <lightguard_jp> Actually, probably the biggest reason.
21:50:14 <bleathem> then +1 to rename
21:50:33 <sbryzak> i'll handle it when we do the next major seam release
21:50:52 <jose_freitas> bleathem: but don't forget that it will break for those not using combined jar
21:51:08 <lightguard_jp> #info the rename and abolishing of the combined jar will happen for all modules by Seam 3.1 but if there are module releases before that they will adopt the new standard.
21:51:09 <bleathem> jose_freitas: we can't when them all :P
21:51:11 <jose_freitas> but it's for good
21:51:30 <lightguard_jp> #action sbryzak will handle the renames / combined jar pom configs as they come up
21:52:20 <lightguard_jp> jose_freitas: I think in reality that number will be very low
21:52:34 <lightguard_jp> mostly because maven is lazy with it's dependencies.
21:52:43 <jose_freitas> well, I defend combined jar, but I mostly use it api and impl
21:52:43 <jose_freitas> hehehe
21:52:58 <jose_freitas> but yes, I believe it too
21:54:02 <lightguard_jp> Do we want the profile jar idea as it's own topic?
21:54:14 * bleathem now has the *best* bash prompt including git details
21:54:33 * lightguard_jp thinks bleathem had better screenshot it for all to see
21:54:44 <kenfinnigan> something for the DWG?
21:54:55 <bleathem> lightguard_jp: yes, it's own topic
21:54:59 <jose_freitas> lightguard_jp: I belive so
21:55:03 <bleathem> or yes, good for the DWG
21:55:13 <bleathem> all hail the DWG
21:55:15 <lightguard_jp> It sounds like a good discussion for the DWG
21:55:31 <lightguard_jp> That'll give people some time to think about it as well.
21:56:06 <kenfinnigan> minor segway back to DWG briefly
21:56:25 <kenfinnigan> my thoughts are that the agenda is public for each meeting and topics can be submitted by anyone
21:56:45 <gastaldi> agreed
21:56:55 <kenfinnigan> and there is nothing saying that if a non DWG member has strong opinions about an agenda item they can submit their thoughts to a DWG member for inclusion
21:57:24 <kenfinnigan> we're not creating a club of exclusivity here, just a means to make global seam design decisions
21:57:28 <lightguard_jp> #info agendas will be public, topics can be submitted by anyone.
21:57:31 <jose_freitas> nice kenfinnigan
21:57:43 <jose_freitas> is there some kind of tool to "officialize" that?
21:57:49 <lightguard_jp> Do we want a separate mailing list for this or just use the seam-dev list?
21:57:52 <jose_freitas> or it will be by email?
21:58:09 <kenfinnigan> i was thinking about that
21:58:25 <kenfinnigan> I think it probably needs to be separate, with decisions and actions posted to the main list
21:58:33 <gastaldi> The seam-dev list would be fine I guess
21:58:40 <jose_freitas> agreed with gastaldi
21:58:54 <gastaldi> It´s related to it
21:59:00 <jose_freitas> they're seam-dev discussions
21:59:14 <kenfinnigan> fine with using seam-dev, but would need some kind of subject key maybe to distinguish it from other traffic
21:59:30 <lightguard_jp> Yep
21:59:37 <lightguard_jp> [DWG] ?
21:59:39 <bleathem> I think one bonus of the DWG is to streamline the decision making process
21:59:44 <kenfinnigan> that works
21:59:53 <bleathem> and having all dicsussion on the sem-dev mailing list will load on extra baggae
22:00:00 <sbryzak> seam-dev gets so little traffic now that i don't think it will get lost
22:00:05 <bleathem> =1 for seperate mailing list for DWG
22:00:09 <bleathem> ^ +1
22:00:12 <jose_freitas> if we use [DWG], than it's better to keep a differnt list
22:00:54 <gastaldi> +1 for [DWG]
22:00:54 <jose_freitas> the thing is to keep the feed to seam-dev
22:01:41 <sbryzak> i have a question.. what is the design work group going to do that's different to what we do on seam-dev already?
22:01:44 <lightguard_jp> We're pretty divided on the mailing list :)
22:01:51 <gastaldi> Let´s keep in seam-dev then, if it gets messy, split into another one
22:02:01 <gastaldi> Everyone agrees with that ?
22:02:09 <bleathem> sbryzak: actually come to a conclusion on issues
22:02:15 <lightguard_jp> It's a streamlined group for large architecture discussion and design.
22:02:22 <bleathem> sbryzak: it seems things atll a lot on seam-dev
22:02:30 <bleathem> ^stall a lot
22:02:39 <sbryzak> bleathem: any particular examples?
22:02:50 <bleathem> the combined jars most recently
22:02:57 <bleathem> profile jars
22:03:05 <sbryzak> i don't think it stalled
22:03:12 <sbryzak> we planned to discuss it at today's irc meeting
22:03:22 <sbryzak> and we've now reached a conclusion
22:03:28 <gastaldi> would that make a difference being on another mailing list ?
22:03:29 <sbryzak> it didn't take that long ;)
22:03:44 <bleathem> ok, you convinced me
22:03:45 <sbryzak> we're not creating another mailing list
22:03:50 <gastaldi> :)
22:03:54 <sbryzak> we already have one for this exact purpose
22:04:19 <sbryzak> if you think something is stalling, then bring it up directly with the people you think it should involve
22:04:34 <sbryzak> or discuss it with them on irc
22:04:41 <sbryzak> a lot of decisions get made during irc discussions
22:05:07 <gastaldi> It´s amazing IRC is still useful nowadays :)
22:05:16 <sbryzak> i don't think that creating a new subset group of people is going to make any difference
22:05:34 <sbryzak> and besides, our team size just isn't big enough to warrant it
22:05:35 <bleathem> ok, I think everyone agrees to use the seam-dev mail list then
22:05:54 <gastaldi> next topic /
22:05:55 <gastaldi> ?
22:05:59 <lightguard_jp> It may not now, but if we had every module lead in attendance to these meetings it certainly would.
22:06:05 <bleathem> (since I was probably the only one who didn't agree initially :P )
22:06:05 <lightguard_jp> Don't have one
22:06:09 <lightguard_jp> That's it
22:06:14 <gastaldi> Cool
22:06:17 <gastaldi> We´re done in time
22:06:25 <mojavelinux> yeah!
22:06:33 <lightguard_jp> Good meeting all!
22:06:34 <sbryzak> i think the weekly irc meeting is the time to bring up stuff like that
22:06:36 <gastaldi> getting better every weel
22:06:38 <gastaldi> week
22:06:43 <lightguard_jp> #endmeeting