21:04:49 <mojavelinux> #startmeeting
21:04:49 <jbott> Meeting started Wed Jun  1 21:04:49 2011 UTC.  The chair is mojavelinux. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:04:49 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:04:53 <kenfinnigan> and the pointy hat?
21:05:07 <lightguard_jp> Add me as a chair please
21:05:07 <bleathem> the pointy "red" hat!
21:05:12 <kenfinnigan> lol
21:05:13 <gastaldi> we hail you
21:05:19 <mojavelinux> #chair lightguard_jp
21:05:19 <jbott> Current chairs: lightguard_jp mojavelinux
21:05:20 <kenfinnigan> isn't that a cardinal?
21:05:30 <mojavelinux> no underwear on underneath :)
21:05:34 <gastaldi> haha
21:05:36 <bleathem> yikes!
21:05:41 <lightguard_jp> You've been hanging around Pete too much
21:05:47 <gastaldi> lol
21:05:50 <mojavelinux> hehehe
21:05:55 <lightguard_jp> Okay, let's get started
21:05:59 <lightguard_jp> First item up
21:06:07 <lightguard_jp> #topic Action Items from last week
21:06:19 <lightguard_jp> bleathem: Your report
21:06:52 <mojavelinux> get on the pulpit man
21:07:05 <gastaldi> He must be praying now
21:07:07 <mojavelinux> brother leathem
21:07:12 <gastaldi> ARISE
21:07:26 <kenfinnigan> is that what bleatham is short for? brother leathem
21:07:33 <kenfinnigan> never knew you were a monk brian!
21:07:36 <gastaldi> haha
21:07:43 <bleathem> sorry
21:07:47 <bleathem> afk for a minute
21:07:50 <lightguard_jp> There he is
21:08:13 <bleathem> #info I spoke with Jay re: the dataexport from jsf data tables
21:08:42 <gastaldi> cool
21:08:56 <bleathem> #info short answer is RichFaces 4 planned to add support for this, but not shceduled for a release version yet
21:09:10 <lightguard_jp> Good enough for me
21:09:18 <bleathem> #info follow-up for further discussion on the RichFaces forums, to discuss any Seam tie-in
21:09:23 <lightguard_jp> I know primefaces already has it, pretty sure icefaces does as well.
21:09:31 <lightguard_jp> not sure about openfaces
21:09:43 <bleathem> right, so JBoss needs a solution to
21:09:47 <bleathem> too
21:09:48 <mojavelinux> funny that was one of the first jsp tags I used
21:09:50 <mojavelinux> displaytag
21:09:53 <mojavelinux> for that very reason
21:10:00 <mojavelinux> that was like 8 years ago
21:10:06 <bleathem> time flies eh mojavelinux?
21:10:16 <kenfinnigan> reminiscing?
21:10:22 <clerum> primefaces lets apache poi do the excel formatting. very simple but effective
21:10:28 <mojavelinux> just saying, nice to see that we are getting around to it :)
21:10:44 <gastaldi> hum, shouldn´t be too hard to do that either
21:10:45 <lightguard_jp> Okay, we'll leave that up to the RichFaces team to work out, and people that ask can pester them :)
21:10:55 <clerum> yeah definitly a RF thing
21:10:56 <bleathem> it may be cool if RF provides basic functionality, but Seam integration could provide some added "sauce"
21:10:59 <mojavelinux> okay, but that would be a great feature for an example app
21:11:00 <gastaldi> Okey
21:11:04 <mojavelinux> so let's make sure we use it as soon as it's ready
21:11:08 <bleathem> via Seam Reports or something
21:11:13 <mojavelinux> oh, yeah!
21:11:14 <mojavelinux> plugin
21:11:16 <gastaldi> Yeah !
21:11:20 <gastaldi> Forge !
21:11:29 <mojavelinux> well, I meant plugin like extension
21:11:30 <mojavelinux> spi
21:11:31 <mojavelinux> or something
21:11:34 <gastaldi> ah ok
21:11:40 <bleathem> /done
21:11:41 <gastaldi> That would do as well :)
21:11:46 <mojavelinux> as in, you get the data dump and you can feed it into your report mechanism
21:11:55 <lightguard_jp> Next two official items from last week went to mojavelinux.
21:12:20 <mojavelinux> oh yes, cool
21:12:24 <lightguard_jp> About the definitions and arquillian embedded jboss modules
21:12:26 <mojavelinux> okay, so notice on the home page we now have the defintiions
21:12:32 <mojavelinux> I updated the community integrator definition
21:12:44 <mojavelinux> http://seamframework.org/Community/CommunityRoles
21:13:15 <gastaldi> nice
21:13:39 <lightguard_jp> #link http://seamframework.org/Community/CommunityRoles
21:13:46 <mojavelinux> I checked on the embedded AS 7 and it sounds like that is already working (or close to it); basically, AS 7 can be embedded cleanly
21:13:53 <lightguard_jp> That may show up twice, oh well :)
21:14:09 <lightguard_jp> #info AS7 can be embedded cleanly for arquillian tests
21:14:20 <kenfinnigan> is there somewhere we can get it yet?
21:14:57 <mojavelinux> I'm a bit behind on following the arquillian dev, but as far as I know, the container should be available
21:15:03 <mojavelinux> check the github repo for Beta1
21:15:04 <gastaldi> I wish configuring arquillian be a little easier.
21:15:06 <kenfinnigan> cool
21:15:49 <mojavelinux> not up to date with Beta1 yet
21:15:58 <mojavelinux> it will be simpler, that's what is currently being worked on
21:16:04 <gastaldi> Ok
21:16:07 <lightguard_jp> We have a couple of followup items that weren't official as well.
21:16:17 <mojavelinux> we are in a bit of a between period right now, because the docs aren't yet put together with the latest of how arquillian in configured
21:16:21 <mojavelinux> but it gets a lot simpler
21:16:27 <bleathem> ALR is the king of developer simplicity, so if he's on it, there is nothing to worry about
21:16:28 <lightguard_jp> One is removing "Committer" from the module pages
21:16:31 <bleathem> :D
21:16:31 <mojavelinux> and I've proposed moving to a yaml baesd format for configuration to make it even simpler
21:16:37 <lightguard_jp> This has been done and now says "Contributor" :)
21:16:44 <gastaldi> Oh my, looks like I won something ! :D
21:17:05 <bleathem> yaml +1 !
21:17:26 <mojavelinux> I'm going to suggest that we have arquillian.yaml if arquillian.xml is absent
21:17:31 <mojavelinux> gotta file a jira for that
21:17:32 <lightguard_jp> We're also in the process of removing the GWT module from the site and replacing it with Errai info
21:17:39 <gastaldi> cool
21:17:59 <mojavelinux> yes, that's for driving that jason
21:18:06 <mojavelinux> so just to be clear,
21:18:10 <mojavelinux> #info there is no GWT Module
21:18:21 <mojavelinux> #info rather, we have Errai CDI
21:18:38 <mojavelinux> #info Errai CDI brings the CDI programming model to GWT, both on the client and server side
21:18:57 <mojavelinux> #info Errai is the bus that handles the event roundtripping
21:19:06 <mojavelinux> it's fast a hell
21:19:13 <lightguard_jp> Look for that change to be finalized in the next day or two
21:19:27 * rruss knew it was good to send Dan to IO with Mike ...
21:19:30 <lightguard_jp> #action lightguard_jp finish the GWT module -> Errai CDI
21:19:40 <mojavelinux> it's like Ajax Push on steroids
21:19:47 <gastaldi> haha cool
21:20:00 <gastaldi> Even better if GWT was not used
21:20:26 <mojavelinux> it's interesting that  you say that george
21:21:07 <gastaldi> Maybe Seam Remote could have something like that ?
21:21:09 <mojavelinux> because it wouldn't be too far out of the realm of possibility to reuse the infrastructure to adapt it to other frameworks
21:21:14 <mojavelinux> right, exactly
21:21:19 <rruss> cbrock: will you be able to use Errai outside of GWT?
21:21:20 <mojavelinux> perhaps Seam remoting could be changed to use Errai
21:21:36 <gastaldi> yeah, that would be awesome
21:21:37 <lightguard_jp> Seam remoting currently is a little messy
21:21:49 <mojavelinux> because a lot of the logic inside of Errai is about the mechanism of handling a streaming json respose
21:21:50 <mojavelinux> and about
21:22:04 <mojavelinux> task scheduling, work pools
21:22:05 <mojavelinux> etc
21:22:08 <lightguard_jp> Reusing Errai would be a good move, if it can be done
21:22:18 <mojavelinux> you could think of it as Node.js written in Java
21:22:24 <kenfinnigan> that would be cool
21:22:24 <gastaldi> yeah
21:22:29 <gastaldi> with CDI
21:23:10 <mojavelinux> #idea use Errai to power Seam Remoting (or other Ajax/push technology stacks)
21:23:18 <gastaldi> Who´s in charge of Seam Remoting ?
21:23:22 <mojavelinux> if you want to know why Errai and Node.js matter
21:23:25 <gastaldi> Shane ?
21:23:34 <kenfinnigan> think so yes
21:23:34 <mojavelinux> I strongly urge you to spend a few minutes and read the Node.js refcard
21:23:37 <mojavelinux> you will totally get it
21:23:49 <mojavelinux> serial request-response is dead
21:23:54 <mojavelinux> long live async requests
21:24:11 <mojavelinux> the refcard is more about the paradigm than the impl
21:24:15 <gastaldi> Richfaces could benefit from that too !
21:24:31 <sbryzak> i'd have to take a look
21:24:37 <mojavelinux> http://refcardz.dzone.com/refcardz/nodejs-building-scalability
21:24:46 <mojavelinux> shane, this idea fits well with Seam Remoting
21:24:46 <PeteRoyle> (morning!)
21:24:51 <sbryzak> there is no push in remoting currently
21:25:05 <sbryzak> it was in seam 2, but i took it out for seam 3 because i wanted to rewrite it
21:25:07 <mojavelinux> how much you can use from Errai is something I can't tell you, but certainly the technique can be used
21:25:27 <mojavelinux> but I trust Mike with this feature if we do put it back
21:25:37 <mojavelinux> because he has spent a lot of time unwrapping it
21:25:42 <sbryzak> it has a few requirements, including 1) being able to subscribe to a jms topic/queue
21:25:46 <jbossbot> git [12core] push 10master7 e31ac24.. 6Lincoln Baxter, III SEAMFORGE-200
21:25:47 <jbossbot> jira [3SEAMFORGE-200] Forge should default to built-in 'mvn' command line if Maven is not detected in the underlying system [10Open (Unresolved) Feature Request,7 Major,6 Lincoln Baxter III] https://issues.jboss.org/browse/SEAMFORGE-200
21:25:47 <jbossbot> git [12core] push 10master URL: http://github.com/forge/core/compare/555f3b4...e31ac24
21:25:50 <sbryzak> 2) receive CDI event notifications
21:25:51 <gastaldi> There is SEAMREMOTING-6 and SEAMREMOTING-7
21:25:52 <jbossbot> jira [3SEAMREMOTING-6] Comet requests for Seam Remoting [10Open (Unresolved) Feature Request,7 Major,6 Shane Bryzak] https://issues.jboss.org/browse/SEAMREMOTING-6
21:25:53 <jbossbot> jira [3SEAMREMOTING-7] Seam event bus integration for remoting [10Open (Unresolved) Feature Request,7 Major,6 Shane Bryzak] https://issues.jboss.org/browse/SEAMREMOTING-7
21:26:15 <mojavelinux> both of those are being worked on in Errai
21:26:27 <jbossbot> git [12core] push 10master7 abcc0f2.. 6Lincoln Baxter, III SEAMFORGE-200, typo
21:26:28 <jbossbot> jira [3SEAMFORGE-200] Forge should default to built-in 'mvn' command line if Maven is not detected in the underlying system [10Closed (Done) Feature Request,7 Major,6 Lincoln Baxter III] https://issues.jboss.org/browse/SEAMFORGE-200
21:26:28 <jbossbot> git [12core] push 10master URL: http://github.com/forge/core/compare/e31ac24...abcc0f2
21:26:31 <mojavelinux> so it will be interesting to see if we can reuse the bus w/o gwt...I'm guessing we can, but don't want to jump to conclusions
21:26:39 <sbryzak> does it only use json though?
21:26:57 <mojavelinux> XML should not be used, not even in Seam remoting (IMO)
21:27:05 <gastaldi> agreed
21:27:06 <sbryzak> what's the alternative?
21:27:09 <mojavelinux> json or yaml
21:27:13 <mojavelinux> yaml being the best choice
21:27:17 <mojavelinux> yaml is the choice
21:27:23 <sbryzak> json doesn't support recursive object graphs
21:27:26 <mojavelinux> though I think currently Errai uses JSON, but it's totally custom inside of Errai
21:27:33 <mojavelinux> so it could use anything
21:27:34 <sbryzak> i don't know about yaml
21:27:38 <johnament> no reusing buses
21:28:05 <mojavelinux> yaml does from what I understand
21:28:17 <sbryzak> i'm looking now
21:28:17 <mojavelinux> but again, i'm a bit on the fringe of my understanding here, still have stuff to read
21:28:26 <mojavelinux> john?
21:28:33 <mojavelinux> no reusing buses?
21:28:48 <gastaldi> sbryzak: That could be an action for next meeting, what do you think ?
21:28:59 <johnament> i don't think it will work. i was looking at it for JMS & Errai, won't work.
21:29:23 <gastaldi> Maybe Errai should be refactored then
21:29:29 <mojavelinux> ah, we'll, I was thinking along the lines of the fact that we could make changes to the project, if there were motivation to do so
21:29:39 <mojavelinux> geoge beat me to it
21:29:51 <johnament> even factoring in a refactor.
21:29:53 <sbryzak> yaml doesn't look like it supports it either
21:29:55 <johnament> conceptually it won't work.
21:30:21 <bleathem> johnament: you mean specifically the JMS tie-in?
21:30:25 <mojavelinux> oh, wait, we are talking about jms and errai, I mean whether errai can be used for other push technologies like seam remoting
21:30:34 <johnament> oh
21:30:37 <mojavelinux> right, that's seperate and likely I agree with you there that's not going to work w/o a bridge
21:30:46 * johnament shouldn't jump into the middle of an on going conversation
21:30:50 <gastaldi> :)
21:30:57 <mojavelinux> it's okay, got us thinking :)
21:31:04 <johnament> why not use the richfaces features?
21:31:17 <johnament> Seam JMS Beta2 just added specific support to support RichFaces push
21:31:18 <mojavelinux> basically, we need an alignment
21:31:20 <johnament> :-)
21:31:38 <mojavelinux> because the actually mechanism of push in errai is highly optimized
21:31:38 <lightguard_jp> mojavelinux: Do you want the action item, or should we give it to someone else?
21:32:17 <bleathem> Richfaces push is going to add support for CDI
21:32:31 <johnament> bleathem: event model?
21:32:33 <mojavelinux> I think the action item is that we need a plan for the seam remoting story with respect to errai...are we moving forward with seam remoting, trying to join them or just pushing forward w/ errai
21:32:39 <bleathem> looks like there is a lot of duplication of effort going on
21:32:44 <mojavelinux> so for shane
21:32:51 <gastaldi> yes
21:33:10 <mojavelinux> and I guess richfaces has a part of that story too
21:33:12 <bleathem> johnament: I don't know the details (yet)
21:33:13 <kenfinnigan> consolidation certainly required
21:33:18 <lightguard_jp> #action sbryzak will talk with cbrock about errai and flesh out the seam remoting / errai idea
21:33:36 <sbryzak> remoting would only use errai for push functionality
21:33:40 <lightguard_jp> #info also need to get Jay involved in this for RichFaces push
21:33:51 <sbryzak> errai is no replacement for the other features
21:33:57 <gastaldi> #agreed
21:33:58 <mojavelinux> yeah, I know
21:34:09 <johnament> sounds like we need a separate "push" feature that is view independent.
21:34:25 <mojavelinux> my hope is that's errai...because it's not just about push
21:34:32 <gastaldi> I bet Seam Remoting is the place for that
21:34:34 <mojavelinux> it's also about async requests and task pooling
21:34:45 <mojavelinux> because the requests will build up otherwise
21:34:54 <kenfinnigan> sounds like errai needs to separate GWT bits so it can be re-used elsewhere
21:35:00 <mojavelinux> errai is very optimized to handle massive # of incoming requests and not getting backlogged
21:35:04 <gastaldi> kenfinnigan: agreed
21:35:13 <mojavelinux> once you start to queue
21:35:14 <bleathem> +1 kenfinnigan, summed it up well
21:35:17 <mojavelinux> your async goes to shit
21:35:53 <mojavelinux> it's all fun and games until the pipe clogs
21:36:00 <kenfinnigan> very true
21:36:07 <lightguard_jp> Any other action items from last week we need to discuss?
21:36:14 <gastaldi> Code Review ?
21:36:19 <kenfinnigan> not that i recall
21:36:19 <lightguard_jp> gastaldi: It's coming
21:36:24 <gastaldi> ok
21:36:36 <mojavelinux> ticket bastard
21:36:38 <gastaldi> What about Forge + Seam modules ?
21:36:56 <lightguard_jp> If we have time.
21:37:04 <gastaldi> ok, let´s proceed then
21:37:10 <mojavelinux> jason and I are getting organized to revive ticket bastard, we will be making an announcement when we get it sorted
21:37:20 <gastaldi> cool
21:37:23 <johnament> ticket bastard?
21:37:26 <johnament> que es?
21:37:31 <mojavelinux> ticket monster -> ticket bastard
21:37:35 <lightguard_jp> Ticket Monster
21:37:39 <gastaldi> lol
21:37:47 <johnament> still don't get it.
21:37:50 <johnament> is that a demo app?
21:37:55 <kenfinnigan> mojavelinux: read thru the design doc, looks like some good thinking has already been done
21:38:01 <mojavelinux> yes, this is the seam booking predecessor
21:38:05 <sbryzak> ticket monster is on hold for a while
21:38:06 <johnament> ah
21:38:07 <gastaldi> https://github.com/seam/ticket-monster
21:38:20 <sbryzak> pete needs to get the infinispan/cdi integration into an infinispan release
21:38:27 <sbryzak> he said that it would happen in early july
21:38:35 <mojavelinux> can we take out infinispan for now?
21:38:38 <mojavelinux> just do JPA?
21:38:50 <johnament> what is it using in infinispan?
21:38:54 <sbryzak> i guess so.. but that was one of the big features for the demo
21:38:59 <kenfinnigan> +1 to that, could then introduce infinispan and hibernate ogm together
21:39:10 <mojavelinux> that's fine, our concern isn't for a demo at this point, it's having a new example to work on
21:39:35 <sbryzak> i fixed most of the build the other night
21:39:40 <mojavelinux> and we actually have design documents for this thing, so it makes it reasonable to keep it going
21:39:50 <mojavelinux> fantastic
21:40:01 <sbryzak> just have to pull out the seam-clouds stuff
21:40:03 <mojavelinux> can we make those design documents public?
21:40:09 <mojavelinux> cause they are useful
21:40:17 <sbryzak> i don't see why not
21:40:24 <rruss> me either
21:40:30 <mojavelinux> okay, we need an action item then
21:40:37 <jose_freitas> agreed
21:40:40 <mojavelinux> just copy paste it to the wiki, clean up some formatting
21:41:03 <mojavelinux> #action Shane will copy paste the ticket monster (bastard) design documents to the Seam wiki so more people can play
21:41:14 <mojavelinux> #action or, put them in a design.md file in the source tree
21:41:28 <mojavelinux> either way
21:41:41 <mojavelinux> feel free to reassign
21:42:17 <lightguard_jp> Okay, moving on to the next item :)
21:42:24 <lightguard_jp> I think you're all interested in this one.
21:42:32 <jose_freitas> as I understood this app is for module leads playing with other modules right?
21:42:58 <lightguard_jp> jose_freitas: Not necessarily.
21:43:15 <lightguard_jp> #topic Results of the Polls
21:43:49 <lightguard_jp> #info Community integrator was a pretty tight race
21:44:03 <lightguard_jp> #info George Gastaldi will be our next Community Integrator
21:44:14 <kenfinnigan> congrats gastaldi!
21:44:18 <gastaldi> Yay !! Finally I won an election ! :D
21:44:20 <jose_freitas> congratulations george
21:44:25 <gastaldi> Thanks !
21:44:38 <jose_freitas> to the next you can try for senator
21:44:39 <sbryzak> ticket monster doc is shared: https://docs.google.com/document/pub?id=1JIVsO90PsLIYI66mEwOWC5qZ2GxHBRWXT3oYnjBTOyQ
21:44:40 <bleathem> congrats gastaldi !
21:44:48 <sbryzak> it won't be easy to move it to seam wiki
21:44:55 <sbryzak> we'd lose all the comments, which i think are important
21:44:59 <sbryzak> plus it's full of tables/images
21:45:30 <mojavelinux> oh, okay, didn't think of making it public in google docs
21:45:34 <johnament> congrats george
21:45:39 <mojavelinux> let's just add a link to it, perhaps from the Examples Ideas page
21:46:00 <gastaldi> Thanks everyone
21:46:03 <jose_freitas> wow, it has a lot of structure already
21:46:10 <mojavelinux> congrats george!
21:46:23 <lightguard_jp> #info Forum Jedi support overwhelmingly went in favor of Jason Porter
21:46:28 <mojavelinux> and also, congrats to george and antoine for becoming officially listed on CDI 1.1, and for their participation
21:46:44 <sbryzak> bah, the published doc lost the comments anyway
21:46:47 <gastaldi> Congratulations Jason !
21:46:56 <mojavelinux> yeah, the forums finally have someone at the wheel again :)
21:46:59 <kenfinnigan> congrats jason, best man got the job
21:47:13 <gastaldi> yeah
21:47:22 <jose_freitas> now the lightguard has another reason to be a guardian
21:47:23 <jose_freitas> :=
21:47:25 <mojavelinux> I realized that I didn't set terms on them, for revote...how about we say 6 months?
21:47:28 <jose_freitas> congrats
21:47:30 <gastaldi> haha nice one jose_freitas
21:47:39 <bleathem> 6 month term sounds good
21:47:46 <lightguard_jp> 6 months sounds like a good term
21:47:46 <gastaldi> yeah
21:47:58 <gastaldi> Hope I don´t get hit by a bus :)
21:48:02 <jose_freitas> agreed
21:48:07 <lightguard_jp> #agreed revote for these positions again in 6 months
21:48:07 <mojavelinux> #action set event in calendar for next vote on community roles
21:48:17 <mojavelinux> barring a special election :)
21:48:20 <bleathem> gastaldi: now you jinxed it! watch out next time you cross the street!
21:48:23 <johnament> that also means that bleathem and lightguard_jp owe time
21:49:27 <gastaldi> :)
21:49:46 <lightguard_jp> Next item, unless others have questions
21:50:10 <mojavelinux> jason, you can add that to your sig on the forums
21:50:22 <lightguard_jp> mojavelinux: Good point
21:50:33 <lightguard_jp> #topic Code Reviews
21:50:46 <lightguard_jp> I'll let gastaldi talk about this, he brought it up
21:51:27 <gastaldi> Ok, it all happened when Antoine joined the room and wanting a code review for Seam Social
21:51:47 <gastaldi> I said that I´ll do it if he do it for Seam Reports also
21:52:05 <gastaldi> It happens that we found better design ideas
21:52:35 <gastaldi> So, I thought that this practice would apply to other modules as well
21:53:10 <mojavelinux> and in fact it has, but perhaps accidental progress, or by chance
21:53:21 <gastaldi> yeah
21:53:34 <mojavelinux> and I know that cody has piped up at a number of meetings asking for a code review, so I think in the interest of seeing seam be successful and consistent
21:53:58 <mojavelinux> we can have sort of a call for review and if you have some cycles, try to pitch in on reviewing those apis
21:54:04 <gastaldi> We could have Crucible running for code reviews
21:54:15 <mojavelinux> jboss is looking at getting that setup
21:54:15 <bleathem> that might be overkill
21:54:24 <gastaldi> bleathem: how so ?
21:54:26 <lightguard_jp> For now, GitHub works just as well
21:54:30 <kenfinnigan> crucible is cool, but wouldn't that add a lot of admin overhead?
21:54:40 <lightguard_jp> You just have to be looking at a commit to make comments
21:54:50 <mojavelinux> the only shortcoming of github is that you can only comment on commits, not just on a file in a branch
21:54:51 <bleathem> I don't think we need code review integrated into our work flow
21:54:58 <gastaldi> ah, ok. Github may do the job as well
21:54:58 <lightguard_jp> You can do line by line commenting as well in GitHub
21:55:03 <mojavelinux> right, I think if we use the develop -> master flow
21:55:04 <bleathem> doing it as "one offs" is better suited
21:55:13 <mojavelinux> then we can comment on the proposed merge
21:55:23 <mojavelinux> that also helps people know what to comment on
21:55:36 <mojavelinux> lightguard_jp this comes back to the git workflow
21:55:48 <mojavelinux> so perhaps, we need to doc how the review process fits in there
21:55:50 <mojavelinux> then this will work
21:55:54 <bleathem> I've been looking more closely at the git workflow - I like what I see
21:55:54 <kenfinnigan> do we need an action item to move all modules to git flow?
21:56:07 <mojavelinux> yes, I think we just need to do it at this point
21:56:12 <jose_freitas> what means to move them to git flow?
21:56:22 <bleathem> Seam Faces will adopt it (as soon as I find the time)
21:56:23 <jose_freitas> does it mean*
21:56:44 <mojavelinux> #action take steps to shift modules to using git flow; first step is to clarify what it is on the mailinglist
21:56:56 <bleathem> jose_freitas: see http://nvie.com/posts/a-successful-git-branching-model/
21:57:05 <lightguard_jp> bleathem: Install git flow, run git flow init you're done :)
21:57:06 <mojavelinux> there have been some follow-up posts as well
21:57:12 <kenfinnigan> was looking for that, it's got great explanation on the process
21:57:34 <bleathem> lightguard_jp: is it transaparent for other committers?
21:57:48 <lightguard_jp> It's essentially a wrapper around branching
21:57:52 <jose_freitas> thanks bleathem, you´ve pointed this link before, but I didn´t read yet. shame on me
21:57:54 <bleathem> lightguard_jp: in that they just fork patch and pull request?
21:57:54 <lightguard_jp> It's completely transparent
21:58:02 <mojavelinux> yep
21:58:05 <lightguard_jp> some extra data in .git/config
21:58:10 <bleathem> but they have to fork develop, not master right?
21:58:11 <mojavelinux> i think it actually solves some confusion with git
21:58:14 <mojavelinux> yes
21:58:30 <kenfinnigan> I agree, makes it easier to manage in my view
21:58:35 <mojavelinux> this is where I wish github would fix their forking
21:58:39 <mojavelinux> so that you can redirect your fork
21:58:48 <lightguard_jp> Set up develop as the main branch in GitHub admin for your module and it'll work just fine.
21:58:49 <kenfinnigan> follows a more natural dev process
21:58:52 <mojavelinux> it's just a matter of changing the remotees on their end
21:58:57 <bleathem> so I was wondering if master should be develop
21:59:02 <lightguard_jp> Might want to make mention of your using the workflow in the readme or description though
21:59:04 <bleathem> rather than release
21:59:18 <kenfinnigan> lightguard_jp: good call
21:59:20 <mojavelinux> ahhhh
21:59:26 <lightguard_jp> You could do that too
21:59:26 <mojavelinux> yeah
21:59:32 <mojavelinux> master release instead of develop master
21:59:46 <lightguard_jp> master is just a name
21:59:47 <bleathem> this conversation is too multi-threaded, I'm losing track of who is responding to who :P
22:00:08 <gastaldi> me too
22:00:10 <lightguard_jp> bleathem: We can talk more later about it if you have questions
22:00:10 <bleathem> lightguard_jp: but master is what contributors fork by default right?
22:00:14 <bleathem> ok
22:00:22 * bleathem shelved
22:00:28 <mojavelinux> k, we can get that started on the list
22:00:31 <jose_freitas> agree with bleathem
22:00:31 <lightguard_jp> bleathem: Just because that's the default branch GitHub gives to them, it's configurable.
22:00:39 <mojavelinux> yep, its' configurable
22:00:43 <bleathem> oh, didn't know that
22:00:44 <mojavelinux> that's how you can make develop the main branch
22:00:47 <mojavelinux> it's in the admin page
22:00:50 <kenfinnigan> bleathem: with git flow it becomes develop, which as lightguard_jp mentioned you can change in the admin of github
22:00:56 <bleathem> in other words, RTFM !!
22:00:59 <mojavelinux> hahaha
22:01:07 <bleathem> lol
22:01:47 <lightguard_jp> #action lightguard_jp will field questions about git flow after the meeting or at some other time
22:01:55 <lightguard_jp> Shall we move on?
22:02:01 <mojavelinux> yes
22:02:07 <lightguard_jp> #topic Meet bi-weekly instead of each week
22:02:18 <lightguard_jp> I've been thinking about this the last couple of meetings
22:02:18 <kenfinnigan> +1 to that idea
22:02:28 <lightguard_jp> Do we have enough stuff currently to hold a meeting each week?
22:02:40 <bleathem> seems like we go overtime each week
22:02:43 <lightguard_jp> I know when I come up with an agenda there doesn't seem to be a lot there.
22:03:03 <lightguard_jp> Only when mojavelinux is present :P
22:03:09 <mojavelinux> :(
22:03:10 <lightguard_jp> Good conversations though
22:03:13 <bleathem> I like the momentum building aspect of it
22:03:21 <PeteRoyle> So mojavelinux is banned every second week?
22:03:25 <jose_freitas> again I agree with bleathem
22:03:26 <bleathem> lol
22:03:27 <mojavelinux> hahaha
22:03:29 <jose_freitas> maybe Im a bot
22:03:31 <mojavelinux> shafted
22:03:32 <gastaldi> hahaha
22:03:45 <bleathem> lightguard_jp: I like the agendas you post, people can show up if they are interested
22:03:52 <gastaldi> bleathem: Agreed
22:03:55 <mojavelinux> we tend to spawn some really great ideas out of the meeting
22:03:57 <lightguard_jp> If the community wants to keep meeting each week, we can certainly do that
22:03:58 <bleathem> if the meetings end up short, no worries
22:04:04 <gastaldi> lightguard_jp really gives the light in here
22:04:17 <mojavelinux> yeah, let's start by trying to do the meeting in 45 minutes
22:04:32 <mojavelinux> knowing that we have one in 7 days
22:04:47 <mojavelinux> if we do it every two weeks, then we just get 1.5 hour meetings :)
22:04:56 <kenfinnigan> to that end, does the agenda need to include a proposed timetable for the meeting?
22:05:07 <lightguard_jp> kenfinnigan: Not a bad idea
22:05:08 <kenfinnigan> to make sure we stay on schedule
22:05:12 <mojavelinux> at least, that's my experience with meetings...so I think we just need to have an enforcer
22:05:27 <bleathem> a "Comunity Enforcer"?
22:05:33 <gastaldi> haha
22:05:34 <lightguard_jp> #info schedule with the agenda
22:05:38 <mojavelinux> it should be meeting bot
22:05:41 <gastaldi> I am an Integrator, don´t look at me ! :D
22:05:43 <lightguard_jp> #undo
22:05:43 <jbott> Removing item from minutes: <MeetBot.items.Info object at 0x7f08382eee90>
22:05:51 <mojavelinux> it should start cricizing any comment about a topic that has already past
22:05:51 <lightguard_jp> #idea schedule along with the agenda
22:06:16 <lightguard_jp> I like the idea, we can try it next week
22:06:20 <mojavelinux> yep
22:06:31 <bleathem> +1
22:06:33 <lightguard_jp> #agreed Create a schedule along with next week's agenda
22:06:40 <lightguard_jp> #agreed meetings will continue each week
22:06:43 <gastaldi> yeah
22:06:50 <mojavelinux> also, if you have an agenda item for a meeting, then feel free to mention at any time...you can either put it on the meeting page or just e-mail jason :)
22:06:56 <lightguard_jp> Is sending out the agenda a day before working for everyone?
22:07:09 <bleathem> yes
22:07:12 <gastaldi> Works for me
22:07:12 <mojavelinux> works for me
22:07:23 <mojavelinux> george, your mind is on my frequency
22:07:23 <jose_freitas> yes
22:07:24 <mojavelinux> hahaha
22:07:29 <gastaldi> haha
22:07:36 <lightguard_jp> Great, I'll keep doing it then.
22:07:46 <mojavelinux> and before we wrap up
22:08:19 <lightguard_jp> That's all I have for the official meeting. I know Shane has wanted to talk about the compatibility module for a while, but that probably needs it's own meeting apart from the community one
22:08:48 <sbryzak> i guess for the compatibility module jharting will need to give us an update
22:09:00 <gastaldi> To the word: jharting
22:09:15 <lightguard_jp> #topic Compatibility Module
22:09:19 <mojavelinux> I want to mention that jason and I (and also shane, he just doesn't know it yet) have been working to organize what we are doing, so that should make the project run smoother
22:09:44 <jharting> yes, so as you probaby know, I volunteered to work on the compatibility module
22:09:46 <lightguard_jp> We're certainly open to ideas as well.
22:10:00 <jharting> I am focusing primarily on bridging the Seam 2 programming model with CDI for now
22:10:15 <jharting> prototyping some stuff to see where the problem areas are
22:10:30 <jharting> not much updates at this point
22:10:50 <jharting> I started working on a wiki page to track progress / possible road blocks
22:11:03 <sbryzak> jharting: so you think it's still worthwhile to proceed with it for now?
22:11:11 <jharting> will send it to seam-dev once I have more content there
22:11:21 <gastaldi> Are we really having a compat module ? I thought that we had a migration doc
22:11:37 <bleathem> Is the migration guide an independent effort from the compatibility module?
22:11:39 <bleathem> ugh
22:11:44 <bleathem> gastaldi: you are fast on the keys!
22:11:52 <mojavelinux> if this hasn't been proposed, one idea is to have a refactoring that moves all Seam 2 classes to org.jboss.seam.classic
22:11:57 <mojavelinux> then you woudn't have a package conflict
22:11:57 <sbryzak> the migration guide will go hand in hand with the compatibility module
22:11:58 <gastaldi> :)
22:11:59 <mojavelinux> just an idea
22:12:07 <sbryzak> that's if the compatibility module goes ahead
22:12:13 <sbryzak> that's what jozef is working to determine currently
22:12:40 <kenfinnigan> like the idea of the classic package namespace to remove the clash
22:12:42 <mojavelinux> you would still have to change your code, but at least you won't have to rewrite it
22:12:57 <mojavelinux> and it would only be when you import Seam 2 types
22:13:10 <mojavelinux> internally, we would need a Seam 2 distribution that has the refactoring done
22:13:30 <mojavelinux> btw, you can provide this as an Eclipse refactoring script
22:13:37 <mojavelinux> which Eclipse has supported since like 3.0
22:13:50 <jharting> interesting
22:14:11 <mojavelinux> the steps for the end user would be
22:14:14 <mojavelinux> run the refactoring script
22:14:15 <kenfinnigan> or we could have a forge plugin to refactor
22:14:22 <mojavelinux> switch to seam-classic-* jars
22:14:28 <mojavelinux> then add compaitbility module
22:14:42 <bleathem> can we use anything from the JackPot proejct?
22:14:45 <mojavelinux> right, we can have multiple options for how to do the refactoring
22:15:12 <gastaldi> I bet on Seam Forge !
22:15:22 <gastaldi> That thing is really cool ! :D
22:15:31 <gastaldi> Another reason to use it
22:15:46 <mojavelinux> but this goes to seam forge supporting refactoring
22:15:51 <mojavelinux> which, is proposed
22:15:52 <bleathem> but Forge has to call on soemthing to do the refactoring right?
22:16:24 <gastaldi> lincoln could help us if he were here
22:16:45 <mojavelinux> my suggestion was to either use the Eclipse refacotring libraries
22:16:53 <mojavelinux> which have issues because of how they are designed (apprantely)
22:16:53 <johnament> forge is using a lot of the internal eclipse APIs, couldn't it just invoke an eclipse refactoring library that it's using?
22:17:04 <mojavelinux> or use the refactorit project, which was a plugin for different IDEs, since abandoned
22:17:06 <mojavelinux> but it was very good
22:17:20 <rruss> I thought Lincoln was leaning more towards have refactoring something provided external to Forge?
22:17:43 <bleathem> that makes the most sense I think
22:17:57 <mojavelinux> internal or external doesn't matter
22:18:01 <mojavelinux> forge has to be able to invoke it
22:18:02 <bleathem> refactoring is a well sovled problem at this point
22:18:11 <mojavelinux> naturally, we would not write a refactoring library
22:18:16 <mojavelinux> definitely not
22:18:19 <mojavelinux> it just has to be invokable
22:18:28 <mojavelinux> oops, we should probably end this meeting, seeing how we are way over
22:18:34 <mojavelinux> okay, next week, we are getting the enforcer in here
22:18:37 <mojavelinux> #endmeeting