21:04:10 <lightguard_jp> #startmeeting
21:04:19 <jbott> Meeting started Wed May 18 21:04:10 2011 UTC.  The chair is lightguard_jp. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:04:19 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:04:19 <lightguard_jp> #chair mojavelinux
21:04:23 <mojavelinux> lightguard_jp does a great job with or without me here. it's a theme of the team, people you can count on :)
21:04:28 <jbott> Current chairs: lightguard_jp mojavelinux
21:04:35 <lightguard_jp> Let's get this started, shall we?
21:05:11 <lightguard_jp> Of course, I'd like to welcome everyone here. Thanks for attending.
21:05:31 <lightguard_jp> The list of people in the channel seems to grow about every couple of weeks! Great news for Seam!
21:05:47 <lightguard_jp> #topic Good news: Brian Leathem joining Red Hat
21:05:51 <mojavelinux> +1
21:06:00 <mojavelinux> and there was much rejoicing!
21:06:06 <marekn> cool
21:06:10 <lightguard_jp> For those who have not heard via twitter or the mailing list, Brian is a Red Hatter now!
21:06:15 <jose_freitas> yay! congratulations
21:06:23 <jharting> congrats!
21:06:28 <lightguard_jp> He'll be working on RichFaces, and of course Seam Faces
21:06:32 <mojavelinux> also, i want to mention here that Brian just nailed his presentation at JUDCon
21:06:38 <bleathem> thanks guys!
21:06:43 <mojavelinux> hell, I felt like I was learning stuff about Seam Faces, and I was
21:06:51 <jose_freitas> :)
21:06:56 <lightguard_jp> Those that weren't at JUDCon missed a great conference, awesome presentations all around.
21:07:05 <jose_freitas> I'm sure I did miss
21:07:10 <bleathem> thanks Dan, I'll see if I can add some polish for the JSF summit
21:07:31 <lightguard_jp> Brian's presentation was recorded, as soon as that goes live we'll send out the URL
21:07:35 <mojavelinux> what Brian really did best was that he explained why Seam Faces was relevant to the audience, which really is the most important thing to accomplish in a talk
21:08:18 <mojavelinux> so great job. and trust in yourself, you will be able to do it again...it's like riding a bike :)
21:08:33 <lightguard_jp> With Brian coming an board, it leads us into our next topic.
21:08:37 <lightguard_jp> #topic Community Integrator
21:08:48 <lightguard_jp> #info we need a new integrator
21:08:52 <mojavelinux> want to quickly define it again to refresh memory
21:09:07 <mojavelinux> actually, we should have this on the site home page just like with the community liaison
21:09:31 <mojavelinux> can we can an action from that
21:09:39 <lightguard_jp> #info We'd like to open this up to nominations and a vote (done via Doddle or similar) so we don't just dump it on someone again :)
21:09:43 <mojavelinux> add defintion of community integrator to project site
21:09:53 <mojavelinux> I nominate George
21:09:57 <lightguard_jp> #action add the definition of community integrator to project site
21:10:10 <bleathem> I nominate John Ament
21:10:16 <lightguard_jp> Are there other nominations people would like to make?
21:10:30 <lightguard_jp> Of course neither of which are here :)
21:10:35 <mojavelinux> btw, that action is to have something like http://seamframework.org/Community/CommunityLiaison, but in many less words
21:10:46 <mojavelinux> I nominate john too :)
21:10:51 <lightguard_jp> In other words don't let Dan write it ;P
21:11:03 <mojavelinux> hahha...no, just say "this will be a tweet" then I'll get it done in 140 chars
21:11:20 <lightguard_jp> It'll be a J1 presentation abstract.
21:11:25 <lightguard_jp> That's a little more :)
21:11:56 <lightguard_jp> #info nominations for Community Integrator: George Gastaldi and John Ament
21:12:12 <lightguard_jp> #info a Doodle will be sent out to the list to place your votes
21:12:30 <lightguard_jp> #topic checkout.sh update
21:12:44 <lightguard_jp> I had some prompting from some to update the checkout.sh in build
21:13:06 <lightguard_jp> It will now, with the proper flags perform fetch, fetch -all, and pull
21:13:13 <lightguard_jp> For those who are tracking multiple modules
21:13:26 <lightguard_jp> I of course welcome any feedback from people that use it.
21:13:38 <bleathem> If it's not too late, I'd also like to nominate kenfinnigan for Community integrator
21:13:57 <lightguard_jp> Ken is Red Hat too :)
21:14:04 <mojavelinux> good call...dang it, so many good candidates :) well, that way, we are sure to get someone willing to play that role (it's a fun role, you get to merge!)
21:14:09 <lightguard_jp> But we'll put him on there.
21:14:19 <kenfinnigan> depends on your definition of RH
21:14:24 <lightguard_jp> Hehe
21:14:28 <mojavelinux> well, Ken is Amentra, so technically still community member
21:14:32 <kenfinnigan> technically yes, but not on engineering tea,
21:14:37 <kenfinnigan> *team
21:14:47 <mojavelinux> actually, i'd like to clarify some of the terms we've used before
21:15:14 * lightguard_jp wishes you could amend things in Meetbot
21:16:19 <mojavelinux> so the way that I see community is anyone who isn't a core seam dev, meaning this is what we do 9 - 5 (and plenty of hours beyond that); community means volunteer to participate essentially
21:16:23 <bleathem> lightguard_jp: don't worry, meetbot notes aren't a binding contract :P
21:17:15 <kenfinnigan> speaking of terms mojavelinux
21:17:39 <kenfinnigan> at the summit we were talking about clarifying contributor and committer on module pages
21:17:48 <kenfinnigan> to have a single term
21:18:18 <lightguard_jp> kenfinnigan: Don't jump ahead in the agenda :)
21:18:37 <kenfinnigan> sorry, was that on the agenda?! my bad
21:18:41 <mojavelinux> hahah
21:18:46 <jose_freitas> hahaha
21:18:50 <mojavelinux> yep, that's up next
21:18:55 <jose_freitas> lightguard_jp is a father indeed
21:18:59 <mojavelinux> good anticipation though
21:19:03 <lightguard_jp> Yeah, couple items down we'll talking about the module pages.
21:19:27 <kenfinnigan> ok, table that comment for the moment then
21:19:36 <lightguard_jp> Does anyone have any questions about the checkout.sh script? Usage, what it does, etc?
21:19:40 <jose_freitas> don“t eat your cookie before lunch
21:19:47 <mojavelinux> anyway, so the point of what I was getting at is that the community integrator is a non core seam dev (i.e., full time job is seam)
21:19:56 <mojavelinux> but we are on the checkout script :)
21:20:08 <bleathem> all clear on the checkout script
21:20:15 <mojavelinux> if you want to come up to speed with all modules, give the checkout script a go
21:20:20 <mojavelinux> if it fails you, report it
21:20:25 <lightguard_jp> Great. Moving along then.
21:20:29 <kenfinnigan> to be honest I think the last time I used the script was over a year ago!
21:20:34 <mojavelinux> if you like it, thank jason :)
21:20:38 <lightguard_jp> I don't think we have a JIRA for it
21:20:46 <lightguard_jp> #info if you have problems email lightguard_jp with the issue in the script
21:20:51 <mojavelinux> the point is to keep everyone up to date with developments across seam, easily
21:21:17 <mojavelinux> #info if you have a problem with the checkout.sh script, make a jira in seam
21:21:21 <lightguard_jp> #topic Seam Reports underway
21:21:30 <lightguard_jp> That works too
21:21:41 <lightguard_jp> We'll see which topic that info goes on :)
21:21:56 <lightguard_jp> George, Pete and myself have been doing some work on Reports
21:22:09 <lightguard_jp> George doing the coding and Pete and I going over some design
21:22:14 <lightguard_jp> It's really starting to come together.
21:22:23 <lightguard_jp> Probably one of the fastest modules to date!
21:22:39 <lightguard_jp> It currently supports generating reports via JasperReports
21:22:51 <mojavelinux> I'd just like to say that reports is a very important topic to me, dating all the way back to writing Seam in Action and my motivations for getting involved there
21:22:55 <lightguard_jp> With more options for BIRT and other renderings planed as well.
21:23:08 <lightguard_jp> Too bad George isn't here :(
21:23:13 <mojavelinux> basically, i've always felt Seam needed to fill this void, and it's so awesome to see it happening
21:23:28 <mojavelinux> in a lot of shops, reports is the only thing the developers spend time doing
21:23:35 <mojavelinux> and they f@#$ hate it
21:23:40 <bleathem> I was thinking about the jsf dataTable integration we brought up last week... I really think we need to address it, but perhaps as a Faces/Reports integration
21:23:49 <lightguard_jp> #link https://issues.jboss.org/browse/SEAMREPORTS jira for Reports
21:24:21 <lightguard_jp> bleathem: Still somewhat torn on that one based on previous talks we had at the start of Seam 3.
21:24:28 <lightguard_jp> We need to talk to Jay about it really.
21:24:45 <mojavelinux> yep, the question is how does it tie into RichFaces
21:24:50 <bleathem> agreed, bring it up with Jay
21:24:55 <lightguard_jp> #action talk to Jay about datatable to reporting details and ideas
21:25:01 <bleathem> I don't think RF 4 has datatable export atm
21:25:09 <mojavelinux> it's actually a really good integration point between RichFaces and Seam, so perhaps a nice research project to reach across the aisle
21:25:14 <lightguard_jp> Actually, I should give that to you Brian
21:25:21 <mojavelinux> because yes, that is another *very important* business case
21:25:26 <bleathem> will do
21:25:44 <lightguard_jp> #undo
21:25:48 <jbott> Removing item from minutes: <MeetBot.items.Action object at 0x2318950>
21:26:02 <lightguard_jp> #action bleathem will talk to Jay about the datatable integration with Seam Reports / export
21:26:19 <lightguard_jp> Hm, that output isn't very helpful :)
21:26:33 <mojavelinux> hahaha...hey, I was impressed
21:26:56 <lightguard_jp> I know where in memory the item was at though
21:27:08 <jose_freitas> that's probably an output for linus
21:27:13 <lightguard_jp> #info questions / comments about Reports or help :) go to George
21:27:44 <lightguard_jp> #topic Seam Spotlight volunteer(s)
21:27:55 <lightguard_jp> If Shane is here he can take this, but I think he's still sleeping
21:28:26 <lightguard_jp> The last spotlight, if it went up, was supposed to be from Shane, but I think he got buried in WebEx prep
21:28:40 <lightguard_jp> After that we have Dan or Stuart doing one on Seam Persistence
21:28:49 <lightguard_jp> Very much needed based on forum feedback
21:29:00 <mojavelinux> i'm going to be pretty slammed with as7 launch preperations
21:29:10 <lightguard_jp> stuartdouglas: Are you here?
21:29:14 <mojavelinux> hopefully we can convince stuart to do it :)
21:29:21 <lightguard_jp> Won't he be busy too with AS7?
21:29:53 <bleathem> maybe we need antoher module in the spotlight until AS7 is launched
21:30:06 <lightguard_jp> Volunteers?
21:30:17 <mojavelinux> well, this is a little different...because I'm going to be doing triple time work by this point
21:30:49 <lightguard_jp> tsurdilo: Are you there?
21:30:54 <mojavelinux> another candidate is lincoln since persistence is close to his heart and it plays into the forge scaffold plugin
21:30:58 <mojavelinux> or paul bakker
21:31:09 <mojavelinux> since he is training on EE 6 and forge
21:31:13 <bleathem> Is Seam Social ready for a spotlight?
21:31:18 <bleathem> it's retty "sexy"
21:31:22 <lightguard_jp> Yeah, just trying to get someone that's here that can commit to doing it.
21:31:27 <bleathem> ^pretty "sexy"
21:31:31 <bleathem> oic
21:31:36 <tsurdilo> lightguard_jp: im here
21:31:47 <lightguard_jp> tsurdilo: Is the drools / jpbm module close enough to showcase some of the features?
21:31:53 <mojavelinux> actually, tsurdilo, proctor said that we need to get together for a meeting regarding cdi support in drools
21:32:08 <mojavelinux> that's out of context here, but jason, let's make sure we take that as an action
21:32:14 <mojavelinux> how about cron for spotlight?
21:32:19 <tsurdilo> lightguard_jp: what mojavelinux said..we need to talk
21:32:24 <mojavelinux> or mail
21:32:28 <lightguard_jp> Was just thinking that
21:32:32 <PeteRoyle> Thought I felt my ears burning :)
21:32:37 <lightguard_jp> Either one would be good
21:32:55 <lightguard_jp> #action speak with tsurdilo and proctor about drools / cdi support
21:32:59 <PeteRoyle> Does mail have a release yet, because cron doesn'
21:33:04 <tsurdilo> lightguard_jp: the xml configuration needs to be the same as what we use for example for spring configuration..besides that part everything else is pretty muc hdone
21:33:20 <lightguard_jp> tsurdilo: That's right, you were saying that the other day.
21:33:35 <lightguard_jp> PeteRoyle: No, neither do, but it's just keeping the pressing going with Seam info
21:33:42 <tsurdilo> lightguard_jp: we will host the modules in droolsjbpm github
21:33:47 <lightguard_jp> s/pressing/presses/
21:33:51 <PeteRoyle> what would be the target deadline for it?
21:33:56 <lightguard_jp> tsurdilo: Got it.
21:34:00 <tsurdilo> lightguard_jp: afaik the docs will be part of drools as well
21:34:05 <lightguard_jp> PeteRoyle: Which?
21:34:10 <mojavelinux> so you can feel free to do an alpha release in conjunction with a spotlight info
21:34:14 <PeteRoyle> a spotlight
21:34:20 <tsurdilo> lightguard_jp: i will also host a module for seam2 .. its a little module that you drop in and it allows you to use all drools5 features
21:34:25 <mojavelinux> cause really it's just about buzz and getting info out there
21:34:30 <lightguard_jp> PeteRoyle: We're looking a couple of weeks out atm.
21:34:34 <PeteRoyle> ok well alpha releae is aimed at next week
21:34:38 <mojavelinux> I think mail is closer
21:34:43 <mojavelinux> oh, really?
21:34:48 <mojavelinux> cool, then cron is perfect
21:34:52 <lightguard_jp> tsurdilo: Awesome
21:34:57 <mojavelinux> pete, you can probably reuse a lot of what you had in your older blog entry (when it was scheduling)
21:35:01 <lightguard_jp> Cron will be good as people are asking about async support as well.
21:35:06 <mojavelinux> that was a good entry, needs to be resurrected
21:35:11 <PeteRoyle> ok too easy
21:35:15 <lightguard_jp> Perfect
21:35:20 <mojavelinux> and yes, a real quick mention of Async and people will be excited and onboard
21:35:24 <mojavelinux> sweeeeeeeeeeet
21:35:29 <PeteRoyle> have you seen the readme as well?
21:35:34 <lightguard_jp> #agreed PeteRoyle will write / resurrect a spotlight entry for Cron
21:35:38 <PeteRoyle> it has some asynch stuff, I wonder if that's usable?
21:35:49 <lightguard_jp> #info this will follow Security and possibly be before persistence.
21:35:54 <PeteRoyle> https://github.com/seam/cron/blob/compliance/readme.md
21:36:10 <lightguard_jp> clerum: Are you there?
21:36:45 <PeteRoyle> brb
21:36:50 <lightguard_jp> Maybe not.
21:36:54 <clerum> here
21:37:20 <lightguard_jp> clerum: Would you be willing to craft a spotlight article for Mail in three or four weeks?
21:37:35 <clerum> sure
21:37:40 <mojavelinux> as I mentioned, I think the only thing between now and a mail alpha release is a MailSender API that hides the use of Instance
21:37:45 <lightguard_jp> Great!
21:37:53 <lightguard_jp> #info clerum will create a Mail Spotlight following the rest
21:38:23 <mojavelinux> jason, do we have a document (internal or public) that lists the lineup? just so we don't lose track?
21:38:31 <lightguard_jp> We may want to take the Instance<> discussion offline, I've been thinking about it a bit.
21:38:39 <lightguard_jp> In the meeting notes.
21:38:44 <mojavelinux> yes, that's an offline discussion
21:38:51 <lightguard_jp> I've been leaving it up to Shane to handle, but he's not here right now.
21:38:55 <mojavelinux> k
21:39:11 <clerum> mojavelinux: shouldn't they just be able to @Inject MailMessage without the get instance
21:39:16 <lightguard_jp> #help we need a Google Doc for scheduling these spotlights
21:39:20 <clerum> or am I missing something
21:39:25 <mojavelinux> okay, if we want to use the meeting notes, then we need one line that has the lineup
21:39:56 <mojavelinux> let's do a forum thread or mailinglist thread about it, kind of reset
21:40:00 <bleathem> can't we just use a sfwk.org page to track the spotlights?
21:40:06 <lightguard_jp> #info current spotlight lineup: Security, Cron, Persistence (hopefully), Mail
21:40:12 <kenfinnigan> could we do something on sfwk that had previous and future, and when an article is written there is a link to it?
21:40:17 <mojavelinux> good call ken
21:40:22 <kenfinnigan> or do we not want the future ones public?
21:40:26 <bleathem> kenfinnigan: +1
21:40:31 <yendor> shane was up at 3am for the webinar
21:40:35 <bleathem> I don't think it's much of a secret
21:40:40 <mojavelinux> that way we get historical entries, so we can find them amidst gavin's 10,000 word dissertations
21:41:05 <kenfinnigan> could be linked from the getting started area
21:41:22 <lightguard_jp> #agreed we need a sfwk page for spotlights
21:41:26 <kenfinnigan> as a way for newcomers to learn about modules in a non read the ref guide way
21:41:34 <lightguard_jp> Good idea
21:41:54 <mojavelinux> and of course this will play right into the Seam Uni content, but available in the interim
21:42:06 <lightguard_jp> Right
21:42:13 <kenfinnigan> that was my thought, SU would be perfect for it, but need an interim
21:42:43 <lightguard_jp> Cool. I think we're all on the same page
21:42:53 <lightguard_jp> Now we just need to execute!
21:42:58 <mojavelinux> +1
21:43:10 <lightguard_jp> Moving on (too many topics, something may need to bump)
21:43:15 <lightguard_jp> #topic Module page updates
21:43:30 <lightguard_jp> Ken was talking about this. I'll let mojavelinux discuss as well.
21:44:03 <lightguard_jp> mojavelinux: Floor's yours for this topic
21:45:56 <bleathem> ...
21:46:06 <lightguard_jp> Maybe :)
21:46:11 <mojavelinux> we all know that flat hierarchys are good, too much structure leads to just, well, issues
21:46:22 <mojavelinux> rigtht now the module pages define too many roles, imho
21:46:29 <mojavelinux> we have lead, committer and contributor
21:46:39 <mojavelinux> I really think we need to just go to two roles, lead and contributor
21:46:53 <mojavelinux> committer doesn't really mean much in a distributed scm like git anyway
21:46:57 <kenfinnigan> +1
21:47:02 <bleathem> committer/contirbutor distinctions have kind of evaporated with github
21:47:06 <mojavelinux> and I don't like the "boys club" of committer
21:47:11 <bleathem> was more of an svn thing
21:47:15 <mojavelinux> if you contribute, you are awesome
21:47:20 <mojavelinux> and so, you become part of the module
21:47:59 <kenfinnigan> mojavelinux: as we discussed as well, if there are contributors that do a lot of work on the module, then we can move them to a co-lead
21:48:06 <mojavelinux> the committers are the leads, the core devs (though still leads should not be trumped)
21:48:22 <mojavelinux> and the community integrator to carry out work that the lead can't get to, but has approved
21:48:39 <mojavelinux> yes, co-lead is sort of the same as what perhaps a traditional "committer" would be
21:49:08 <mojavelinux> lead means that you guide the direction of that module and review the code flowing in
21:49:33 <mojavelinux> but we don't really need a lot of other distinctions, imo
21:50:09 <gastaldi> yo
21:50:13 <kenfinnigan> how does the community integrator work in terms of merging changes and knowing they have been "reviewed" by the lead?
21:50:19 <mojavelinux> because we want to be an inclusive community, not 9 layers of bureaucracy hell (like apache)
21:50:23 <mojavelinux> via a +1
21:50:28 <bleathem> kenfinnigan: I'd look for references to jira issues
21:50:36 <kenfinnigan> does the pull request need to be reviewed by the lead and a comment added
21:50:44 <kenfinnigan> before the integrator can merge?
21:50:50 <mojavelinux> that's either the lead saying "I trust your review" or the lead "I reviewed it, but can't get to it right away, so feel free to push it through immediately"
21:51:00 <kenfinnigan> ok cool
21:51:14 <mojavelinux> it's about preventing bottlenecks
21:52:06 <bleathem> next topic?
21:52:10 <mojavelinux> yep
21:52:32 <mojavelinux> oh, btw, module leads, feel free to add names of contributors to your page
21:52:36 <mojavelinux> eventually, this will be easier
21:52:41 <mojavelinux> for now, sorry it's a pain
21:52:53 <lightguard_jp> #topic Seam 3 Forums
21:52:59 <lightguard_jp> This one is close to me :)
21:53:13 <bleathem> should we list a contributor for a single commit?
21:53:46 <lightguard_jp> I spend a bunch of time each day looking through the RSS feed of the Seam 3 forums and fielding questions. I know many of you have been contacted by my to answer a question regarding your module.
21:54:20 <lightguard_jp> We really need to stay on top of these. I'm asking module leads to either subscribe to seam-forums@lists.jboss.org or the RSS feed for Seam 3 Forums
21:54:39 <yendor> bleathem: leave that decision to the lead
21:55:06 <lightguard_jp> It's really important we stay up on these questions, at least until more community people become used to using the various modules.
21:55:31 <bleathem> we should also give community members time to answer
21:55:40 <bleathem> they may get accustomed to having devs anser all the time
21:56:20 <lightguard_jp> Perhaps, but we don't have a lot of expertise in the community it yet.
21:56:41 <lightguard_jp> Some times they get answered by the community, but before they were staying unanswered for weeks before anyone responded
21:56:46 <jose_freitas> I agree with you bleathem, but I believe seam 3 don't have a big amount of experienced users yet
21:57:01 <bleathem> Fair enough, but it's something to keep in mind in the not too distant future
21:57:06 <mojavelinux> I have some background on this issue I could share
21:57:13 <lightguard_jp> mojavelinux: Please do
21:57:19 <mojavelinux> so part of the issue we are dealing with is no even about the technical content, but more about appearance
21:57:23 <mojavelinux> seam 2 got beat up pretty badly for looking mia
21:57:47 <mojavelinux> just the lack of any presence at all made it seem like the project was being ignored
21:57:55 <mojavelinux> so sometimes just saying hi in the forums goes a long way
21:58:11 <mojavelinux> second, in dealing with forums, go with a minimilistic approach (trust me, you will run out of gas otherwise)
21:59:02 <mojavelinux> you can say "please file a jira", please see this FAQ, etc, but being sincere (we obviously don't want to be like "RTFM" that never really helps anything)
21:59:14 <mojavelinux> one former colleague I had used an awesome strategy
21:59:28 <mojavelinux> any question that he thought might come up more than once, he made an FAQ out of it, then linked to that
21:59:40 <mojavelinux> then, in the future, the response was simple...the answer was centralized
21:59:44 <mojavelinux> updating it if needed
22:00:06 <kenfinnigan> I guess that method would be easier with the likes of Seam Uni
22:00:22 <mojavelinux> yes, and anytime you need something to help you be more effective, add it to the req for Seam University
22:00:27 <kenfinnigan> to make those FAQs easy to find
22:00:33 <mojavelinux> because the goal of that site is to address this very issue
22:00:48 <mojavelinux> so basically, it sucks now, but at least we can accumulate some content in the interim
22:01:15 <mojavelinux> I do think that we need to discuss the idea of having a forum moderator, perhaps not today
22:01:20 <mojavelinux> but soon
22:01:42 <mojavelinux> a moderator just makes sure that people are not abusing the forum and also can help direct people that are clearly lost
22:01:47 <lightguard_jp> #info a forum moderator may be a good idea to look into at a later date
22:01:52 <mojavelinux> all other major projects have this, like ubuntu for instance
22:02:13 <bleathem> are we moving to the JBoss community forums soon?
22:02:20 <mojavelinux> a moderator can also address the panic questions like "is seam 3 dead?" without letting them linger when obviously we are just busy elsewhere
22:02:29 <mojavelinux> yes
22:02:42 <mojavelinux> how soon I don't know yet, it's going slower than I personally would like
22:03:17 <bleathem> I nominate lightguard_jp for forum moderator!
22:03:25 <lightguard_jp> Figured that was coming
22:03:29 <lightguard_jp> lol
22:03:34 <bleathem> :D
22:03:38 <gastaldi> +1 to Jason Porter also !
22:03:43 <jose_freitas> since you mentioned seam university, faq and community, can I add a point I really miss?
22:03:55 <lightguard_jp> Sure
22:04:19 <jose_freitas> I think seam articles should spread outside the community too
22:04:33 <jose_freitas> we must write articles and publish in infoQ, TSS and etc.
22:04:38 <mojavelinux> for forum moderator, I think we need one core dev and one community member...typically it's someone who is already there most of the time and isn't really doing more work, just empowered to address fires
22:04:59 <gastaldi> A firefighter ! How so ! :)
22:05:06 <kenfinnigan> mojavelinux: like the idea of joint moderator, don't want to lay the role on a single person
22:05:25 <mojavelinux> right, like in the past, stuart was definitely acting as the moderator of the seam 2 forum
22:05:29 <lightguard_jp> jose_freitas: There's nothing stopping people adding them to dzone or infoQ or jax, etc
22:05:44 <mojavelinux> he was always around and answered questions like "is there ever going to be another release" by directing those folks to blog entries, etc
22:05:49 <stuartdouglas> that was a while ago, I must admit I have not been on there for ages
22:06:02 <stuartdouglas> morning everyone
22:06:06 <mojavelinux> right, but you inspired the idea in my mind :)
22:06:11 <mojavelinux> good morning
22:06:16 <jose_freitas> lightguard_jp: maybe you guys should encourage that
22:06:28 <mojavelinux> yes, that is the plan jose
22:06:33 <mojavelinux> for sure
22:06:49 <bleathem> jose_freitas: be sure to share with the community anything you submit, so we can upvote
22:06:59 <bleathem> we're overtime btw
22:07:03 <mojavelinux> yep
22:07:08 <mojavelinux> gotta wrap up
22:07:13 <kenfinnigan> I would also suggest that the moderator roles could be rotational, maybe someone does it for a month or two, and then someone else comes in
22:07:21 <kenfinnigan> just so the moderator doesn't get stale
22:07:41 <lightguard_jp> I like it, we should continue the discussion offline.
22:07:45 <mojavelinux> indeed...or they can be renominated, some folks actually like to hold onto the position because it suits them well
22:07:54 <mojavelinux> so we can just make sure we ask
22:08:06 <kenfinnigan> for sure, but wouldn't want to give someone the role that they have no end date on
22:08:15 <lightguard_jp> #action followup with the moderator discussion
22:08:22 <bleathem> I nominate kenfinnigan for forum moderator !
22:08:33 <bleathem> lol
22:08:42 <mojavelinux> let's do a doodle for both community integrator and moderator
22:08:54 <mojavelinux> also, i'll try to put together a definition for both
22:09:13 <kenfinnigan> I have a selective blind spot on that line, was my name mentioned ;-)
22:09:20 <lightguard_jp> #action mojavelinux will put together definitions for both community integrator and forum moderator
22:09:24 <jose_freitas> hahaha
22:09:33 <lightguard_jp> #info a doodle will be sent out for both
22:10:00 <lightguard_jp> We're running over time, and there's at least one other important topic that we need to cover
22:10:11 <lightguard_jp> Okay by all if we proceed?
22:10:17 <mojavelinux> again, thanks everyone for coming, it's awesome we have so much activity in a meeting, this really is a great group!
22:10:23 <bleathem> fine by me
22:10:31 <lightguard_jp> #topic CloudBees trial
22:10:59 <lightguard_jp> We have a CloudBees FOSS account we're using to try out. Right now it has Reports and Catch on it.
22:11:05 <kenfinnigan> cool
22:11:13 <lightguard_jp> #info get with lightguard_jp if you want your module on the cloudbees instance
22:11:17 <kenfinnigan> is that just for the hudson jobs?
22:11:30 <mojavelinux> the main motivation here is for the core devs to communicate to the community that we really hate being locked behind a vpn too and we are going to fix that
22:11:43 <lightguard_jp> Yeah, we're looking at it for hudson 1) outside of the Red Hat firewall 2) so we have a little more control
22:11:52 <mojavelinux> and it's jenkins
22:11:58 <kenfinnigan> lightguard_jp: I'd be interested in i18n being there
22:12:02 <lightguard_jp> Right
22:12:07 <lightguard_jp> Not Hudson :)
22:12:13 <lightguard_jp> Please send me an email
22:12:18 <bleathem> we can put Faces there too
22:12:22 <kenfinnigan> will do
22:12:27 <bleathem> ok
22:12:32 <bleathem> why note put all the modules there?
22:12:36 <mojavelinux> we may hit limits, so we have to sort that out first
22:12:43 <mojavelinux> hence the roll on
22:12:51 <mojavelinux> or roll out
22:12:58 <bleathem> got it
22:13:04 <mojavelinux> plus, jason is getting used to how it's setup
22:13:17 <mojavelinux> before having to reconfigure everything again
22:13:24 <lightguard_jp> Those are the main topics I had (at least without Shane being here)
22:13:34 <lightguard_jp> I need to understand how to use Jenkins better
22:13:53 <mojavelinux> yep
22:13:58 <lightguard_jp> I know there's a lot of power there, we just need to tap into it.
22:14:04 <kenfinnigan> lightguard_jp: in terms of git flow, are there plans to move solder to that dev model?
22:14:08 <mojavelinux> I think solder should be next, yes
22:14:13 <lightguard_jp> #git flow
22:14:17 <lightguard_jp> Oops
22:14:21 <mojavelinux> because it probably has the most contributors
22:14:26 <lightguard_jp> #topic git flow
22:14:30 <mojavelinux> the most diverse set of contributors that is
22:14:35 <lightguard_jp> I've been using git flow and I know a few others have as well.
22:14:48 <kenfinnigan> I've been using it a bit for i18n, works well
22:14:55 <kenfinnigan> and very intuitive
22:15:00 <lightguard_jp> It really works out nice and helps you keep branches under control, and also reminds you to branch
22:15:18 <lightguard_jp> I know I've fallen into the trap of working on master all the time.
22:15:31 <lightguard_jp> git flow really helps you remember to branch if you have features or fixes.
22:15:36 <lightguard_jp> great idea
22:15:41 <mojavelinux> great news!
22:16:22 <lightguard_jp> That's all I have, and actually have to pack up and do a Catch presentation at a JUG in an hour.
22:16:32 <bleathem> good luck with that lightguard_jp !
22:16:38 <lightguard_jp> bleathem: Thanks
22:16:52 <mojavelinux> awesome! good luck!
22:17:08 <lightguard_jp> Meeting over! Thanks everyone for showing up! Good talk this week.
22:17:12 <lightguard_jp> #endmeeting