21:00:54 <lightguard_jp> #startmeeting
21:01:01 <jbott> Meeting started Wed Apr 20 21:00:54 2011 UTC. The chair is lightguard_jp. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:01 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:19 <lightguard_jp> #chair mojavelinux
21:01:23 <jbott> Current chairs: lightguard_jp mojavelinux
21:01:39 <mojavelinux> hey everyone!
21:01:48 <mojavelinux> good to be back in the land of the sane
21:01:54 <mojavelinux> for a few days at least
21:02:06 <lightguard_jp> #meetingtopic 2011-04-20 Meeting
21:02:43 <sbryzak> morning all
21:02:47 <mojavelinux> hey shane
21:03:31 <lightguard_jp> Shall we start with our first agenda item?
21:03:50 <mojavelinux> yes, let's get moving
21:03:54 <lightguard_jp> Oh, first off, since I think this is our first meeting since the release, AWESOME JOB TO EVERYONE!!
21:03:59 <lightguard_jp> #topic Formatting change must be done by May 1st
21:04:34 <mojavelinux> some modules are already done, but now we are in a half in, half out situation, so let's just plow through and get this done
21:04:50 <lightguard_jp> #info source formatting was talked about in a previous meeting, also formatting is in the build module
21:05:23 <johnament> #agreed
21:05:27 <lightguard_jp> #info We will change modules that don't have it done by the 1st
21:05:35 <lightguard_jp> Please change your own module though :)
21:05:39 <mojavelinux> perhaps we need to identify which modules are not done...best would be to create a jira in your module
21:05:46 <mojavelinux> that way we can track when you've got it done
21:05:57 <lightguard_jp> We can do that that.
21:06:01 <mojavelinux> forge should change too
21:06:28 <lightguard_jp> Since I've been living in JIRA land for a little while, I can take that item.
21:06:46 <lightguard_jp> #action lightguard_jp Will create JIRA issues in modules that need to be converted
21:07:06 <mojavelinux> excellent, thanks
21:07:26 <lightguard_jp> Any questions about what this is or what it entails?
21:07:56 <mojavelinux> #topic New Community Integrator
21:08:08 <oranheim> mojavelinux: greetings :)
21:08:25 <mojavelinux> hey ove!
21:08:32 <johnament> is the change in code formatting, headers, both?
21:08:36 <kenfinnigan> And what does that title mean exactly?
21:08:41 <oranheim> mojavelinux: good to see you back here
21:08:53 <lightguard_jp> Looks like we moved too fast :)
21:09:03 <mojavelinux> backing up
21:09:07 <mojavelinux> #topic Formatting change must be done by May 1st
21:09:20 <oranheim> mojavelinux: you should be in Norway now! It's getting awesome here. Nice temp and it's warming up... Just like Seam!
21:09:29 <lightguard_jp> Header should be there, but I don't think it's required, the code formatting is what we're talking about here
21:09:33 <mojavelinux> the headers are less important, I'm more concerned that we need to have the formatting right so that patches are not messy, and we can actually get on people for breaking whitespace
21:09:39 <bleathem> Faces doesn't have the header
21:09:43 <mojavelinux> right now, ball is in our court
21:09:48 <mojavelinux> the headers are more "as you go"
21:09:55 <mojavelinux> but the headers should be on all java and xml files
21:10:02 <mojavelinux> asl header
21:10:26 <mojavelinux> i think it's important especially with git since it's so easy to cherry pick files
21:10:31 <lightguard_jp> If it's helpful for people we could setup a checkstyle file for this
21:10:36 <mojavelinux> we want to keep the attribution
21:10:40 <bleathem> I'll add the ASL headers back in to FAces - the old GPL headers were removed in a rush job
21:10:44 <mojavelinux> cool
21:10:48 <kenfinnigan> Does forge need to move to asl?
21:10:58 <kenfinnigan> Think it's still lgpl
21:11:03 <mojavelinux> really?
21:11:07 <lincolnthree> yes
21:11:14 <lincolnthree> forge is moving to EPL though
21:11:18 <lightguard_jp> Oops, we missed that one
21:11:22 <bleathem> yeah, I noticed that too. I thought it was intentional
21:11:27 <lincolnthree> it is intentional at the moment
21:11:35 <johnament> i believed what bleathem believed as well.
21:11:39 <mojavelinux> according the master
21:11:44 <mojavelinux> forge has no license https://github.com/seam/forge/blob/master/dist/src/main/assembly/licence.txt
21:11:57 <bleathem> forge has a license to kill :P
21:12:04 <mojavelinux> hahaha
21:12:11 <lincolnthree> in soviet russia, forge license you
21:12:15 <oranheim> hehe
21:12:23 <johnament> more like a license to ill.
21:12:30 <sbryzak> johnament: are you ok to write the next module spotlight?
21:12:50 <johnament> sbryzak: it's like 80% done, Jordan was going to give it a once over.
21:13:03 <sbryzak> johnament: great, do you think it will be ready early next week?
21:13:18 <johnament> sbryzak: i'll probably have it to Saturday morning.
21:13:23 <mojavelinux> okay, next topic
21:13:28 <mojavelinux> #topic New Community Integrator
21:13:32 <sbryzak> johnament: cool, i'll let gunnar know that he can write the next one
21:13:37 <mojavelinux> #info Jason was previously the community integrator
21:13:48 <lightguard_jp> I have since moved on
21:13:54 <lincolnthree> that was fast
21:14:04 <mojavelinux> the purpose of this job is that someone from the community has rights to merge code across modules, when the core team can't get to it
21:14:15 <mojavelinux> otherwise, things can get stuck
21:14:20 <lightguard_jp> To full developer @ Red Hat, and now wield the awesome power of admin for all projects. :)
21:14:24 <mojavelinux> jason is now admin
21:14:39 <mojavelinux> so brian is now appointed community integrator :)
21:14:51 <johnament> congrats Brian!
21:14:55 <lightguard_jp> We've appointed someone new (he doesn't know it yet)
21:15:00 <mojavelinux> #info Brian Leathem now has the role of community integrator
21:15:04 <bleathem> w00t!
21:15:08 <kenfinnigan> Congrats Brian
21:15:12 <lightguard_jp> #info bleathem is the new Community Integrator
21:15:24 <bleathem> that explains the gihub message I got earlier
21:15:37 <sbryzak> bleathem: i wouldn't be celebrating, it means more work ;p
21:15:41 <lightguard_jp> I think we need to add him in github though, don't we? Or has that been done?
21:15:46 <johnament> so this was another case of mojavelinux changing someone before telling him, right?
21:15:56 <mojavelinux> yes, you got appointed and then notified :)
21:16:02 <lightguard_jp> Dan and I both talked about it
21:16:06 <mojavelinux> we move you along fast around here
21:16:22 <lightguard_jp> I think Shane was sleeping at that time
21:16:39 <sbryzak> i'm doing a lot of that these days
21:16:43 <sbryzak> still recovering from the release
21:17:00 <lightguard_jp> Can't blame you there
21:17:27 <mojavelinux> so the point of the community integrator is two fold
21:18:05 <bleathem> So my responsibilities in this role are to perform pull requests as appropriate when someone from the core can't get to it?
21:18:09 <lightguard_jp> Put an #info in there
21:18:13 <mojavelinux> one, it's to help distribute the work of merging in patches when a module lead can't get to it, so you have the ability to help if you are available (no requirement)
21:18:18 <lightguard_jp> So it's in the notes
21:18:22 <bleathem> got it
21:18:49 <lightguard_jp> #info The Community Integrator is to help distribute the work of merging in patches when a module lead can't get to it, so you have the ability to help if you are available (no requirement)
21:18:56 <mojavelinux> and second is to make sure the community has equal voice with core devs...so a balance of "power" though I don't like that word
21:19:14 <mojavelinux> you are a branch of gov't :)
21:19:19 <lightguard_jp> #info second is to make sure the community has equal voice with core devs...so a balance of "power" though I don't like that word
21:19:39 <johnament> I'm surprised that Jason doesn't like the word.
21:19:44 <mojavelinux> I'm making this stuff up as I go along, but I wouldn't be the first :)
21:19:58 <bleathem> sweet, I'm a bureaucrat now
21:20:03 <mojavelinux> hahaha
21:20:10 <lightguard_jp> He helps keep us honest
21:20:14 <mojavelinux> you keep us honest
21:20:18 <mojavelinux> hahaha
21:20:28 <johnament> it must be redhat syndrome... repeating each other
21:20:34 <mojavelinux> you are Andreson Cooper or Bill Maher, whichever you fancy best
21:20:38 <lightguard_jp> That's anti bureaucracy :)
21:21:00 <mojavelinux> #topic SEAMXML -> SEAMCONFIG
21:21:11 <bleathem> I'll go with Rick Mercer
21:21:15 <lightguard_jp> Too bad stuart isn't here
21:21:20 <bleathem> (Canadian equivalent)
21:21:24 <mojavelinux> awesome
21:21:43 <mojavelinux> #info one of the remaining inconsistencies from the Seam Config rename was the JIRA key; can't change a JIRA key unfortunately
21:22:21 <mojavelinux> #info all issues have been migrated to the new key, so now the module is officially config all the way through
21:22:29 <mojavelinux> thanks to Jason for taking care of that
21:22:40 <lightguard_jp> We did lose the version mapping with issues, sorry
21:23:45 <mojavelinux> water over the damn, we forge ahead
21:24:00 <mojavelinux> #topic Git workflow
21:24:23 <mojavelinux> #info Jason has also migrated all projects to the official Git workflow that JBoss IT created from my original prototype workflow
21:24:37 <mojavelinux> #info you shouldn't notice any change, but it's good that we are aligned
21:24:52 <lightguard_jp> Shouldn't really affect anything from a day to day usage
21:24:56 <lightguard_jp> We still have the pull request step
21:25:00 <lightguard_jp> That's the big one.
21:25:31 <jbossbot> git [12forge] push 10master7 d739869.. 6Lincoln Baxter, III vanity
21:25:35 <jbossbot> git [12forge] push 10master URL: http://github.com/seam/forge/compare/ee1eb69...d739869
21:25:39 <mojavelinux> yes, and if you look at the low level details, it actually fixes a problem in the workflow (I can't remember what it is right now)
21:25:44 <mojavelinux> damn it lincoln, that crown is going to your head
21:25:48 <mojavelinux> hahaha
21:25:53 <lightguard_jp> lol
21:25:57 <mojavelinux> #topic JIRA hookup in GitHub
21:26:01 <mojavelinux> Jason, you want to fill in the details here
21:26:36 <lightguard_jp> I'm still toying with this to see what it gives us and what we need, but github can recognize jira tickets in commit messages
21:26:52 <lightguard_jp> It can also walk things through the workflow, but it uses the id of the next workflow step
21:27:10 <lightguard_jp> Not sure if I like that, very cryptic commit messages
21:27:26 <mojavelinux> I'd say just the link would be a huge first step
21:27:30 <lightguard_jp> like [SEAMSERVLET-32 transition: 54]
21:27:34 <jbossbot> jira [3SEAMSERVLET-32] ImplicitHttpServletObjectsProducer.getHttpServletResponse() returns null [10Resolved (Done) Bug,7 Blocker,6 Unassigned] https://issues.jboss.org/browse/SEAMSERVLET-32
21:27:39 <lightguard_jp> Wow, that was actually a ticket
21:27:57 <johnament> good thing it was already fixed too
21:28:13 <lightguard_jp> We should be good with [SEAMSERVLET-##] style though. I have it in catch, let me know if you want to try it out in your module.
21:28:32 <lightguard_jp> Pretty sure it needs to be in brackets too.
21:28:40 <lightguard_jp> Like I said, still playing around with it.
21:28:47 <bleathem> I've got SEAMFACES-## in many of my commit messages. Will this automatically link up?
21:28:55 <mojavelinux> awesome, play around we'll check back next week...actually, pilot brian too
21:29:00 <bleathem> or do I have to do something to get that?
21:29:06 <mojavelinux> because he will fix about a trillion bugs before next week :)
21:29:13 <lightguard_jp> #info contact lightguard_jp if you want JIRA issue resolution in your github module
21:29:17 <bleathem> lol
21:29:25 <lightguard_jp> Okay
21:29:36 <bleathem> lightguard_jp: "I want JIRA issue resolution in your github module"
21:29:40 <mojavelinux> we have a JIRA for our national debt and global climate change, do you have a fix for those?
21:29:45 <lightguard_jp> #action lightguard_jp will add the JIRA integration to Seam Faces
21:29:49 <bleathem> ^in my
21:29:56 <mojavelinux> our gov't needs JIRA
21:30:03 <johnament> lightguard_jp: "I want JIRA issue resolution in my github modules"
21:30:14 <lightguard_jp> #info we also now have commit emails going to those who commit to the projects
21:30:22 <mojavelinux> oh, that's right, expand on that
21:30:35 <lightguard_jp> May need to tweak that python code a bit still, but now when you push a contribution they'll get an email saying it was added.
21:30:49 <mojavelinux> DEBT-59: We are giving wall street too many bailouts
21:31:02 <lightguard_jp> #action lightguard_jp will add JIRA integration to Seam JMS
21:31:09 <mojavelinux> and how is that hooked up (the thank you e-mail)?
21:31:14 <mojavelinux> (leading question)
21:31:34 <lincolnthree> yeah, i just got one of those
21:31:38 <lightguard_jp> It's done via a post-commit web hook setup in the admin of the repo
21:31:51 <lightguard_jp> Like I said, may need to play with that a bit :)
21:32:02 <mojavelinux> an app we currently host on GAE and written by Manik
21:32:06 <johnament> lightguard_jp: what about Seam JCR?
21:32:10 <lightguard_jp> The old program (Python GAE) I don't think worked
21:32:15 <lightguard_jp> Had to tweak it last night / this morning
21:32:20 <mojavelinux> but it will be rewritten by Jason by the time it's all done...and why it is in python, only Manik knows
21:32:25 <mojavelinux> see
21:32:30 <lightguard_jp> #action lightguard_jp will add JIRA integration to Seam JCR
21:32:34 <johnament> thank you :-)
21:32:45 <lightguard_jp> It's either Python or Java to run on GAE
21:32:59 <lightguard_jp> Probably easier in python anyway :)
21:33:05 <mojavelinux> and python is the obvious choice for a company that uses about 99% java
21:33:13 <mojavelinux> hehehe
21:33:19 <lightguard_jp> JBoss or Red Hat ;) ?
21:33:24 <mojavelinux> jboss
21:33:28 <mojavelinux> 1% is ruby
21:33:32 <mojavelinux> torquebox
21:33:37 <mojavelinux> hahaha
21:33:41 <johnament> mojavelinux: it's probably a jython instance on top of the fake JVM running
21:33:45 <lightguard_jp> And the next version of bots will be in Ruby if I have my say :)
21:33:52 <mojavelinux> that's fine, just no python
21:34:08 <mojavelinux> it strangles me
21:34:18 <lightguard_jp> If we could get access to a server we could do it in whatever we want :)
21:34:23 <lightguard_jp> It just needs to have a URL to hit
21:34:41 <mojavelinux> yes, that's the next step...we just needed a short term fix because we aren't handing out any credits right now
21:34:45 <lightguard_jp> Something we need to take up with Red Hat
21:34:50 <mojavelinux> and pete thanks everyone for faces commits
21:34:54 <mojavelinux> since it was still running on his instance
21:35:07 <mojavelinux> so now it will come from the module lead, right?
21:35:25 <lightguard_jp> It comes from seamdev@gmail.com I believe
21:35:34 <lightguard_jp> It's setup to only come from one email
21:35:43 <mojavelinux> ah, I know
21:35:51 <lightguard_jp> A future version could be expanded to come from the module lead
21:35:56 <mojavelinux> make it come from seam-commits-owner@lists.jboss.org
21:36:22 <lightguard_jp> #action lightguard_jp change the email from in the commit emails to seam-commits-owner@lists.jboss.org
21:36:41 <lightguard_jp> I'm getting bombarded with the action items, good thing they're small
21:36:57 <mojavelinux> you're doing awesome ;)
21:37:14 <lightguard_jp> We should probably move on to the two big agenda items
21:37:20 <lightguard_jp> While we still have 20 min left
21:37:24 <mojavelinux> while on this topic, jason is going to be working on consolidating irc logs and bots at jboss...a longer term project, but it's going to be awesome
21:37:32 <mojavelinux> okay, last two items
21:37:40 <mojavelinux> #topic Development Methodology for Seam
21:38:06 <mojavelinux> I bring this up after having a conversation with someone respectable at 33rd degree (and agile expert)
21:38:25 <mojavelinux> anyway, we were talking and I realized that someone I was assuming that open source projects don't need a dev methodology
21:38:30 <mojavelinux> we just code like wild west
21:38:38 <mojavelinux> which has been great, but I don't think it's sustainable
21:38:46 <mojavelinux> we've had some attempt at a methodology
21:38:50 <mojavelinux> it's called slide-driven planning
21:39:00 <mojavelinux> someone presents a schedule on a slide at a conference that no one has ever seen
21:39:09 <mojavelinux> then we have to stick to that because we made a stupid promise
21:39:21 * bleathem guilty
21:39:26 <mojavelinux> so we need to kill that approach and pick something sustainable
21:39:30 <bleathem> well, inversely guilty
21:39:35 <kenfinnigan> Sounds good
21:39:39 <mojavelinux> you were the victim
21:39:54 <johnament> bleathem: i have to say, faces has been taking a beating on the forums.
21:40:05 <bleathem> :(
21:40:21 <bleathem> I went through a bunch of forum posts last night, will do sao again tonight
21:40:47 <bleathem> People are looking for a Seam 2 migration guide
21:40:54 <lightguard_jp> Yep
21:40:58 <bleathem> What's the plan there?
21:41:02 <mojavelinux> I don't really have a suggestion here...
21:41:06 <lightguard_jp> Another loose end for us
21:41:11 <mojavelinux> oh, migration guide, well, yes, just like jason said
21:41:15 <mojavelinux> another "maybe it will happen by magic"
21:41:27 <johnament> on that topic
21:41:33 <lightguard_jp> You mean "maybe someone in the community will do it for us" ?
21:41:37 <johnament> i have an app at work, trying to port it.
21:41:42 <bleathem> Seems like something we could recruit community memebers to do, if thery were given a sandbox to work in
21:41:46 <kenfinnigan> Kind of needs someone to migrate an app like wiki example and doc changes
21:41:50 <bleathem> and an outline to build on
21:41:54 <johnament> at least on the faces side + persistence, I can probably provide something
21:42:11 <lightguard_jp> A big part of this is the Seam2/CDI compat
21:42:16 <lightguard_jp> Which isn't there.
21:42:22 <bleathem> I don't have any Seam 2 experience, so I can't help out much in this regard
21:42:30 <mojavelinux> i think the first step is, where do we start aggregating notes
21:42:36 <lightguard_jp> If they had that then they can still use Seam 2 but use CDI and migrate the stuff slowly.
21:42:43 <bleathem> Do we need a topic for this?
21:42:50 <mojavelinux> we have a wiki page, but is that okay with everyone? or should we make it simpler
21:43:05 <mojavelinux> #topic seam 2 migration guide, how can we get it off the ground
21:43:17 <sbryzak> we need a volunteer to work on the compatibility module
21:43:44 * bleathem *crickets*
21:43:49 <lightguard_jp> I can help out, but not until after JUDCon
21:43:53 <mojavelinux> fortunately, rick hightower did part of the work already
21:43:57 <mojavelinux> in a sense
21:44:03 <lightguard_jp> with the spring integration ?
21:44:08 <sbryzak> it will be a two part process
21:44:12 <mojavelinux> because he integrated cdi and spring...which is going to be pretty similar to how we do it with seam 2
21:44:16 <johnament> I think the easiest starting point is how to convert those 100+ *.page.xml and pages.xml that are sitting in every project into view config
21:44:20 <lightguard_jp> Yeah, we could piggy back some of that
21:44:24 <sbryzak> marek will have to work on the seam 2 side of it
21:44:33 <mojavelinux> ah, so we need a forge plugin
21:44:37 <johnament> mojavelinux: have you tried it? when i tested it on sunday it barely works.
21:44:41 <sbryzak> we don't have to convert pages.xml
21:44:45 <mojavelinux> to convert pages.xml into view config types
21:44:50 <bleathem> View config is missing some of the pages.xml functionality still
21:44:54 <mojavelinux> that would be a good plugin actually
21:44:58 <johnament> mojavelinux: i was thinking that too
21:45:06 <sbryzak> as seam 2 will be running inside the container
21:45:28 <mojavelinux> it's really a question of whether we are helping them migrate or helping them stay
21:45:36 <mojavelinux> if they migrate, they don't need the bridge
21:45:42 <mojavelinux> so part of the guide is just about pure migration
21:45:46 <bleathem> A "migration guide" is seperate from a "compatibility module" though
21:45:50 <sbryzak> we need to do two things
21:45:54 <mojavelinux> get off seam 2 in favor of seam 3/cdi
21:45:59 <mojavelinux> that's one path
21:46:03 <sbryzak> 1) provide the bridge so that they can run their seam 2 app inside a cdi container
21:46:07 <mojavelinux> yes, what bleathem said
21:46:20 <sbryzak> 2) provide a migration guide, so that they can slowly migrate their seam 2 components to cdi
21:46:32 <mojavelinux> I would say #2 may also be a cold turkey switch
21:46:44 <sbryzak> the migration guide isn't going to be difficult
21:46:48 <mojavelinux> meaning, same text, some people just might do it more dramatically
21:46:54 <sbryzak> it's #1 that's more work to implement
21:47:18 <bleathem> #2 is tough though, because some stuff isn't supported yet
21:47:22 <mojavelinux> well, the migration guide is going to take a long time to get right, and it will be more about collective input
21:47:27 <sbryzak> i get the impression from the forums that some people do want to go cold turkey
21:47:31 <lightguard_jp> Is #1 what people are asking for, or do they want #2?
21:47:35 <mojavelinux> because it's not just "this is this", it has to be partially story driven
21:47:40 <sbryzak> we really need to start working on #1 though
21:48:02 <sbryzak> seam 2.4 is planned to be the last maintenance release for seam 2.x
21:48:06 <mojavelinux> we need to move forward with both in parallel
21:48:15 <sbryzak> it is supposed to contain the compatibility features
21:48:36 <sbryzak> we don't need to worry about implementing that, although we will have to work with marek to get it done
21:48:43 <kenfinnigan> So 2.4 is meant to be CDI runnable?
21:48:52 <sbryzak> kenfinnigan: that's the plan
21:49:05 <sbryzak> after that's released, no more seam 2
21:49:17 <sbryzak> as we will have provided a complete migration strategy for seam 2 apps
21:49:42 <mojavelinux> so we need to decide who will lead the compat module...I think it should be Marek
21:49:56 <sbryzak> mojavelinux: i tend to agree
21:50:10 <sbryzak> i'll chat with him tonight and propose it to him
21:50:20 <mojavelinux> I think the guide needs to be a collective ownership that starts as a wiki page, and then you (shane), jason and I can reify it
21:50:24 <sbryzak> and perhaps jason can take care of the seam 3 side of things
21:50:38 <sbryzak> i think the guide needs to be a chapter in the documentation
21:50:49 <sbryzak> however yes, it can start as a wiki page
21:51:00 <mojavelinux> i'll put a call to action on that
21:51:17 <lightguard_jp> Our documentation needs some refining in general
21:51:21 <mojavelinux> if we only had a wiki that would let us edit at the same time (like google docs)
21:51:30 <mojavelinux> last topic
21:51:44 <mojavelinux> oh, before that, one more topic
21:51:48 <mojavelinux> #topic forge plugins
21:52:01 <mojavelinux> some of you have begun writing forge plugins, way to be!
21:52:13 * lightguard_jp still needs to write his
21:52:17 <lincolnthree> I'd just like to get a sense of who's given it a shot, and what we have so far
21:52:27 <lincolnthree> What issues people are running in to
21:52:40 <mojavelinux> problems? feel free to catch up with lincoln after the meeting
21:52:46 <mojavelinux> :)
21:52:53 <lincolnthree> yep, and remember to join forge-dev
21:53:05 <lincolnthree> https://lists.jboss.org/mailman/listinfo/forge-dev
21:53:17 <mojavelinux> there is a newly forged arquillian plugin in the wild, so you can check that out for ideas too
21:53:26 <mojavelinux> lincoln, is there a directory yet?
21:53:38 <johnament_> i just missed the last 90 seconds, as I accidently changed my runmode.
21:54:07 <mojavelinux> remember to join forge-dev https://lists.jboss.org/mailman/listinfo/forge-dev is what you missed
21:54:13 <bleathem> johnament_ we decided there was no longer a need for Seam JMS while you were gone
21:54:18 <mojavelinux> lincoln wants to know if you have any problems
21:54:22 <mojavelinux> hahaha
21:54:32 <johnament_> so forge is not seam?
21:55:01 <mojavelinux> forge's facebook page says "it's complicated"
21:55:18 <lincolnthree> mojavelinux: no directory yet
21:55:22 <lincolnthree> but
21:55:26 <lincolnthree> we have a repo
21:55:36 <lincolnthree> and an organization
21:55:40 <lincolnthree> https://github.com/forge
21:55:44 <bleathem> I see it as: Forge is more than Seam
21:55:48 <mojavelinux> right, I was just thinking that the devs can see what else people are doing without hunting for it
21:55:53 <bleathem> Forge will do Seam, but will eventually do much more
21:55:57 <mojavelinux> seam is our brand
21:56:02 <johnament_> forge needs an x-men emblem on its tights :/
21:56:06 <mojavelinux> seam modules are one project
21:56:10 <mojavelinux> seam forge is another
21:56:48 <mojavelinux> that's how it is today, tomorrow, it could be different ;) hehehe
21:56:52 <mojavelinux> okay, parties
21:56:58 <mojavelinux> #topic JUDCon meetup(s)
21:57:07 <johnament> so bleathem and I are bunking up sunday
21:57:11 <mojavelinux> if you are in town for JUDCon
21:57:15 <mojavelinux> http://community.jboss.org/wiki/BostonJBossUserGroup-LetsGetReadyToRumble2
21:57:19 <bleathem> Thanks for that johnament !
21:57:24 <mojavelinux> that's the kickoff dinner
21:57:35 <mojavelinux> Sunday night, at John Howards (that's a tavern, not a person's house)
21:57:47 <mojavelinux> you have to be specific about these things, I hate when I think I'm going to a tavern and end up at a house
21:57:51 <mojavelinux> houses don't have taps
21:57:58 <bleathem> Sweet, I get to Boston at 5:30 pm. I might actually make it to the event!
21:58:12 <johnament> mojavelinux: some houses have taps
21:58:26 <mojavelinux> hehehe
21:58:45 <mojavelinux> at 7:30 on Monday night is the community asylum live broadcast
21:59:01 <mojavelinux> we'll all go in that room, afterwards is the hackfest
21:59:07 <mojavelinux> however, based on how this has worked in the past
21:59:13 <johnament_> grrr
21:59:17 <lincolnthree> Forge will be representing at HackFest
21:59:21 <lincolnthree> PS. There is beer at hackfest this year. Confirmed!
21:59:26 <mojavelinux> the end of the asylum they say "let's go to the bar" and then hackfest gets ditched
21:59:30 <lincolnthree> No.
21:59:34 <lincolnthree> This time we learned from our mistakes.
21:59:39 <mojavelinux> so, we are staying at hackfest this year
21:59:43 <johnament_> that's what happened last year?
22:00:09 <lincolnthree> johnament_ everyone left..
22:00:14 <bleathem> johnament_: the hackfest was dry
22:00:19 <mojavelinux> yep
22:00:23 <johnament_> ahhh
22:00:28 <lincolnthree> they left in search of beer
22:00:32 <mojavelinux> it was dry even no water
22:00:36 <johnament_> this is my first judcon
22:00:41 <mojavelinux> it was really dry
22:00:45 <bleathem> mine too, but that story has been told around many a campfire
22:00:50 <johnament_> so what is being hacked on?
22:00:55 <mojavelinux> but arquillian guys stayed and hacked
22:01:00 <bleathem> Forge hackfest!
22:01:04 <lincolnthree> hey
22:01:09 <mojavelinux> forge plugins for one
22:01:13 <lincolnthree> mojavelinux: I hacked on the first version forge javaparser!
22:01:22 <mojavelinux> I remember, you were very excited
22:01:26 <lincolnthree> you guys were writing containers
22:01:30 <lincolnthree> I'm always excited...
22:01:35 <mojavelinux> we were excited that we got the tomcat container working
22:01:39 <mojavelinux> hahah
22:01:44 <bleathem> how fare you've all come!
22:01:49 <bleathem> ^far
22:01:53 <mojavelinux> bring something you want feedback on
22:02:28 <mojavelinux> so the one thing to decide is, when should we have a seam community meetup...perhaps not just the hackfest, don't want to double book
22:02:54 <mojavelinux> I'd say either post-hackfest ~10:30PM or so
22:02:58 <johnament_> I have to leave Tuesday at ~2pm
22:03:02 <mojavelinux> or Tuesday night ~9:00PM
22:03:32 <lightguard_jp> AFAIK the only thing going on Tuesday night is the Summit / World Keynote
22:03:48 <bleathem> What's the agenda for the seam community meetup?
22:03:58 <lightguard_jp> Good question
22:04:02 <lightguard_jp> I'll let Dan field that one
22:04:14 <mojavelinux> so my idea for the meetup is to get to know each other in person, and to brainstorm at a higher level
22:04:21 <mojavelinux> hackfest is actual code
22:04:26 <bleathem> We need some kind of strategy planning moving forward from 3.0.0.Final
22:04:54 <kenfinnigan> Good idea. Feeding into the idea of more strategic planning
22:05:02 <mojavelinux> exactly, bring your smartphones and we jot down some notes, but we just need to open up the floor, yes strategy
22:05:22 <lightguard_jp> Good time to plan the development methodology.
22:05:26 <mojavelinux> we can talk about techs to get into, how to challenge competitors and how to be more relevant to app devs
22:05:31 <mojavelinux> yes, good idea
22:05:35 * bleathem I'll bring a pencil and paper
22:05:42 <lightguard_jp> Start adding #ideas
22:05:47 <johnament_> canadian smart phones don't work in the US :/
22:05:59 * bleathem proud owner of a motorolla flip phone - dumb as it gets
22:06:04 <mojavelinux> just need the notepad feature
22:06:09 <lightguard_jp> #idea Good time to plan the development methodology.
22:06:17 <mojavelinux> you'll own an android by the time you leave ;)
22:06:23 <lightguard_jp> #idea we can talk about techs to get into, how to challenge competitors and how to be more relevant to app devs
22:06:28 <bleathem> #agreed Good time to plan the development methodology.
22:06:36 <bleathem> lol
22:06:42 <lightguard_jp> bleathem: won't work for you, not a chair
22:06:46 <bleathem> oh
22:06:50 <bleathem> well, I still agree
22:06:55 <mojavelinux> so either monday night or tuesday night...probably monday night is best, we can also do a follow-up on tuesday night
22:07:00 <mojavelinux> #agreed Good time to plan the development methodology.
22:07:04 <mojavelinux> there
22:07:12 <johnament_> #agreed Monday night is best
22:07:16 <lightguard_jp> agreed for monday?
22:07:20 <bleathem> Faces is in need of some serious strategy, and sizing up against CODI
22:07:37 <mojavelinux> exactly...so we hack for ~ 2.5 hours, then we go and get some eats and meetup
22:07:48 <bleathem> I'm curious - How many other modules have direct competition?
22:07:52 <mojavelinux> i'll make sure we find a place that has late night food, because we'll be starved
22:08:00 <lightguard_jp> #agreed Community meeting Monday night after hackfest
22:08:05 <mojavelinux> i'd say all of them, if you consider spring
22:08:09 <mojavelinux> like spring social
22:08:13 <bleathem> true
22:08:21 <bleathem> but who considers spring :P
22:08:40 <mojavelinux> bankers
22:08:45 <mojavelinux> hehehe
22:08:49 <bleathem> lol
22:09:10 <mojavelinux> excellent, good meeting, looking forward to judcon
22:09:31 <mojavelinux> feel free to pass around your presentations for review
22:09:36 <lightguard_jp> All done? Anyone have any last minute things?
22:09:40 <bleathem> #agreed Looking forward to JUDCon
22:09:48 <lightguard_jp> #endmeeting