21:06:01 <lightguard_jp> #startmeeting
21:06:09 <jbott> Meeting started Wed Mar 23 21:06:01 2011 UTC.  The chair is lightguard_jp. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:06:09 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:06:15 <lightguard_jp> #chair mojavelinux
21:06:19 <jbott> Current chairs: lightguard_jp mojavelinux
21:06:44 <mojavelinux> #topic announcements
21:08:25 <mojavelinux> #info Jordan is enjoying his new job, but it's requiring a lot of his time, so he said he can't realistically lead the JMS module in the near term
21:09:49 <mojavelinux> #info john ament has volunteered to be the JMS module lead; he has been working with Jordan recently and also got a strong recommendation from Jordan
21:10:33 <gmorling> He is the lead already according to http://seamframework.org/Seam3/JMSModule :-)
21:11:00 <mojavelinux> yep, I updated it before he even accepted ;) i was optimistic :)
21:11:09 <gmorling> hehe
21:11:46 <johnament> yes you were.
21:11:59 <mojavelinux> with that said, we are looking for people interested to help john out, since module lead doesn't mean do all the work...in fact, the best thing a lead can do is build up a little army for yourself :)
21:12:36 <gmorling> sounds interesting, what's on the agenda for Seam JMS?
21:12:41 <mojavelinux> #info we are looking for contributors to Seam JMS
21:12:45 <mojavelinux> #info Seam JMS should have a new release soon
21:13:15 <mojavelinux> #link Seam JMS  http://seamframework.org/Seam3/JMSModule
21:14:03 <mojavelinux> john, to answer a question you asked a while back, no we don't have to support MDB in Seam JMS if it's causing a road block
21:14:16 <mojavelinux> we really just want
21:14:23 <mojavelinux> 1) make jms easier to use and configure
21:14:27 <mojavelinux> 2) bridge jms events
21:14:35 <mojavelinux> mdb is more of a pain in everyone's side imho
21:14:46 <johnament> #info the next release is expected to be 3.0.0.Beta1
21:15:10 <mojavelinux> mdb is a means to an end, an end people would be happy to get to another way
21:15:28 <mojavelinux> #link http://seamframework.org/Seam3/JMSModule Seam JMS  module
21:15:37 <mojavelinux> i had the wrong syntax
21:15:42 <johnament> #info Beta1 will come after 3.0.0.Final for the main Seam modules
21:15:50 <mojavelinux> sounds good...since that is only days away ;)
21:16:18 <mojavelinux> #info Seam 3.0.0.Final is schedule before the end of the month, though QE is going to push back if we don't have issues resolved
21:17:15 <mojavelinux> we are currently facing some problems with seam security due to what appears to be another glassfish visibility issue, but we can't reproduce in a testing environment
21:17:22 <mojavelinux> SEAMSECURITY-42 tells the saga
21:17:26 <jbossbot> jira [3SEAMSECURITY-42] NPE when attempting to login [10Reopened (Unresolved) Bug,7 Major,6 Shane Bryzak] https://issues.jboss.org/browse/SEAMSECURITY-42
21:18:03 <mojavelinux> #info we are currently facing some problems with seam security due to what appears to be another glassfish visibility issue, but we can't reproduce in a testing environment; see SEAMSECURITY-42
21:18:07 <jbossbot> jira [3SEAMSECURITY-42] NPE when attempting to login [10Reopened (Unresolved) Bug,7 Major,6 Shane Bryzak] https://issues.jboss.org/browse/SEAMSECURITY-42
21:18:11 <mojavelinux> sorry for the double post there
21:18:38 <mojavelinux> #info snapshots of weld osgi bundles are now published to the jboss snapshots repository
21:19:58 <mojavelinux> #link https://repository.jboss.org/nexus/content/repositories/snapshots/org/jboss/weld/weld-osgi-bundle/ Weld OSGi bundle snapshots
21:20:11 <jharting> mojavelinux: what's the target for Seam 3 Final? Is it ok to target GF 3.1 + updated Weld or are we going to hack around vanilla GF 3.1 anyway?
21:20:24 <mojavelinux> very good question
21:20:46 <mojavelinux> I want a Weld 1.1.1 release, period
21:20:50 <mojavelinux> and I want it now
21:21:07 <gmorling> the question is when this would be available in GF
21:21:17 <mojavelinux> actually, that doesn't matter so much
21:21:26 <lightguard_jp> A weld 1.1.1 has to be in GF 3.1.1 (hopefully they do one)
21:21:31 <mojavelinux> what's important is that the code is fixed
21:21:42 <mojavelinux> because it takes 2 seconds to drop it into an existing glassfish installation
21:21:48 <lightguard_jp> And better integration code :(
21:21:53 <mojavelinux> however, we can't link to a snapshot reasonably, because it could change any day
21:22:10 <mojavelinux> the current snapshot works
21:22:16 <mojavelinux> so I say, cut the damn thing
21:22:20 <gmorling> ok. if it is that easy then its good. I know updating Hibernate Validator is nearly impossible
21:22:30 <mojavelinux> yep, the instructions are on brian's blog
21:22:34 <mojavelinux> but they can be repeated in one line
21:22:49 <mojavelinux> copy weld-ogi-bundle.jar to glassfish/modules/weld-osgi-bundle.jar and restart glassfish
21:22:53 <mojavelinux> you are now upgraded
21:22:57 <mojavelinux> of course, that assumes no api changes
21:23:01 <mojavelinux> atm, there are none
21:23:05 <mojavelinux> so, it works
21:23:14 <gmorling> I'm just wondering how many people get this by their ops
21:23:36 <mojavelinux> if we can get a weld 1.1.1 release, then we don't have to worry about the glassfish 3.1 out of the box, we just say "upgrade" is a requirement
21:23:51 <mojavelinux> well, the thing is, to us, it doesn't matter
21:23:57 <mojavelinux> because glassfish 3.1 is not compliant, period
21:24:04 <bleathem> Not many poeple are going to run Seam 3 apps in production yet... at least not those who have problematic ops
21:24:08 <mojavelinux> so, we say, we target a compliant environment
21:24:13 <mojavelinux> however, we can't say that, if there is no migration path
21:24:25 <mojavelinux> and the fault is mostly in Weld
21:24:29 <mojavelinux> which makes it doubly bad
21:24:35 <mojavelinux> so, we need a release of Weld
21:25:02 <gmorling> I just would like to avoid Seam being blamed although we cant do anything about the problems
21:25:15 <kenfinnigan> Do we need to support as6 running with weld trunk?
21:25:19 <mojavelinux> #agreed Seam 3 can target Weld 1.1.1 instead of working around problems in vanilla GlassFish 3.1 if Weld 1.1.1 is released soon
21:25:41 <gmorling> for when is Weld 1.1.1 expected?
21:26:05 <mojavelinux> that's the problem, I don't know, and although I've requested a release, it doesn't seem to be making any difference
21:27:13 <mojavelinux> we would have to then support AS 6 with Weld 1.1.1 too, but I don't anticipate any problems there
21:27:17 <bleathem> I'll follow up with my post to weld-dev, to rattle the cage
21:27:33 <mojavelinux> I'm hoping shane can throw some weigh around here
21:28:16 <mojavelinux> Weld 1.1.1 does not currently solve all problems, though, but it is a much better situation
21:28:33 <mojavelinux> solve all glassfish problems that is
21:29:02 <gmorling> How bad is the problem anyways (I was not too much involved)? Is it imaginable to release Seam 3 without Weld 1.1.1 or is this a deal breaker?
21:29:36 <bleathem> Faces will not run on Vanilla Glassfish 3.1
21:29:47 <bleathem> Weld 1.1.1-SNAPSHOT is required
21:29:55 <mojavelinux> I thought it did
21:30:05 <mojavelinux> i'm pretty sure it does
21:30:12 <bleathem> Sorry, over stated
21:30:17 <mojavelinux> here's the situation
21:30:22 <bleathem> anything interesting doesn't
21:30:26 <mojavelinux> we fixed deployment problems on vanilla glassfish
21:30:36 <mojavelinux> meaning, adding seam jars won't break your deployment
21:30:54 <mojavelinux> however, several features in solder (and thus other features in seam) just don't work
21:31:20 <mojavelinux> except for the security issue, all features do work (from what we can tell) with the weld snapshot
21:31:24 <bleathem> Sorry, I forgot you made changes to the Seam jars, moreso than just the Weld fixes.
21:31:38 <mojavelinux> yeah, we hacked around shit in Seam to make it work
21:31:42 <bleathem> retract my statement from the record :P
21:32:07 <mojavelinux> I want to pull out those hacks as soon as we get people off of the vanilla glassfish 3.1 (either via a weld upgrade or glassfish 3.1.1)
21:32:31 <mojavelinux> so, it's not a show stopper, but it's not pleasant either
21:32:40 <mojavelinux> let's put it this way
21:32:44 <mojavelinux> booking works
21:32:48 <mojavelinux> on glassfish
21:32:52 <mojavelinux> vanilla glassfish
21:32:56 <mojavelinux> that's about all we can guarnatee
21:33:34 <mojavelinux> because the visibility issues are not really apparent until you hit them
21:34:03 <mojavelinux> without a full review of the seam codebase for potential problems...problems mind you, that should even be problems
21:34:12 <gmorling> hmm, ok. all in all this sounds to me that we should wait for Weld 1.1.1 Final before going Final with Seam 3. We can't really tell people to use a snapshot version to get certain things working imo
21:34:42 <mojavelinux> right, and I think Weld 1.1.1 could easily be released before the end of the week, if someone actually commits to it
21:34:50 <mojavelinux> so that's the message we need to take to the Weld team
21:35:03 <gmorling> agree
21:35:07 <mojavelinux> solid
21:35:27 <mojavelinux> #agreed Seam 3.0.0.Final will be much better off if a Weld 1.1.1 release could happen first
21:35:38 <stuartdouglas> AFAIK only Pete and Ales have permission to do the release process
21:35:55 <mojavelinux> yep, i know
21:37:54 <mojavelinux> btw, I apologize if I sound a little irritated about this issue...it's taken an enormous amount of time and patience to work around something that isn't even a problem in Seam
21:38:20 <bleathem> Irritation is shared all around
21:38:25 <kenfinnigan> Perfectly understandable
21:38:48 <mojavelinux> okay, onwards. lincolnthree1 did you want to say something about forge?
21:39:26 <lightguard_jp> He's always talking about Forge, you may need to be more specific :)
21:39:30 <mojavelinux> btw, I'm still waiting on a link to the jira report for which issues need to be fixed
21:39:36 <mojavelinux> oh, he asked to have the floor I believe
21:41:22 <kenfinnigan> mojavelinux: Shall I create the report in JIRA tonight? (if I have access)
21:41:46 <mojavelinux> sure, it shouldn't require any special access, just a filter that you save and mark as public
21:41:50 <mojavelinux> then anyone can link to it
21:41:56 <kenfinnigan> Will do
21:43:04 <mojavelinux> this could be a bit of an experiment with how you do a target release filter across multiple projects in jira
21:43:47 <mojavelinux> it may be something like status = unresolved and fix version = 3.0.0.%
21:43:58 <gmorling> Couldn't Shane make his filter public?
21:44:14 <kenfinnigan> Probably also contains "seam" in project name
21:44:25 <mojavelinux> oh, yes, you can select projects in a multi-select
21:44:40 <mojavelinux> but yes, btw, I renamed the one project that was getting stuck in the middle
21:44:46 <mojavelinux> so now you can select Seam Distribution
21:44:50 <kenfinnigan> Will give it a shot if Shane hasn't released his first
21:44:54 <mojavelinux> then shift select to Seam Validation
21:44:58 <mojavelinux> and that's all the Seam 3 projects
21:45:04 <mojavelinux> oops, should say Seam 3 Distribution
21:45:16 <johnament> well, except you want to exclude the modules that aren't releasing yet, right?
21:45:20 <mojavelinux> for the fix version, you may have to click on "advanced"
21:45:31 <mojavelinux> oh yeah, good point
21:45:42 <mojavelinux> i'm just saying in general, FYI
21:45:46 <mojavelinux> let me info that
21:46:12 <mojavelinux> #info when searching in JIRA, all projects between Seam 3 Distribution and Seam Validation are the Seam 3 modules (no other projects get stuck in the middle)
21:46:31 <kenfinnigan> Cool
21:46:42 <mojavelinux> just makes things simpler
21:47:05 <kenfinnigan> Is the best place to have a list of modules for final in the full distribution build?
21:47:28 <kenfinnigan> Where I can find a list that is
21:47:38 <mojavelinux> actually, you know what?
21:47:49 <mojavelinux> that should be a column on http://seamframework.org/Seam3/Status
21:48:11 <kenfinnigan> There used to be a roadmap page with ticks for that
21:48:16 <mojavelinux> jason, can you add a column for "In stack" or something
21:48:20 <mojavelinux> wait
21:48:24 <kenfinnigan> But I think it was removed
21:48:28 <mojavelinux> we discussed this already
21:48:32 <mojavelinux> we were going to split the table into two
21:48:37 <mojavelinux> modules in the stack
21:48:41 <mojavelinux> modules not yet in the stack
21:48:49 <kenfinnigan> Sounds reasonable
21:48:52 <mojavelinux> then, it's like a promotion when you get into the stack
21:48:57 <mojavelinux> and there was much rejoicing
21:49:01 <mojavelinux> yeah
21:49:13 <mojavelinux> of course, we should have this list in the distribution too, as you are suggesting ken
21:49:17 <kenfinnigan> And a very visually intuitive way of seeing what is in the stack
21:49:22 <mojavelinux> the web page is for the web crawlers
21:49:26 <mojavelinux> yes
21:49:31 <mojavelinux> and the humans
21:49:50 <mojavelinux> hahaha
21:50:00 <kenfinnigan> Is there a full dist readme the list could be added to?
21:50:10 <bleathem> does this work for anyone?
21:50:14 <bleathem> https://issues.jboss.org/secure/IssueNavigator.jspa?mode=hide&requestId=12314294
21:50:21 <mojavelinux> #action split table of modules into two tables, one for modules in the stack, one for modules not in the stack http://seamframework.org/Seam3/Status
21:50:38 <mojavelinux> dist readme should be in dist/
21:51:00 <gmorling> One question about dependency versions
21:51:05 <mojavelinux> what's up?
21:51:13 <kenfinnigan> Ok, will look at adding a list to it
21:51:40 <gmorling> to be part of the stack a module should require specific versions, right? Seam Validation is based specifically on HV 4.2 (Beta) though
21:51:49 <gmorling> should = shouldn't
21:52:51 <gmorling> I thinks this would be an issue at least if we try tro create a combined jar for all stock modules
21:53:48 <mojavelinux> seam validation is a special case because it's a vendor extension of a spec exclusively
21:54:01 <mojavelinux> all other seam modules primarily code to EE 6
21:54:11 <kenfinnigan> I brought up a related issue with shane last night about seam-bom
21:54:15 <mojavelinux> and have no relationship to a spec implementation
21:54:32 <mojavelinux> well, okay, seam conversation is in the same boat
21:54:44 <kenfinnigan> Post final, as modules have their own releases
21:55:09 <kenfinnigan> Seam-bom will be stack bom and not what is the latest release of a module
21:55:14 <mojavelinux> #action kenfinnigan add a list of modules in the stack release to the dist readme.txt
21:55:33 <mojavelinux> yes, correct, seam-bom is a baseline
21:55:40 <mojavelinux> doesn't mean you can upgrade a module in your application
21:55:44 <kenfinnigan> Yey! I have an action!
21:55:49 <mojavelinux> sorry, flub
21:55:55 <mojavelinux> you can upgrade a module in your application
21:56:10 <mojavelinux> the point is that w/ seam-bom, you get a starting point, so you don't have to worry about which version is the default
21:56:30 <mojavelinux> or I should say recommended
21:56:35 <mojavelinux> so let's say I'm coding up seam booking
21:56:40 <mojavelinux> I add seam-bom
21:56:44 <kenfinnigan> Ok. Always thought it was the latest as opposed to starting point
21:56:48 <mojavelinux> I just say "seam-faces", "seam-security"
21:56:52 <kenfinnigan> That makes more sense
21:56:57 <mojavelinux> oh, but there is an update to seam-faces
21:57:01 <mojavelinux> so now I just upgrade it with an explicit version
21:57:06 <mojavelinux> now, the question comes in
21:57:20 <mojavelinux> what about if seam-faces needs a newer version of seam-security, which isn't in the seam-bom
21:57:34 <mojavelinux> so then seam-faces *temporarily* requires an explicity version of seam-security
21:57:42 <mojavelinux> to be rectified on the next seam-bom update
21:57:49 <mojavelinux> so the way I see it, the versions sort of float in and out
21:57:57 <kenfinnigan> Ok. Seems logical
21:58:01 <gmorling> I see
21:58:13 <mojavelinux> but this is very much a "learn as we go" process
21:58:20 <gmorling> So this shouldn't be a real problem then
21:58:33 <mojavelinux> because there is very little in the way of reference points here
21:58:47 <mojavelinux> right, going "versionless" is not a hard requirement
21:58:54 <mojavelinux> think of it the other way, as a convenience
21:59:49 <mojavelinux> #info seam-bom sets module versions as a convenience to the end developer and as a recommendation of compatible versions
21:59:53 <lincolnthree1> sorry, im here
21:59:57 <mojavelinux> #info ;modules and/or applications can set the version of a module explicitly
22:00:13 <lincolnthree1> (i was here all along, just not "here")
22:00:17 <mojavelinux> #info modules should request the update in the next seam-bom release and remove the version once it is there
22:00:29 <mojavelinux> #info but it does not have to happen urgently
22:01:32 <kenfinnigan> So if a seam module has an explicit version for a dependency
22:01:41 <mojavelinux> #action document the seam-bom version policy on the coding guidelines page
22:01:53 <mojavelinux> #action document the purpose of the seam-bom in the seam module refguide <- this should be a jira
22:01:58 <kenfinnigan> We should raise a jira on the main seam project to update it?
22:02:09 <mojavelinux> that's correct
22:02:14 <kenfinnigan> Cool
22:02:25 <mojavelinux> however, we still have to feel that out...as to how urgent that really is
22:03:40 <mojavelinux> we are going to learn some things about version matrices :)
22:04:50 <mojavelinux> we are over time
22:05:28 <mojavelinux> whatever you can do to help resolve issues for final, it would be most appreciated and get us back to innovating :)
22:05:34 <gmorling> So will you keep us posted on the mailing list about the release/Weld issue?
22:05:51 <mojavelinux> yes, that will be a decision we'll make in the coming days
22:06:12 <mojavelinux> hopefully we get the support of the Weld team on this one
22:06:16 * mojavelinux prays
22:06:28 <gmorling> I'm confident :-)
22:07:03 <mojavelinux> btw, if you are interested in scala and cdi, daniel_hinojosa has a case study you can check out
22:07:07 <mojavelinux> pretty cool stuff https://github.com/dhinojosa/cdi-scala
22:07:56 <mojavelinux> thanks everyone for coming and for participating. seam 3.0.0.final is the beginning of an awesome project :)
22:08:01 <mojavelinux> I can't wait to see what happens next
22:08:23 <mojavelinux> #endmeeting