#richfaces Meeting

Meeting started by balunasj_mtg at 15:04:14 UTC (full logs).

Meeting summary

    1. Agenda for this meeting: (balunasj_mtg, 15:04:47)
    2. http://community.jboss.org/wiki/RichFacesTeamMeetingAgenda6-29-2011 (balunasj_mtg, 15:04:55)

  1. AS7 & OpenShift Blogs, videos (balunasj_mtg, 15:05:17)
    1. Lets start with the work that is going on with lfryc and getting showcase to AS7 (balunasj_mtg, 15:05:45)
    2. I'm trying to deploy whole demo without need to configure the server manually before (lfryc, 15:07:44)
    3. there are some issues which must be solved in management interface compatibility (lfryc, 15:07:59)
    4. ACTION: lfryc Continue investigation, work with AS7 guys for any issues, and try to prep a blog mid next week (balunasj_mtg, 15:18:07)
    5. https://issues.jboss.org/browse/RFPL-1506 created (balunasj_mtg, 15:18:25)
    6. Also going to be working on a screencast for OpenShift but that is a little farther out - 2-3 weeks (balunasj_mtg, 15:19:02)
    7. we can discuss that further in another meeting (balunasj_mtg, 15:19:16)
    8. https://issues.jboss.org/browse/RFPL-1507 (balunasj_mtg, 15:19:31)

  2. 4.1 Mobile showcase app (balunasj_mtg, 15:20:01)
    1. this is currently planned for M2 - although I need to flush out the details (balunasj_mtg, 15:20:31)
    2. Current planning it to be the same application, but with device detection, and changes added. (balunasj_mtg, 15:21:07)
    3. this would use similar steps as tweetstream (balunasj_mtg, 15:21:29)

  3. 4.1 Editor (balunasj_mtg, 15:33:53)
    1. lfryc you've been spending some more time on this (balunasj_mtg, 15:34:21)
    2. any quick updates? (balunasj_mtg, 15:34:34)
    3. I have started with initial inspections of CKEditor and from perspective of JS integration it seems very promising! (lfryc, 15:34:53)
    4. I need to investigate in other directions: skinning and modal panel customization (lfryc, 15:35:17)
    5. I have also collected all requirements from wiki and issue tracking (lfryc, 15:35:38)
    6. so next week I should have available wiki page with editor requirements (lfryc, 15:35:59)
    7. from these requirements can we separate what should be integrated in scope of M1 (lfryc, 15:36:19)
    8. CKEditor has also strong JavaScript API giving us possibility to extend functionality in future (lfryc, 15:39:15)
    9. ACTION: lfryc list these ideas in the requirements wiki and we can use it as start point in discussions what should be improved in later releases (balunasj_mtg, 15:41:10)
    10. AGREED: (balunasj_mtg, 15:41:14)
    11. quote " wyer just that ck editor rocks :-)" (balunasj_mtg, 15:42:07)

  4. 4.1 Select updates (balunasj_mtg, 15:46:50)
    1. wyer has been looking and working on some updates to the select component (balunasj_mtg, 15:47:09)
    2. can you share current thoughts, and status? (balunasj_mtg, 15:47:28)

  5. 4.1 Git Build updates (balunasj_mtg, 15:53:46)
    1. wyer has already started some updates and helper scripts, and I'm also curious to get juank_prada feedback with the git and build stuff (balunasj_mtg, 15:54:33)
    2. lets start with juank_prada how has been your experience so far? I know you had some maven hiccups (balunasj_mtg, 15:55:07)
    3. anything from a git usage point of view? (balunasj_mtg, 15:55:17)
    4. lets talk about some of the updates wyer has done with the scripts this might help as well. (balunasj_mtg, 16:00:31)
    5. ACTION: juank_prada Try to review and update wiki overview to better highlight getting started info - both user, and developer based (balunasj_mtg, 16:01:01)
    6. wyer can you describe what you've already done and some of your plans (balunasj_mtg, 16:01:25)
    7. https://github.com/richfaces/build/blob/develop/scripts/checkout.sh (balunasj_mtg, 16:04:32)
    8. ACTION: wyer Create a dev forum topic on plans and ideas for build scripts (balunasj_mtg, 16:08:03)


Meeting ended at 16:10:05 UTC (full logs).

Action items

  1. lfryc Continue investigation, work with AS7 guys for any issues, and try to prep a blog mid next week
  2. lfryc list these ideas in the requirements wiki and we can use it as start point in discussions what should be improved in later releases
  3. juank_prada Try to review and update wiki overview to better highlight getting started info - both user, and developer based
  4. wyer Create a dev forum topic on plans and ideas for build scripts


Action items, by person

  1. juank_prada
    1. juank_prada Try to review and update wiki overview to better highlight getting started info - both user, and developer based
  2. lfryc
    1. lfryc Continue investigation, work with AS7 guys for any issues, and try to prep a blog mid next week
    2. lfryc list these ideas in the requirements wiki and we can use it as start point in discussions what should be improved in later releases
  3. wyer
    1. wyer Create a dev forum topic on plans and ideas for build scripts


People present (lines said)

  1. balunasj_mtg (112)
  2. lfryc (45)
  3. wyer (42)
  4. juank_prada (10)
  5. ppitonak (4)
  6. jbossbot (2)
  7. jbott (2)


Generated by MeetBot 0.1.4.