15:02:16 <balunasj> #startmeeting
15:02:16 <jbott> Meeting started Fri Jun 24 15:02:16 2011 UTC.  The chair is balunasj. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:16 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:32 <bleathem> balunasj: I started a blog entry summarizing the sessions I went to
15:02:48 <balunasj> bleathem: ok sounds good - I'll try to do the same
15:03:07 <bleathem> balunasj: but a seperate entry summarizing the JBoss sessions would be good too
15:03:17 <bleathem> I wonder iif Dan is working on that
15:03:31 <balunasj> #info We are going to discuss 4.1 planning and updates today.
15:03:47 <lfryc> balunasj: bleathem it would be great to see your presentations at least in form of slides
15:03:49 <balunasj> #info I want to go through the current jira assigned and discuss editor, and picklist items.
15:04:07 <balunasj> lfryc: yup - I'll put mine up on slideshare as part of the blog
15:04:15 <lfryc> great to hear
15:04:15 <bleathem> lfryc: http://github.com/bleathem/talks
15:04:22 <balunasj> actually I'll put them up anyway
15:04:25 <lfryc> bleathem: nice! :-)
15:04:26 <balunasj> bleathem: nice idea :-)
15:05:27 <balunasj> lfryc: Since bleathem is on vacation next week I would like to focus on his issues and the picklist first
15:05:35 <balunasj> lfryc: does that sound ok?
15:05:54 <lfryc> balunasj: yes, let's take it..
15:06:11 <balunasj> #topic bleathem's issues for 4.1
15:06:27 <balunasj> #link https://issues.jboss.org/secure/IssueNavigator.jspa?reset=true&jqlQuery=project+%3D+RF+AND+fixVersion+%3D+%224.1.0.Milestone1%22+AND+resolution+%3D+Unresolved+AND+assignee+%3D+bleathem+ORDER+BY+priority+DESC&mode=hide
15:07:01 <balunasj> bleathem: You only have two issues at the moment and they are the new component ones
15:07:19 <balunasj> bleathem: I know you were busy with JSFSummit, but did you have any chance to look at these further?
15:07:45 <bleathem> I've gone through the forum post
15:08:03 <bleathem> and looked at the 3.3.3 components at the demo level
15:08:14 <bleathem> next is to look into the 3.3.3. implementations
15:08:25 <bleathem> and plan what can be salvaged for 4.1
15:08:37 <bleathem> that's where things stand for me at the moment
15:09:06 <balunasj> bleathem: ok, a good start, I see this as your priority when you return from vacation
15:09:16 <bleathem> balunasj: priority 1 !
15:09:38 <balunasj> bleathem: I'd like to get a solid idea of requirements, and estimate that first week, so we can get more items planned.
15:10:11 <bleathem> balunasj: right, I think I'll have a good feel for a time estimate once I've looked at the 3.3.3 code
15:10:14 <balunasj> bleathem: I would like you to follow similiar steps as lfryc
15:10:24 <bleathem> sure
15:10:55 <balunasj> #action bleathem Create subtasks and requirement wiki pages for the ordered list, and pick list
15:11:15 <bleathem> sounds good
15:11:39 <balunasj> #action bleathem provide estimates on implementation on 4.1 M! jira's as well.
15:11:48 <balunasj> bleathem: ok cool
15:12:20 <balunasj> I will likely also assign some other jira's to you, either as smaller tasks to help learn, or area's I think you would be good at.
15:12:53 <bleathem> great, looking forward to it
15:12:53 <balunasj> when we review the jira's for M1 we'll see what fits
15:13:35 <balunasj> bleathem: Besides unknown jira's just discussed any questions or items for 4.1 you want to discuss?
15:14:09 <bleathem> Not at this point - I'm sure I will once I dive in
15:14:18 <balunasj> sure
15:14:33 <balunasj> #topic lfryc issues for 4.1
15:14:39 * bleathem is looking forward to working on code, rather than slides when he gets back
15:14:56 <balunasj> bleathem: I bet - me too - just got to get through my planning
15:15:06 <balunasj> lfryc: You know how much american's like that ;-)
15:15:13 * lfryc completely understand :-)
15:15:15 <lfryc> hehe :-)
15:15:28 <balunasj> #link https://issues.jboss.org/secure/IssueNavigator.jspa?reset=true&jqlQuery=project+%3D+RF+AND+fixVersion+%3D+%224.1.0.Milestone1%22+AND+resolution+%3D+Unresolved+AND+assignee+%3D+lfryc+ORDER+BY+priority+DESC&mode=hide
15:15:29 <bleathem> :D
15:15:44 <balunasj> #info ^ lfryc 4.1 jira's
15:16:15 <balunasj> actually lets sort by key
15:16:15 <balunasj> https://issues.jboss.org/secure/IssueNavigator.jspa?reset=true&jqlQuery=project+%3D+RF+AND+fixVersion+%3D+%224.1.0.Milestone1%22+AND+resolution+%3D+Unresolved+AND+assignee+%3D+lfryc+ORDER+BY+key+ASC%2C+priority+DESC
15:16:27 <balunasj> https://issues.jboss.org/browse/RF-11027
15:16:45 <balunasj> lfryc: I'm moving this to critical, and then we can review the subtasks
15:16:55 <jbossbot> jira [RF-11027] rich:editor component for 4.X [Open (Unresolved) Feature Request, Major, Lukáš Fryč] https://issues.jboss.org/browse/RF-11027
15:17:00 <lfryc> sure
15:17:48 <balunasj> lfryc: I think you are in progress on 1,2,3 sub-tasks
15:17:53 <lfryc> balunasj: I would like to add one more subtasks - test implementations in portal environment
15:17:59 <lfryc> balunasj: exactly
15:18:01 <balunasj> +1
15:18:36 <lfryc> I would like to mock up JSPs with editors and try them as porlets, before we will hear from Wesley
15:19:26 <balunasj> lfryc: that is a good idea - you might also want to search through google and see what is there.
15:19:40 <lfryc> balunasj: I would like give 3 days next week to touch all of these impls and try how much they suit requirements we have collected on forums
15:20:23 <balunasj> lfryc: Also as I mentioned in the forums I think you should review jira RF & RFPL for any editor related items.
15:20:30 <lfryc> balunasj: with full-featured editors, I'm starting to have feeling we are running out of alternatives
15:20:43 <balunasj> lfryc: explain?
15:21:11 <lfryc> balunasj: without TinyMCE, there stays only FCKEditor, which might have similar issues, since TinyMCE seems to be little more maintained
15:21:33 <lfryc> balunasj: but FCK is also choice of some of big players: Attlasian, Drupal..
15:21:54 <balunasj> balunasj: that says a lot too
15:22:25 <balunasj> I'll be curious to see what you come up with
15:22:30 <balunasj> on the investigation
15:22:52 <balunasj> i.e. we may find that a basic implementation fits our needs
15:23:01 <lfryc> balunasj: have you heard how much users are actually using advanced editor?
15:23:22 <lfryc> balunasj: may we want to consider implement rather simple one only for 4.1?
15:23:28 <bleathem> CKEditor has support for Sharepoint...  -1  :P
15:23:44 <balunasj> lfryc: No I'm not sure of usage there.
15:23:48 <balunasj> bleathem: :-)
15:23:52 * bleathem don't mind me just looking through the editor pages
15:24:15 <lfryc> balunasj: it may be necessary to add support for some simple editors in future releases...
15:24:27 <lfryc> balunasj: maybe community will bring some of these..
15:25:00 <balunasj> lfryc: I would be curious about how easy/hard it would be to create a composite component that wraps one of the advanced editors.  I.e. if we implement detailed integration with a simple editor, perhaps we can blog about creating complext editors with composite components.
15:25:10 <balunasj> bleathem: lfryc: thoughts ^?
15:26:08 <bleathem> I think it would be ideal if we could use the same editor implementation for both the simple and advanced editors
15:26:10 <lfryc> balunasj: as custom solution, it will probably rock... but you won't be able to expose events externally
15:26:35 <lfryc> bleathem: yes, I hope it would work that way
15:26:38 <bleathem> allow the app devs to scale the complexity as much as they need
15:26:49 <lfryc> bleathem: exactly
15:26:52 <balunasj> bleathem: that is my goal as well
15:26:55 <bleathem> lfryc: cool, I hope it works out
15:27:32 <lfryc> balunasj: I would like to discuss this more next week after initial touch on impls
15:27:35 <bleathem> it would be annoying if a dev wants to "upgrade" an app to use the advanced editor, and the usage changes for end-users because it's a diffenrent component
15:28:12 <balunasj> #action lfryc spend 3 days next week reviewing the editor implementations & provide feedback and suggestions to the team
15:28:52 <balunasj> lfryc: It is also worth looking at how others are doing this - openfaces, icefaces etc...  There is nothing wrong with learning from others :-)
15:29:03 <lfryc> balunasj: I have reviewed them already
15:29:14 <balunasj> lfryc: :-)
15:29:21 <balunasj> should have figured
15:29:32 <lfryc> balunasj: PrimeFaces are using CLEEditor
15:29:38 <lfryc> balunasj: it is using JQuery internally
15:30:01 <lfryc> balunasj: I have concerns about future compatibility, they will need to count with problems when need to upgrade JQuery version
15:30:40 <balunasj> lfryc: I thought that was a very good point - about upgrading jquery and how that would effect the editor
15:31:07 <balunasj> lfryc: Ideally they would be able to remain in sync, because I want to limit our dependencies, but that is something to look into next week
15:31:51 <lfryc> balunasj: another point is how much support can users get for particular implementations
15:32:05 <lfryc> balunasj: there are only two enterprise choices - TinyMCE and FCKEditor
15:33:51 <balunasj> lfryc: it is something to consider, but I think stability, and maintainability from our side is key
15:34:30 <lfryc> balunasj: agree
15:35:44 <balunasj> lfryc: I'll look forward to what you find next week
15:35:55 <lfryc> balunasj: I have ran out of my points for now
15:36:16 <balunasj> lfryc: the last point with editor I wanted to bring up was mobile
15:36:28 <lfryc> balunasj: as I said on forums, I will also look into design of end-user API
15:37:04 <balunasj> We discussed a little in the forums - but mobile so far does not look like much of an option with rich text editors
15:37:16 <balunasj> it is not just us - but pretty much all them have issues there
15:37:22 <lfryc> balunasj: yes, I have tried with testing mobiles and haven't found any impl which is able to handle that
15:37:47 <lfryc> balunasj: even iPad is not able to use TinyMCE and FCKEditor doesn't support it completely
15:38:34 <balunasj> yup
15:38:47 <balunasj> So that is no a Priority 1 item for this
15:38:51 <lfryc> balunasj: but I think we should design the way of support detection and provide styled textarea (which will change dimensions on display rotation)
15:39:25 <lfryc> balunasj: will look more into what JQuery Mobile and others do in this area
15:39:46 <balunasj> lfryc: I agree with degrading to a text area, but the device detection, and orientation support is a wider feature I think.
15:40:29 <balunasj> Feature detection yes - hopefully there is an easy way with these editors to provide an "alt" - like an image :-)
15:40:46 <balunasj> lfryc: anything else for now with editor?
15:41:25 <lfryc> balunasj: no, let's look forward for more details next week!
15:41:31 <balunasj> lfryc: agreed
15:41:57 <balunasj> #info lfryc your other issue is Rf-11068
15:42:32 <balunasj> I think we can move this to major, as if needed we could migrate in M2 as part of notify integration
15:42:38 <balunasj> lfryc: wdyt?
15:43:13 <lfryc> balunasj: sure, I think we would need more than only migration of sandbox
15:43:32 <lfryc> to be ready for contributions into sandbox
15:43:42 <lfryc> balunasj: blogs, howtos, etc.
15:43:54 <balunasj> lfryc: agreed - this is something I've asked wesley to look into when he gets back
15:44:04 <lfryc> balunasj: but we need to complete it since we would like to integrate current works
15:44:37 <balunasj> lfryc: If this is something you or bleathem want to work on too - that is fine
15:44:53 <balunasj> lfryc: I figured I would have you focus on editor for now
15:45:30 <lfryc> balunasj: yes, I will do as much as possible in this direction
15:45:55 <balunasj> lfryc: ok - we can figure out who is going what for sure.
15:46:02 <lfryc> balunasj: I have some "side projects" in form of showcase migration
15:46:11 <balunasj> ok lets move on to jira review
15:46:16 <balunasj> lfryc: yup for sure :-)
15:47:01 <balunasj> #topic 4.1.M1 jira review
15:47:08 <balunasj> #link https://issues.jboss.org/browse/RF/fixforversion/12315856
15:47:29 <balunasj> #action balunasj follow up with Alex and Ilya on their tasks
15:48:01 <balunasj> I'll take a look at the maven build issues as well
15:48:07 <balunasj> ( jira already assigned )
15:48:19 <balunasj> So lets break down the Unassigned items
15:49:38 * lfryc will be back in minute..
15:49:50 <bleathem> balunasj: I can do the showcase texts/grammar fixes
15:50:01 <balunasj> bleathem: agreed
15:50:06 <balunasj> please assign to you
15:50:22 <balunasj> Please take RF-11011 as well
15:50:23 <jbossbot> jira [RF-11011] rich:hashParam there is in screen.height instead of window.height in the text description for this component in showcase [Open (Unresolved) Bug, Minor, Unassigned] https://issues.jboss.org/browse/RF-11011
15:51:14 <balunasj> I'll take https://issues.jboss.org/browse/RF-10932
15:51:15 <jbossbot> jira [RF-10932] MyFaces: upgrade to 2.0.5 release [Open (Unresolved) Task, Critical, Unassigned] https://issues.jboss.org/browse/RF-10932
15:51:55 <balunasj> bleathem: While you are in the examples - can you take https://issues.jboss.org/browse/RF-10985
15:51:56 <balunasj> ?
15:51:56 <jbossbot> jira [RF-10985] richfaces-showcase: design and minor content problems [Open (Unresolved) Bug, Critical, Unassigned] https://issues.jboss.org/browse/RF-10985
15:52:38 <balunasj> bleathem: and this is also example related - and would need you to learn about skinning a bit https://issues.jboss.org/browse/RF-10988
15:52:39 <jbossbot> jira [RF-10988] richfaces-showcase: bad description at standard skinning page. [Open (Unresolved) Bug, Critical, Unassigned] https://issues.jboss.org/browse/RF-10988
15:53:05 <bleathem> taken
15:53:13 <balunasj> great
15:53:30 <balunasj> https://issues.jboss.org/browse/RF-10940
15:53:32 <jbossbot> jira [RF-10940] Client side validation refers to non existing javascript function [Reopened (Unresolved) Bug, Critical, Unassigned] https://issues.jboss.org/browse/RF-10940
15:53:42 <balunasj> lfryc: This might be a good one for you - if you agree?
15:54:15 <lfryc> balunasj: taking..
15:54:43 <balunasj> lfryc: When you reviewed Justin's pull request - did you modify this area? https://issues.jboss.org/browse/RF-10948
15:54:44 <jbossbot> jira [RF-10948] component select: instable behaviour in conjunction with a standard jsf-tag ajax (event selectitem, probably more) [Open (Unresolved) Bug, Major, Unassigned] https://issues.jboss.org/browse/RF-10948
15:55:19 <balunasj> I'll take https://issues.jboss.org/browse/RF-11054
15:55:20 <jbossbot> jira [RF-11054] Dynamically created tabs within tabPanel causes NPE in getActiveItem() [Open (Unresolved) Bug, Major, Unassigned] https://issues.jboss.org/browse/RF-11054
15:55:52 <lfryc> balunasj: I haven't integrated yet, it was better to discuss the complete behavior first
15:56:27 <balunasj> lfryc: I thought his pull request was just for a bug - not the feature changes we are discussing
15:56:38 <balunasj> lfryc: no problem them we'll review all at once
15:56:41 <lfryc> balunasj: it was for setValue("") setValue(null
15:57:00 <balunasj> lfryc: ah ok - that was a valid issue for sure
15:57:08 <lfryc> balunasj: yes, it is now evident..
15:57:39 <balunasj> lfryc: ok
15:57:43 * lfryc would need to leave in several minutes
15:58:05 <balunasj> we are basically done for now anyway
15:58:12 <balunasj> I 'll take that select issue for now
15:58:41 <balunasj> bleathem: You're out all next week right?
15:58:50 <bleathem> correct, M-F
15:59:12 <balunasj> bleathem: So have a good time, and we'll get you into the thick of it when you return
15:59:19 <lfryc> balunasj: ah, sorry, I haven't answered the first question.. I haven't touch rich:select a much, so if you feel fine with taking this..
15:59:37 <bleathem> balunasj: thanks!
15:59:43 <balunasj> lfryc: Thanks a lot - and we'll follow up next week
15:59:52 <balunasj> #action balunasj jira's reviewed and assigned
15:59:55 <balunasj> #endmeeting