15:02:55 <balunasj> #startmeeting
15:02:55 <jbott> Meeting started Wed Jun 15 15:02:55 2011 UTC. The chair is balunasj. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:55 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:03:13 <balunasj> #info Agenda for todays meeting is http://community.jboss.org/wiki/RichFacesTeamMeetingAgenda6-15-2011
15:03:21 <balunasj> #topic Announcements
15:03:30 <balunasj> #info Git migration is completed!!
15:03:41 <balunasj> #info great job lfryc
15:04:05 <balunasj> lfryc: any last follow ups or discussions?
15:04:11 * bleathem applause
15:04:38 <lfryc> balunasj: no, just hack on that
15:04:49 <balunasj> lfryc: nice!!
15:05:20 <balunasj> #info JBoss world keynote blogs are being posted
15:05:40 <balunasj> #info RichFaces/tweetstream blog posted to :
15:05:44 <balunasj> #link http://in.relation.to/Bloggers/RichFacesAndTheMobileWebForTheJBossWorld2011Keynote
15:06:02 <balunasj> #info please promote and/or check it out :-)
15:06:31 <balunasj> Any other general announcements for now?
15:06:46 <bleathem> Nice to see a non-Ceylon post on in.relation.to :P
15:06:57 <wyer> heh
15:06:58 <balunasj> bleathem :-) agreed
15:07:06 <lfryc> balunasj: I have posted some initial proposals and thougts-gathering on Editor
15:07:23 <balunasj> lfryc: nice - where on dev forum?
15:07:32 <lfryc> http://community.jboss.org/message/610318#610318
15:07:36 <lfryc> http://community.jboss.org/message/610315#610315
15:08:05 <lfryc> balunasj: bleathem please review and share your thoughts..
15:08:09 <balunasj> ah great! that did not make it into my email bucket yet
15:08:16 <balunasj> lfryc: sounds good
15:08:28 <bleathem> lfryc: will do
15:08:38 <balunasj> #topic 4.1 Planning: Jira
15:08:52 <balunasj> #info I've created all the planned jira release versions
15:09:03 <balunasj> #info 4.1.0.M1, 4.1.0.M2, 4.1.0.CR1, 4.1.0.Final
15:09:27 <balunasj> #info just so everyone knows I'm using 4.1.0.Final as a staging location for jira's we want in 4.1, but are not scheduled
15:10:09 <balunasj> #info I've gone through all the jira's that were for 4.1.0.Milestone1
15:10:39 <balunasj> #info weeded them out, and it should be in fairly good shape although some are not assigned yet.
15:10:51 <bleathem> When will you schedule issues for M2 and CR1?
15:10:58 <bleathem> after M1?
15:11:19 <balunasj> bleathem: We'll start to do that now, and then as we get closer to M1 freeze.
15:11:57 <balunasj> bleathem: The idea is that before M1 freeze date M2 should be ready to go so everyone can just keep on moving
15:12:11 <bleathem> understood
15:12:30 <balunasj> speaking of dates :-)
15:12:42 <balunasj> #topic 4.1 Planning: Dates
15:13:04 <balunasj> #info M1 code freeze should be around the end of July with a release early August
15:13:23 <balunasj> #info M2 should follow 1 month later following the same model
15:14:04 <balunasj> So as we finalize estimates this week and next we need to think about these dates for assignments
15:14:26 <balunasj> We'll discuss later releases as M2 is clearer
15:15:25 <balunasj> blabno: ping - want to touch base and see if you will be able to assist with any notify integration work?
15:16:11 <balunasj> lfryc is going to be working on it, but any assistance or ideas from you are always welcome!
15:16:49 <balunasj> really at this point anyone interested in helping out - please let me know - either on list or off
15:17:08 <wyer> well i am open for issues
15:17:29 <balunasj> wyer: Excellent to hear!!
15:17:47 <wyer> my house is mostly unpacked and i will have internet next week so some smallish things will suit me plus whatever we discuss re rich:select
15:18:19 <balunasj> wyer: Awesome - glad to hear you are unpacked - that can be a long process
15:18:36 <wyer> i'll say if i won't have the time available for an issue
15:18:53 <balunasj> wyer: perfect that is all we can ask :-)
15:18:54 <wyer> so as to avoid things been late or me losing sleep :P
15:19:04 <balunasj> sure
15:19:25 <balunasj> ok - lets move on so we can get to some of the other topics
15:19:34 <balunasj> #topic 4.1 Planning: approach
15:20:11 <balunasj> #info we obviously don't have much time, and we have a few new components, some known issues we need to fixed, etc...
15:20:32 <balunasj> #info so the question is: focus on new components first, or known issues?
15:20:35 <balunasj> thoughts?
15:20:49 <lfryc> balunasj: I would like first to focus on new components
15:21:03 <balunasj> Personally I think getting a headstart on new components would be best.
15:21:05 <lfryc> balunasj: and we could stabilize them in M2
15:21:05 <bleathem> if we have to let something slip, which is better to let slip?
15:21:19 <wyer> i agree new components is better so that bugs can be found during m2
15:21:42 <bleathem> +1 for stabilisation time of new components
15:21:46 <balunasj> bleathem: some component picklist/orderedlist/editor can not slip
15:22:06 <balunasj> and some bugs can not slip either - push/fileupload issues
15:22:25 <balunasj> some general critical bugs etc...
15:22:34 <bleathem> can we do a "slip" vs. "no slip" split instead?
15:23:27 <balunasj> bleathem: sure - we can look at it that way - but also think it is important that any critical new component get in quick.
15:23:28 <lfryc> it should be given by JIRA issues priority, right?
15:23:52 <wyer> i think new components need to get in asap
15:24:00 <balunasj> #agree Critical new components should be completed asap to have time to stabilize
15:24:07 <wyer> we know where the existing bugs are
15:24:19 <wyer> we need to know about the ones in the new components which don't exist yet :P
15:24:20 <balunasj> #agree Critical known issues should also be worked in
15:24:47 <balunasj> #agree We'll use standard priority in jira as normal
15:25:10 <balunasj> ok so that that goes nicely into the next topic on M1 jira review
15:25:19 <blabno> balunasj: hello jay, i was afk
15:25:43 <balunasj> blabno: no problem - did you see my question above?
15:26:05 <blabno> no, i got disconnected right after that
15:26:15 <balunasj> ok one sec
15:26:45 <lfryc> balunasj: I have reviewed and things that goes into M1 seems very reasonable
15:27:02 <balunasj> blabno: ping - want to touch base and see if you will be able to assist with any notify integration work?
15:27:02 <balunasj> 11:16 AM
15:27:02 <balunasj> lfryc is going to be working on it, but any assistance or ideas from you are always welcome!
15:27:02 <balunasj> 11:16 AM
15:27:02 <balunasj> really at this point anyone interested in helping out - please let me know - either on list or off
15:27:14 <balunasj> blabno: from above ^
15:27:25 <juank_prada> balunasj: anyway i could help?
15:27:50 <lfryc> balunasj: I suggest to collect and review issues that are generally doing problems to functional tests
15:27:59 <juank_prada> i just got to the meetin and i see i've missed a lot of things
15:28:06 <balunasj> juank_prada: absolutely! What do you think you would be interested in assisting with?
15:28:19 <juank_prada> balunasj: whatever... from devel to documentation
15:28:28 <balunasj> juank_prada: Lets discuss after meeting or later so we keep on track
15:28:29 <blabno> cool, i think that the component is ready tested a lot so there should be no problem
15:28:35 <balunasj> juank_prada: but thanks!
15:28:38 <juank_prada> balunasj: sure
15:29:09 <balunasj> blabno excellent - lfryc will be reviewing and helping to get into the release
15:29:31 <balunasj> blabno: lfryc: we need to get sandbox migrated to git though - what are your thoughts on that?
15:29:59 * lfryc is looking forward to further work on notify..
15:30:21 <lfryc> balunasj: sandbox wouldn't be problematic one
15:30:53 <lfryc> balunasj: do you remember is there task for that?
15:31:00 <balunasj> lfryc: agreed it should be fairly straight forward
15:31:02 <balunasj> looking..
15:31:29 <lfryc> balunasj: standard git clone will apply here, just need to reconfigure svn.authors collected from previous garthering
15:31:47 <balunasj> lfryc: does not appear to be - I'll create one
15:32:18 <lfryc> balunasj: I'm going to work on it as part of notify works - notify is going to be in M2 probably, right?
15:33:08 <balunasj> lfryc: https://issues.jboss.org/browse/RFPL-1501
15:33:09 <jbossbot> jira [RFPL-1501] Migrate sandbox from SVN to git [Open (Unresolved) Task, Critical, Lukáš Fryč] https://issues.jboss.org/browse/RFPL-1501
15:33:24 <lfryc> thanks
15:33:24 <balunasj> lfryc: yes I think that notify will be M2
15:33:38 <balunasj> although that is an RF issue - I'll move it
15:33:57 <balunasj> ok so lets shift to M1 review topic for now
15:34:00 <lfryc> balunasj: then I suggest to assign migration to M1 scope
15:34:18 <balunasj> ok - one min
15:35:21 <balunasj> ok moved
15:35:26 <balunasj> RF-11068
15:35:27 <jbossbot> jira [RF-11068] Migrate sandbox from SVN to git [Open (Unresolved) Task, Critical, Lukáš Fryč] https://issues.jboss.org/browse/RF-11068
15:35:42 <balunasj> #topic 4.1 Planning: M1 jira review
15:36:23 <blabno> lfryc: i'm not sure if i have synchronized javascript files between 4.x and 3.3.4, since i've fixed a bug (notify doesnt show in IE7) recently, so if you run into it, don't worry, cause it has been already fixed in 3.3.4
15:36:25 <balunasj> #info M1 jira's have been reviewed and filtered by me. The items remaining there are important to be done in this stage - although open to discuss of coarse
15:36:57 <balunasj> #link https://issues.jboss.org/browse/RF/fixforversion/12315856
15:37:02 <lfryc> blabno: thanks for warning..
15:38:00 <balunasj> alexsmirnov: Has 4 issues assigned to him at this time, and some are still in the investigation phase, but any changes to CDK is important to get in early in my experience
15:38:41 <balunasj> alexsmirnov: I know you are busy with PBR TCK work right now
15:39:03 <balunasj> alexsmirnov: so we can discuss later as needed
15:39:27 <balunasj> FYI - I'm just going through the list of issues by person
15:40:08 <balunasj> bleathem: Right now you only have two issues assigned - the two new components for picklist and ordering list
15:40:34 <bleathem> balunasj: looking forward to it!
15:40:51 <balunasj> bleathem: have you had a chance to review the existing components and/or the wiki page yet?
15:41:11 <bleathem> yes, I reviewed them
15:41:21 <bleathem> at a functional level
15:42:17 <balunasj> bleathem: I know you are still getting into the swing of things too :-) + JSFSummit prep
15:42:32 <bleathem> I'll add some comments as I straighten them out in my head
15:42:37 <balunasj> bleathem: what do you think your plans are around that?
15:42:55 <balunasj> bleathem: ok then - let me know if you have any questions, concerns.
15:43:26 <bleathem> balunasj: will do, I haven't really investigated my approach yet
15:43:37 <bleathem> balunasj: I'll let you know when I do
15:43:48 <balunasj> bleathem: ok
15:44:45 <balunasj> Ilya wants to work on some updates to the showcase with new examples - I'll touch base with him on what he thinks he can get done.
15:45:50 <balunasj> #action balunasj, bleathem, lfryc what we need in the short term is estimates on these issues so we can plan them out - even rough estimates would be good
15:46:54 <balunasj> For me I've got the new component umbrella issue, and the maven 3 build
15:46:59 <balunasj> I'll be adding to it :-)
15:47:19 <balunasj> lfryc: Right now you have 11 issues https://issues.jboss.org/secure/IssueNavigator.jspa?reset=true&jqlQuery=project+%3D+RF+AND+fixVersion+%3D+%224.1.0.Milestone1%22+AND+resolution+%3D+Unresolved+AND+assignee+%3D+lfryc+ORDER+BY+priority+DESC&mode=hide
15:47:46 <balunasj> most are around the editor component with some admin items
15:48:06 <balunasj> I'll take a look at your posts on the editor and we'll discuss more
15:48:35 <balunasj> then we have 8 unassigned issues
15:48:41 <balunasj> https://issues.jboss.org/secure/IssueNavigator.jspa?reset=true&jqlQuery=project+%3D+RF+AND+fixVersion+%3D+%224.1.0.Milestone1%22+AND+resolution+%3D+Unresolved+AND+assignee+is+EMPTY+ORDER+BY+priority+DESC&mode=hide
15:48:57 <balunasj> These are issues I think are needed in M1
15:49:11 <lfryc> balunasj: I have also RFPL JIRAs assigned, which will take a lot of time
15:49:31 <balunasj> lfryc: true - we'll take a look there as well.
15:50:12 <lfryc> balunasj: the estimates will based on editor component and I would say, we need to align the requirements first
15:50:37 <balunasj> I'll take several of these on - myfaces, showcase for sure. Then we'll discuss others.
15:50:51 <balunasj> lfryc: agree - lets get the requirements there first with the editor
15:51:08 <lfryc> balunasj: do you think separate meeting on new components is appropriate?
15:51:52 <lfryc> balunasj: I have many ideas how to improve usability of Editor from 3.3.x but much of them will probably not be going to M1
15:52:34 <balunasj> lfryc: Thought I had that as part of agenda - we have a meeting planned next Friday, and the one the following week to discuss 4.1 finalization. So editor requirements, jira, etc..
15:52:45 <balunasj> lfryc: that can be part of those meetings
15:52:57 <lfryc> balunasj: and I think we should not change a much what will be initially implemented since focusing on bugfixing in later releases
15:53:09 <balunasj> I suggest breaking up your requirements into base functionality, and add-ons.
15:53:22 <lfryc> balunasj: exactly
15:53:34 <balunasj> lfryc: good same page
15:54:53 <balunasj> so I'll review your comments so far, and then we'll finalize at next weeks meeting
15:54:57 <balunasj> lfryc: ^
15:55:09 <lfryc> balunasj: agree
15:56:11 <balunasj> we are nearly out of time, so I'll ask people with jira's assign to them to review them ( RF/RFPL ) and think about implementation time requirements
15:56:30 <balunasj> #action All : ask people with jira's assign to them to review them ( RF/RFPL ) and think about implementation time requirements
15:57:16 <balunasj> Anything else specific to 4.1.M1 for now - we'll have follow ups in jira/forums too
15:58:03 <balunasj> #topic 4.1 Planning: general jira review
15:58:07 <balunasj> #link https://issues.jboss.org/browse/RF/fixforversion/12317055
15:58:30 <balunasj> #info as I said I'm using 4.1.0.Final as a staging area
15:59:10 <balunasj> #action please review these ( especially ones assigned to you ) for updates/thoughts etc...
15:59:39 <balunasj> #action balunasj I'll start assigning out so please let me know if there are issues or concerns
16:01:46 <balunasj> ok - before we move on to the rich:select topics from wyer does anyone have any comments for 4.1 items?
16:02:04 <lfryc> balunasj: not from me
16:02:06 <bleathem> no commets from me - it all looks good
16:02:14 <balunasj> ok great!
16:02:38 <balunasj> btw - FYI - I'll be pretty booked up rest of week with JSFSummit prep - so my time will be limited as well
16:02:49 <bleathem> ugh, me too
16:03:04 <wyer> i'll bother lfryc when i need help :P
16:03:23 <balunasj> wyer: we'll be around, just updating presentations :-)
16:03:35 <balunasj> #topic rich:select improvements
16:03:47 <balunasj> #link http://community.jboss.org/thread/168004
16:04:11 <balunasj> #info wyer has proposed some improvements for rich:select for discussionn
16:04:32 <balunasj> wyer: just an FYI - I've only got about 15 min before I need to go - but we can continue later as needed too
16:04:41 <wyer> balunasj, sure
16:05:08 <balunasj> wyer: where do you want to start?
16:05:18 <lfryc> can I start?
16:05:33 <wyer> lfryc, sure
16:05:36 <lfryc> simply our demo has showing the limit of rich:select :-)
16:05:41 <wyer> yeah
16:05:43 <lfryc> http://richfaces-showcase.appspot.com/richfaces/component-sample.jsf?demo=select&skin=blueSky
16:05:57 <wyer> if you goto http://richfaces-showcase.appspot.com/richfaces/component-sample.jsf?demo=select&skin=blueSky and on the manual input demo select an item
16:06:08 <lfryc> 1. open second select by arrow button and select one of items
16:06:22 <lfryc> 2. when you open it again, you will get only 1 item in completion box
16:06:36 <wyer> then when you open the list by clicking the component (input or arrow) it only shows the currently selected item because the list is been scoped due to manual input
16:06:45 <lfryc> I don't know how we missed it but seems unreasonable for me
16:07:40 <wyer> so basically lfryc and myself agree this behavior should change ?
16:07:54 <lfryc> wyer: you proposed changes to work this around, but my opinion is that this way rich:Select should not behave at all
16:07:58 <balunasj> perhaps I'm missing it - what is the issue. As this is a select one
16:07:59 <bleathem> +1 this needs to be fixed
16:08:41 <bleathem> the other items in the select list disapear when you select one of them (under a particular circumstance)
16:08:43 <lfryc> balunasj: rich:select doesn't comply usability..
16:08:58 <wyer> lfryc yeah i did and i think those proposals are still required if simply to complete the api of the component, but i agree with you that the component should behave differently
16:09:26 <balunasj> So you want it to always show everything in the list?
16:09:28 <lfryc> balunasj: I think it should behave pretty much as standard HTML select
16:09:49 <balunasj> Just to be clear - it is still just selecting one item right - not like autocomplete
16:10:38 <wyer> balunasj, an end user does not understand why the list only contains one item after they have selected one the first time
16:10:42 <lfryc> balunasj: but this does work for selecting by typing - you should get only what you have asked for
16:10:43 <balunasj> So you don't want it to narrow the list, just select the first "match"
16:11:00 <lfryc> balunasj: but when clicking to button, I expect to get all of the suggestions...
16:11:31 <wyer> balunasj, the list should narrow while typing in input but not when opening list after initial selection
16:12:14 <balunasj> So if I type in "arkan"
16:12:22 <balunasj> it should be narrowed?
16:12:34 <lfryc> balunasj: yes..
16:12:49 <lfryc> balunasj: but when you initiate with using mouse, it should return complete list
16:12:53 <bleathem> cicking the arrow though should then un-narrow it
16:13:19 <wyer> balunasj, yes but after you click and choose arkan and you open the list again it only shows arkansas and the users do not understand why
16:13:23 <balunasj> What would happen if I type "arkan" and click the arrow?
16:13:35 <lfryc> balunasj: it will get closed :-)
16:14:02 <wyer> balunasj, same as what happens now
16:14:27 <balunasj> not I click the arrow again to open the selection
16:14:27 <lfryc> balunasj: we just need to distinguis how the box was initially opened - by mouse/keys
16:14:36 <bleathem> I'm confused
16:14:36 <balunasj> should it be narrowed or expanded?
16:15:03 <balunasj> So am I - we should have the same behavior key or click
16:15:10 <lfryc> balunasj: when you type "arkan" you get list, then you can select or close hitting button
16:15:36 <wyer> balunasj, what if a valid item has been selected and the list is reopened the item is then cleared ?
16:15:48 <wyer> that would satisfy both cases ?
16:15:51 <bleathem> but selecting an item (by key) currently narrows the list to only that item. To get the full list, the selection has to firts be cleared (currently)
16:15:53 <balunasj> right now there seems like a bug because I should not be able to leave it as "arka" anyway.
16:16:17 <wyer> balunasj, you can leave it as arkan now...
16:16:52 <balunasj> wyer: yes - but I think that is a bug - at least with showcase because it says invalid entries are not allowed
16:17:29 <bleathem> Perhaps saying "selecting an item should not narrow the list" is a good way of putting it
16:17:35 <wyer> balunasj, ah yeah i agree its a bug, it should highlight red if closed with incomplete input
16:17:39 <balunasj> bleathem: Right - when I have a log list and start typing the list should always show everything - but select the first match
16:18:07 <balunasj> for example in jira
16:18:08 <bleathem> typing should narrow the list, selecting an item should not narrow the list
16:18:38 <balunasj> when you assign a jira - the list does not narrow as you match - it selects the first match
16:19:40 <bleathem> balunasj: that seems like an easily consistent approach
16:19:44 <wyer> the list narrowing while typing is great functionality tho, i would not change that
16:20:23 <balunasj> bleathem: That is what I'm looking for ;-)
16:20:24 * bleathem is currently jealous oj balunasj's sound-proof walls
16:20:47 <balunasj> I would like one way of doing it whether by click or key
16:21:13 * balunasj bleathem my wife texted me and asked for help - so I'm not completely cut off ;-)
16:21:21 <bleathem> if we differentiate between typing, and selecting via arrows, we could achieve some consistency
16:21:39 <balunasj> wyer: I'm trying to think og another place you could see the same thing
16:21:50 * bleathem balunasj you should have put a Faraday cage in those walls!
16:21:52 <balunasj> wyer: lots of places when you select a state for example
16:22:15 * balunasj bleathem hmm, that is a great idea...
16:22:27 <bleathem> narrowing could be done by typing into a sperate "filter" box
16:22:35 <balunasj> http://www.timeanddate.com/worldclock/meeting.html
16:22:50 <wyer> bleathem, thats a good idea
16:22:50 <balunasj> so go to this and open up a location and start typeing
16:23:22 <balunasj> bleathem: would need to see a mockup - not sure where the filter box would go
16:23:43 <lfryc> balunasj: but our component has manual input enabled
16:23:43 <balunasj> when I start typing "bos" I get boston, but the whole list is still visible
16:23:51 <lfryc> balunasj: which is causing misconsistency
16:24:00 <lfryc> balunasj: I could see similar one on labels in JIRA
16:24:04 <wyer> balunasj, lfryc is hitting the nail
16:24:32 <balunasj> lfryc: but so what - why not have it be consistent
16:24:34 <wyer> balunasj, the whole list been visible is crap tho, if i can give a use case
16:25:00 <wyer> balunasj, 300 items in the list all prefixed with a 4 digit number
16:25:40 <wyer> balunasj, user types 1234 and selects an item, now if they want to change the selection they need to backspace 20 times to reach the number portion of the item
16:26:42 <bleathem> in the world time example, selecting an item "resets" the narrowing filter
16:26:42 <balunasj> why not just select the whole text and start over?
16:26:48 <wyer> balunasj, if they click open the list box it should clear the input and redisplay the full list or if possible we could leave the input just select it so one key erases it but still display the full list
16:26:55 <bleathem> so in your use case, you would just start typing from the beginning
16:27:10 <balunasj> wyer: you want the click to clear the selection?
16:27:15 <balunasj> wyer: don't like that
16:27:22 <wyer> balunasj, users are too dumb to realise they need to select the input and start typing again ?
16:28:14 <balunasj> wyer: I could see it auto-highlight the selection when the arrow is clicked
16:28:44 <wyer> balunasj, yeah i would prefer that too
16:28:44 <lfryc> balunasj: it doesn't see auto-highlight work in Chrome
16:29:00 <balunasj> I've got to get going :-( but like the discussion
16:29:13 <wyer> okay we can continue on the forums
16:29:24 <wyer> i need to go home
16:29:25 <balunasj> wyer: I'll give you rights to post on the dev forums if you don't already have time
16:29:31 <balunasj> lfryc: could you check?
16:29:34 <wyer> okay thanks
16:29:35 <lfryc> wyer: yes, please could you describe your preferable solutions on forums?
16:29:43 <wyer> also my cla is still not approved
16:29:53 <lfryc> balunasj: yes
16:29:58 <balunasj> wyer: walk through - step my step on what the user would do/see
16:30:05 <balunasj> wyer: I approved it, just going to
16:30:15 <wyer> lfryc, sure i'll try to some screen mockups
16:30:27 <balunasj> wyer: go through community manager - but you are good to go
16:30:32 <lfryc> wyer: it would be great
16:30:34 <balunasj> wyer: Thanks for your input!!
16:30:49 <wyer> sure thanks for taking the time guys
16:31:02 <bleathem> that was fun!
16:31:03 <balunasj> sure thing
16:31:08 <balunasj> talk to later
16:31:24 <balunasj> #action wyer Post detailed descriptions of behavior on dev forum
16:31:42 <balunasj> #action lfryc Verify that wyer has access to dev forum posting
16:31:46 <balunasj> Thanks All!!
16:31:50 <balunasj> #endmeeting