#richfaces Meeting

Meeting started by balunasj_mtg at 15:01:03 UTC (full logs).

Meeting summary

    1. Agenda for today: http://community.jboss.org/wiki/RichFacesTeamMeetingAgenda6-9-2011 (balunasj_mtg, 15:01:34)

  1. Git migration (balunasj_mtg, 15:02:40)
    1. as you can see in the agenda we are very close to wrapping this up (balunasj_mtg, 15:02:55)
    2. lfryc has done a great job, and we only have a few open items left (balunasj_mtg, 15:03:17)
    3. I have prepared proposal of workflow which was published at http://community.jboss.org/docs/DOC-16874 (lfryc, 15:06:57)
    4. ACTION: lfryc follow up with Vlastimil on fisheye integration (balunasj_mtg, 15:07:08)
    5. this has been reviewed by balunasj_mtg and bleathem (balunasj_mtg, 15:08:06)
    6. I have also prepared Guide how to use pull request with RF JIRA (which has newly enabled Git workflow to support this model) (lfryc, 15:10:55)
    7. ACTION: balunasj_mtg review the pull request and rF jira workflow document (balunasj_mtg, 15:11:23)
    8. Guide can be found here and applies also to other projects: http://community.jboss.org/docs/DOC-16877 (lfryc, 15:11:32)
    9. first point what we need to refine is modifying the existing branches structure to meet the workflow (lfryc, 15:12:11)
    10. AGREED: We can get rid of the branches that are not part of the current workflow (balunasj_mtg, 15:13:27)
    11. ACTION: lfryc will fire issue for removing all the unnecessary branches and tags (it means all except master and 4.0.0.Final) (lfryc, 15:16:04)
    12. stale branches can be removed as long as it will not remove the tags (lfryc, 15:22:45)
    13. also there should be left only last of release tags (lfryc, 15:24:00)
    14. ACTION: lfryc rename the tags to follow timestamp pattern (lfryc, 15:25:11)
    15. ACTION: rename the master branch to develop (lfryc, 15:28:34)
    16. ACTION: create new master branch pointing to 4.0.0.Final (lfryc, 15:28:58)
    17. ACTION: lfryc: setup GitHub to have develop as default (lfryc, 15:29:39)
    18. other topic is RFPL JIRAs and pull request workflow (lfryc, 15:30:02)

  2. RFPL jira's and pull requests (balunasj_mtg, 15:34:11)
    1. RFPL contains issues which doesn't introduce commits (lfryc, 15:34:59)
    2. that's why they doesn't support pull requests (lfryc, 15:35:21)
    3. when developer works on RFPL JIRA which finally introduces commit and pull request, it have to be reflect in RF JIRA (lfryc, 15:35:52)
    4. either by creating and linking new RF JIRA or simply moving the JIRA into RF space (lfryc, 15:36:12)

  3. Sharing feature branches (lfryc, 15:38:57)
    1. AGREED: If RFPL jira results in source code updates to core project is should be moved to RF (balunasj_mtg, 15:38:58)
    2. feature branch may not be needed to be shared in project repositories (lfryc, 15:39:33)
    3. two developers can share code in personal repositories (lfryc, 15:39:54)
    4. it satisfies that no one will start work on feature branches (lfryc, 15:40:06)
    5. but seems to be very restricting rule (lfryc, 15:40:19)
    6. For large tasks sharing a feature branch in the project repo is ok, (balunasj_mtg, 15:41:41)
    7. The same rules apply - when the jira is resolved and branch merged the feature branch can be removed (balunasj_mtg, 15:42:06)
    8. AGREED: with removing branches (lfryc, 15:42:56)
    9. We will likely need to go through and "clean up" from time to time anyway - and the rule will be that features branches for resolved jira's can be removed (balunasj_mtg, 15:43:10)

  4. Release criteria (lfryc, 15:51:46)
    1. ACTION: lfryc post a dev forum post about previous topic to continue (balunasj_mtg, 15:52:18)
    2. the part of release testing criteria is that release should not start before the branch is stabilized (lfryc, 15:53:01)
    3. the new workflow is just following it (lfryc, 15:53:12)
    4. the difference from the past is based that functional tests wasn't ran just prior to each release (lfryc, 15:53:49)
    5. ACTION: ppitonak please create jira's to cover stabilizing smoke test ftest suite before M1 (balunasj_mtg, 16:00:34)
    6. ACTION: ppitonak document release criteria for 4.1 releases (balunasj_mtg, 16:05:49)

  5. 4.1 planning (balunasj_mtg, 16:07:36)
    1. we are already over time for the meeting (balunasj_mtg, 16:07:48)
    2. IDEA: Have a separate meeting just for 4.1 finalization and discussing (balunasj_mtg, 16:08:05)
    3. AGREED: yes, it would be good at this situation (lfryc, 16:08:24)
    4. because of timing it would be post JSFSummit (balunasj_mtg, 16:08:27)
    5. before then I'll email specific tasks and things that should be ready before then so we can hit that meeting ready to nail down specifics (balunasj_mtg, 16:08:58)
    6. ACTION: email specific tasks and things that should be ready before then so we can hit the meeting ready to nail down specifics (balunasj_mtg, 16:09:26)
    7. ACTION: everyone needs to review the docs in the agenda, and add comments, or thoughts. (balunasj_mtg, 16:12:50)


Meeting ended at 16:18:50 UTC (full logs).

Action items

  1. lfryc follow up with Vlastimil on fisheye integration
  2. balunasj_mtg review the pull request and rF jira workflow document
  3. lfryc will fire issue for removing all the unnecessary branches and tags (it means all except master and 4.0.0.Final)
  4. lfryc rename the tags to follow timestamp pattern
  5. rename the master branch to develop
  6. create new master branch pointing to 4.0.0.Final
  7. lfryc: setup GitHub to have develop as default
  8. lfryc post a dev forum post about previous topic to continue
  9. ppitonak please create jira's to cover stabilizing smoke test ftest suite before M1
  10. ppitonak document release criteria for 4.1 releases
  11. email specific tasks and things that should be ready before then so we can hit the meeting ready to nail down specifics
  12. everyone needs to review the docs in the agenda, and add comments, or thoughts.


Action items, by person

  1. balunasj_mtg
    1. balunasj_mtg review the pull request and rF jira workflow document
  2. lfryc
    1. lfryc follow up with Vlastimil on fisheye integration
    2. lfryc will fire issue for removing all the unnecessary branches and tags (it means all except master and 4.0.0.Final)
    3. lfryc rename the tags to follow timestamp pattern
    4. lfryc: setup GitHub to have develop as default
    5. lfryc post a dev forum post about previous topic to continue
  3. ppitonak
    1. ppitonak please create jira's to cover stabilizing smoke test ftest suite before M1
    2. ppitonak document release criteria for 4.1 releases
  4. UNASSIGNED
    1. rename the master branch to develop
    2. create new master branch pointing to 4.0.0.Final
    3. email specific tasks and things that should be ready before then so we can hit the meeting ready to nail down specifics
    4. everyone needs to review the docs in the agenda, and add comments, or thoughts.


People present (lines said)

  1. balunasj_mtg (114)
  2. lfryc (93)
  3. bleathem (45)
  4. ppitonak (23)
  5. jbott (3)
  6. alexsmirnov (2)
  7. jhuska (1)
  8. juank_prada (1)


Generated by MeetBot 0.1.4.