#richfaces Meeting

Meeting started by balunasj_mtg at 15:01:38 UTC (full logs).

Meeting summary

    1. Agenda posted http://community.jboss.org/wiki/RichFacesTeamMeetingAgenda5-24-2011 (balunasj_mtg, 15:02:14)

  1. Meetbot (balunasj_mtg, 15:02:43)
    1. started using this so that meeting minutes are not such a pain (balunasj_mtg, 15:03:06)
    2. Who ever is running the meeting will be responsible for using meetbot commands (balunasj_mtg, 15:03:34)
    3. this will be a learning process with it (balunasj_mtg, 15:04:19)
    4. basic instructions are here http://wiki.debian.org/MeetBot (balunasj_mtg, 15:04:26)
    5. ACTION: balunasj_mtg will post links to the minutes on the meeting information page as usual. (balunasj_mtg, 15:06:26)

  2. Git migration (balunasj_mtg, 15:06:52)
    1. Status of the git migration, and remaining steps (balunasj_mtg, 15:07:21)
    2. code base is migrated but needs further changes (lfryc, 15:08:18)
    3. especially finalize release process (SCM settings) (lfryc, 15:08:33)
    4. do not clone repositories currently (lfryc, 15:08:54)
    5. code base is migrated but needs further changes (lfryc, 15:10:17)
    6. especially finalize release process (SCM settings) (lfryc, 15:10:22)
    7. do not clone repositories yet (lfryc, 15:10:28)
    8. the final migration end will be announced on the forums (lfryc, 15:11:03)
    9. ACTION: lfryc will post to dev forums when migration and updates are complete (balunasj_mtg, 15:11:54)
    10. ACTION: lfryc will update all wiki pages, and build process pages with latest approach - estimate is tomorrow/next day (balunasj_mtg, 15:13:53)
    11. ACTION: lfryc will create a jira to cover closing of /trunk and any other modules we have migrated. (balunasj_mtg, 15:16:52)
    12. https://issues.jboss.org/browse/RFPL-1469 (lfryc, 15:17:15)
    13. RFPL-1469 created by lfryc (balunasj_mtg, 15:17:48)
    14. other items to discuss with git is workflow, and migration plans for docs and QE (balunasj_mtg, 15:18:25)
    15. AGREED: QE will wait about a week after primary project migration (balunasj_mtg, 15:20:42)
    16. AGREED: QE and docs can manage their own migration to git with their own jira's (balunasj_mtg, 15:22:31)
    17. sean is not able to work on RichFaces for a little bit - so we'll be taking over doc updates where needed. (balunasj_mtg, 15:23:12)
    18. this would include migration of docs (balunasj_mtg, 15:23:25)
    19. ACTION: balunasj_mtg will create the needed jira's for this (balunasj_mtg, 15:23:38)
    20. HELP: (bleathem_, 15:25:33)
    21. Next topic is discussing git workflow (balunasj_mtg, 15:27:22)
    22. What process we should take - benevolent dictator? integration manager, etc..? (balunasj_mtg, 15:27:59)
    23. http://nvie.com/posts/a-successful-git-branching-model/ (bleathem_, 15:30:26)
    24. the Git Wrokflow being adopted by the Seam Project (bleathem_, 15:30:48)
    25. AGREED: We don't want a single bottleneck for git - we will need multiple integration managers (balunasj_mtg, 15:31:06)
    26. IDEA: some of modules may have only one manager, e.g. showcase, CDK for necessity of reviewing (lfryc, 15:33:26)
    27. AGREED: all pull requests would need to be tied to a jira (balunasj_mtg, 15:38:38)
    28. IDEA: we should reuse Git Pull Request Workflow in JBoss JIRA (lfryc, 15:38:44)
    29. AGREED: the Git pull Request Workflow in Jira works very well (bleathem_, 15:39:05)
    30. ACTION: lfryc Please be sure to document that in the wiki updates for the workflow (balunasj_mtg, 15:39:32)
    31. AGREED: We'll have 3 integrators at first lfryc bleathem_ and myself - we'll adjust as needed (balunasj_mtg, 15:40:29)
    32. obviously anyone can still fork, and make updates, and pull requests - just that we'll manage the merging to the main repos <--FYI (balunasj_mtg, 15:41:22)
    33. ACTION: All - review git workflow in more detail - http://nvie.com/posts/a-successful-git-branching-model/ (balunasj_mtg, 15:42:21)
    34. AGREED: The test repo will have ppitonak and 1-2 others for integration managers (balunasj_mtg, 15:45:50)
    35. AGREED: Docs will be the same integration manages as the rest of the project (balunasj_mtg, 15:46:18)
    36. ACTION: setting up 'Git Author Names' and 'github Username' in jboss.org user profiles (lfryc, 15:47:59)
    37. it is needed to proper bounding between JBoss issue tracking (JIRA, FishEye) and GitHub (lfryc, 15:48:33)
    38. discussed authors file for git hub migration - most are entered there. (balunasj_mtg, 15:57:32)
    39. AGREED: JBoss.org accounts should be updated with github info (balunasj_mtg, 15:59:16)
    40. ACTION: balunasj_mtg Ask on dev forums for users to add this. (balunasj_mtg, 15:59:41)
    41. ACTION: balunasj_mtg will contact Bernard to get his info (balunasj_mtg, 16:00:27)

  3. RichFaces 4.1 (balunasj_mtg, 16:00:49)
    1. With my vacation last week, and other issues I was not able to complete the minutes or the 4.1 items from the last team meeting on 5-10-2011 (balunasj_mtg, 16:01:26)
    2. ACTION: Review transcript for 5-10-2011 meeting and create abbreviated minutes from it. (balunasj_mtg, 16:02:20)
    3. ACTION: balunasj_mtg jira review and updates for 4.1 before end of week (balunasj_mtg, 16:03:16)
    4. ACTION: create an initial plan based on resources, timing, etc... for the release. (balunasj_mtg, 16:03:37)
    5. we are still planning on Fall release for 4.1 - the exacts dates at TBD for now. (balunasj_mtg, 16:04:18)
    6. there are some obvious additions like rich:editor, picklist, etc... also likely are rich:columns, and rich:notify from bernard (balunasj_mtg, 16:05:11)
    7. non-component focus will be on cdk, forge, performance, mobile/html integration (balunasj_mtg, 16:05:50)
    8. existing updates for components include push with CDI, CSV updates with new constraints, fileupload issues (balunasj_mtg, 16:08:00)
    9. ACTION: include ne or two cool skins which will be based on design from jboss.org guys in the planning (balunasj_mtg, 16:09:21)
    10. there is also various jira's and other items that will be reviewed and made part of the plan (balunasj_mtg, 16:10:02)
    11. Need to keep in mind timing and release blocks. (balunasj_mtg, 16:10:22)
    12. ACTION: create JIRAs for QE to cover one skin and one for styling current components (lfryc, 16:12:09)

  4. git follow up items (balunasj_mtg, 16:16:08)
    1. ACTION: need to migrate sandbox to Git (lfryc, 16:17:07)
    2. ACTION: I suggest rename the examples (lfryc, 16:18:13)
    3. examples repository contains developer examples which may be taken by community but it is not recommended, because it is quite a messy (lfryc, 16:19:09)
    4. I suggest to go with developer-examples instead (lfryc, 16:19:22)
    5. AGREED: dev-examples sounds good (lfryc, 16:20:15)
    6. AGREED: dev-examples +1 (bleathem_, 16:20:36)
    7. AGREED: lets go with dev-examples (balunasj_mtg, 16:20:42)


Meeting ended at 16:21:53 UTC (full logs).

Action items

  1. balunasj_mtg will post links to the minutes on the meeting information page as usual.
  2. lfryc will post to dev forums when migration and updates are complete
  3. lfryc will update all wiki pages, and build process pages with latest approach - estimate is tomorrow/next day
  4. lfryc will create a jira to cover closing of /trunk and any other modules we have migrated.
  5. balunasj_mtg will create the needed jira's for this
  6. lfryc Please be sure to document that in the wiki updates for the workflow
  7. All - review git workflow in more detail - http://nvie.com/posts/a-successful-git-branching-model/
  8. setting up 'Git Author Names' and 'github Username' in jboss.org user profiles
  9. balunasj_mtg Ask on dev forums for users to add this.
  10. balunasj_mtg will contact Bernard to get his info
  11. Review transcript for 5-10-2011 meeting and create abbreviated minutes from it.
  12. balunasj_mtg jira review and updates for 4.1 before end of week
  13. create an initial plan based on resources, timing, etc... for the release.
  14. include ne or two cool skins which will be based on design from jboss.org guys in the planning
  15. create JIRAs for QE to cover one skin and one for styling current components
  16. need to migrate sandbox to Git
  17. I suggest rename the examples


Action items, by person

  1. balunasj_mtg
    1. balunasj_mtg will post links to the minutes on the meeting information page as usual.
    2. balunasj_mtg will create the needed jira's for this
    3. balunasj_mtg Ask on dev forums for users to add this.
    4. balunasj_mtg will contact Bernard to get his info
    5. balunasj_mtg jira review and updates for 4.1 before end of week
  2. lfryc
    1. lfryc will post to dev forums when migration and updates are complete
    2. lfryc will update all wiki pages, and build process pages with latest approach - estimate is tomorrow/next day
    3. lfryc will create a jira to cover closing of /trunk and any other modules we have migrated.
    4. lfryc Please be sure to document that in the wiki updates for the workflow
  3. UNASSIGNED
    1. All - review git workflow in more detail - http://nvie.com/posts/a-successful-git-branching-model/
    2. setting up 'Git Author Names' and 'github Username' in jboss.org user profiles
    3. Review transcript for 5-10-2011 meeting and create abbreviated minutes from it.
    4. create an initial plan based on resources, timing, etc... for the release.
    5. include ne or two cool skins which will be based on design from jboss.org guys in the planning
    6. create JIRAs for QE to cover one skin and one for styling current components
    7. need to migrate sandbox to Git
    8. I suggest rename the examples


People present (lines said)

  1. balunasj_mtg (144)
  2. lfryc (57)
  3. bleathem_ (38)
  4. ppitonak (7)
  5. nbelaevski (5)
  6. jbott (4)
  7. jbossbot (3)
  8. alexsmirnov (1)


Generated by MeetBot 0.1.4.