08:05:18 <maxandersen> #startmeeting
08:05:25 <jbott> Meeting started Thu Feb 17 08:05:18 2011 UTC.  The chair is maxandersen. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:05:25 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:05:40 <maxandersen> #topic release notes
08:05:55 <maxandersen> jumping right into it - busy morning ;)
08:06:03 <mcasperson> thats fine with me
08:06:26 <maxandersen> I marked a few issues with release notes - maybe just one ;)
08:06:42 <maxandersen> i don't think we will get closer to get more issues marked.
08:06:55 <maxandersen> not sure if you saw changes/updates from anyone on these ?
08:07:32 <mcasperson> I had a look this morning against the JIRAs, and there didn't seem to be any changes
08:07:37 <mcasperson> which one did you mark?
08:08:06 <maxandersen> let me see if i cna find it…was the one mark said soa wanted in there.
08:08:36 <mcasperson> I don't think I saw that. I'll get that put in tomorrow then
08:09:06 <maxandersen> darn vpn - 2 sec ill find it.
08:11:45 * maxandersen frantically searching
08:12:25 <mcasperson> thats ok, send me an email and I'll put it in tomorrow morning
08:12:31 <maxandersen> mcasperson:  https://issues.jboss.org/browse/JBDS-1554
08:13:39 <mcasperson> ah, ok. that issue is actually in the known issues already. the workaround is listed as "open up the perspective manually"
08:13:49 <mcasperson> i'll update it with the specifics tomorrow
08:15:04 <maxandersen> mcasperson: ah ok goodie - sorry didn't have the foresight to verify with release notes ;)
08:15:18 <maxandersen> ok so release notes covered.
08:15:42 <maxandersen> #action mcasperson checks if JBDS-1554 needs more specifics and if needed update release notes.
08:15:46 <maxandersen> agreed ?
08:16:04 <mcasperson> yep, i'll get that done first thing tomorrow
08:16:11 <maxandersen> roge
08:16:17 <maxandersen> roger ;)
08:16:24 <maxandersen> #topic installation and update site information
08:17:17 <maxandersen> Which doc relates to this ? I just realized we might not cover the updatesite info for JBDS 4 this morning and would like to have  a quick look to see if we need something there.
08:17:54 <mcasperson> actually i don't think the update sites have been covered for JBDS, only Jboss tools
08:18:22 <maxandersen> for JBDS 3 we had a document outlining these...
08:18:41 <mcasperson> hmmm. I do seem to remember something about a password protected update site
08:18:48 <maxandersen> yes
08:18:55 <mcasperson> but i never had a password, so I didn't confirm it
08:19:21 <mcasperson> it;s probably in the getting started guide, or the beginners guide
08:19:47 <maxandersen> i.e. http://www.jboss.com/products/devstudio/ links to it but since docs changed their links (again ;) the links are broken.
08:20:17 <maxandersen> http://www.redhat.com/docs/en-US/JBoss_Developer_Studio/3.0/html/Update_Guide/chap-update_site_configuration.html
08:20:49 <mcasperson> ah, ok. I removed the update guide since there was no way to update from 3 to 4
08:21:11 <maxandersen> well there is for 4 to 4.x's
08:21:24 <maxandersen> and there is the technical preview site. which includes the BPEL plugins.
08:21:52 <mcasperson> ok. i'll have to get the details for the 4.x docs.
08:22:00 <mcasperson> is the technical preview site a password protected thing?
08:22:37 <maxandersen> currently yes.
08:23:30 <mcasperson> i guess those details should also go in the release notes (since the new intro does mention the technical previews). can I get a password and the url?
08:23:35 <maxandersen> so question is how we do that …let me see what the docs says now.
08:23:48 <mcasperson> i don't think we do
08:24:27 <maxandersen> the docs just need to say its provided when downloading JBoss Developer Studio.
08:24:36 <maxandersen> let me grab the url.
08:25:28 <maxandersen> crap - nick isn't on.
08:25:33 <mcasperson> so the "update site" is not an eclipse P2 thing then? it's included in JBDS?
08:25:41 <maxandersen> its an eclipse p2 thing yes
08:26:10 <mcasperson> but the site is already configured when you install JBDS?
08:26:28 <maxandersen> okey - I can give you the outline of these, their names and the url as I think they will be - but need nickboldt to verify - that will happen end of my day - giving it you early your day i reckons.
08:28:39 <mcasperson> great. so we just need to mention the urls in the release notes then?
08:28:50 <mcasperson> so people can grab the previews if they want to
08:28:54 <mcasperson> ?
08:29:03 <maxandersen> yes
08:29:26 <maxandersen> so there are three sites - the main, the extras and tech preview site.
08:29:36 <maxandersen> main and extras are installed by default.
08:29:48 <maxandersen> tech preview needs to be added manually.
08:30:27 <mcasperson> no problem. so they add the P2 site, which then prompts them for their access.redhat.com credentials?
08:31:29 <maxandersen> I wish
08:31:51 <maxandersen> its a one time password we give out at the time of download (at least thats the idea/plan right now)
08:32:11 <maxandersen> might be PM decides we can pull the password requirement.
08:32:23 <mcasperson> when will that be decided?
08:32:32 <maxandersen> red hat IT couldn't provide us with the means of having single signon.
08:32:50 <maxandersen> I'll make sure it gets cleared out ASAP - hopefully on todays call.
08:33:30 <mcasperson> sounds complicated... so what should get put in the docs, or will that be decided in a meeting later today?
08:34:02 <maxandersen> maybe you can write something like "If the update sites requests a password use the one provided to you when downloading JBoss Developer Studio or contact Red Hat Support for information if you are missing the username/password" ?
08:34:12 <maxandersen> yes its utterly complicated and annoying.
08:34:41 <mcasperson> hmmm, the old "contact your system administrator" palm off. I can totally do that :P
08:35:16 <maxandersen> :)
08:35:44 <mcasperson> well, if anything gets decided in the next 12 hours just email me an I'll update the notes accordingly
08:36:34 <maxandersen> http://devstudio.jboss.com/updates/4.0/staging/
08:36:46 <maxandersen> that url will change to be http://devstudio.jboss.com/updates/4.0
08:37:12 <maxandersen> thus you can remove the staging part from those urls on that page to get the final one.
08:37:29 <maxandersen> i'm 99% that is/will be the case - ill get verification later today on that.
08:37:34 <mcasperson> so http://devstudio.jboss.com/updates/4.0 will get put in the docs, but I can test with http://devstudio.jboss.com/updates/4.0/staging/
08:37:46 <maxandersen> staging/techpreview is the techpreview site
08:37:50 <maxandersen> yes
08:38:25 <mcasperson> just so i'm clear, if the customers want a tech preview (of say BPEL) they use http://devstudio.jboss.com/updates/4.0/staging/
08:38:47 <mcasperson> http://devstudio.jboss.com/updates/4.0 contains the actual released and supported version of JBDS
08:38:51 <mcasperson> ?
08:41:32 <maxandersen> sorry - was sending mail to push PM to take decison on passwords.
08:41:59 <maxandersen> the root url is just the info page.
08:42:07 <maxandersen> sorry forget me.
08:42:36 <maxandersen> yes - devstudio.jboss.com/updates/4.0 is the *main* supported plugin update site - it is automatically configured within JBDS.
08:43:38 <maxandersen> 4.0/extras is the 3rd party sites - currently just contain springide and testng; others might get added.
08:43:52 <maxandersen> its also preconfigured.
08:44:27 <maxandersen> 4.0/techpreview is not preconfigured thus must be added manually and you add it as eclipse p2 updatesite.
08:45:18 <mcasperson> so the url that customers need to know is http://devstudio.jboss.com/updates/4.0/techpreview, which at this point may or may not prompt you for a password
08:45:22 <maxandersen> about 4.0/techpreview I would write something like "The tech preview site is at http://devstudio.jboss.com/updates/4.0/techpreview, if you do not already see this in the list of update sites of JBoss Developer Studio you add it in <bla blah about how to add an eclipse p2 updatesite>"
08:45:28 <mcasperson> ok
08:47:56 <mcasperson> maxandersen, so apart from some additional info on how to manually select a perspective for https://issues.jboss.org/browse/JBDS-1554 and adding some info on the techpreview P2 site, are there any other changes we need to make?
08:48:59 <maxandersen> the remainder is the "Installation docs" to be uploaded - I guess that one should have notice update udpdatesites too ?
08:50:24 <mcasperson> Good idea. I emailed Mark with the version of the docs as they stood this morning. If you are going to be chatting with him later on maybe you can mention that they will be updated and I'll email him a new copy tomorrow?
08:53:04 <maxandersen> mcasperson: are those docs available somewhere for me to reach ?
08:53:08 <maxandersen> i will.
08:53:28 <maxandersen> #action maxandersen sync with PM and PPM on update site /installation instructions.
08:53:45 <maxandersen> #action mcasperson incorpoate updatesite info to docs
08:54:17 <maxandersen> mcasperson: you can also mention http://devstudio.jboss.com/updates/4.0 will always have the latest info in case something changes/breaks/whatnot ;)
08:54:26 <mcasperson> the "installation guide" is just chapter 3 of the getting started guide built into a seperate doc - http://docs.redhat.com/docs/en-US/JBoss_Developer_Studio/4.0/html-single/Getting_Started_Guide/index.html#installation
08:55:04 <mcasperson> although i did edit the screenshots to remove the references to "CR1"
08:55:11 <maxandersen> hmm….not sure why jboss tools installation is covered in there ?
08:55:38 <mcasperson> i couldn't tell you... that was how the docs were handed to me
08:55:59 <maxandersen> this is weird - these are "newish" docs (i.e. jbosst ools 3.2 *trunk* sites are mentioned)
08:56:13 <maxandersen> gawd…that part should simply be removed.
08:56:37 <mcasperson> thats easily done
08:56:49 <maxandersen> 3.3 should just get removed.
08:57:18 <maxandersen> #action mcasperson remove 3.3 in geting started guide - jboss tools installation instructions are irrelevant here.
08:58:40 <mcasperson> i'll do that tomorrow and email Mark the new version with the P2 tech preview site mentioned
08:59:40 <maxandersen> great - sorry for the last minute rumble.
09:00:31 <maxandersen> ok mcasperson im shifting over to china sync - anything else we need to sync on ?
09:00:35 <maxandersen> ah yes ..
09:00:39 <maxandersen> #topic face2face
09:01:15 <maxandersen> ill be sending out a link to a doodle site where I'll ask everyone to give a yes, maybe, no chance on their availability for face2face meeting in Brno.
09:01:39 <maxandersen> this is asked in context outside of budget discussions - just about personal availability to do it.
09:01:58 <maxandersen> then afterwards we'll see who can go when and how long budget stretches us.
09:02:23 <mcasperson> sounds good
09:02:55 <maxandersen> did you talk to jmy/jwulff about it ?
09:03:12 <mcasperson> he hasn't been in the office this week
09:03:17 <maxandersen> Rodney said he would be reaching out to doc team soon.
09:03:22 <maxandersen> ok
09:03:27 <mcasperson> and i keep forgetting to catch him on IRC
09:03:32 <maxandersen> ok - so i guess that calls the end of this meeting  ? :)
09:03:37 <maxandersen> :)
09:03:47 <maxandersen> #endmeeting