08:02:35 <maxandersen> #startmeeting
08:02:49 <jbott> Meeting started Thu Feb 10 08:02:35 2011 UTC.  The chair is maxandersen. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:02:49 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:02:49 <maxandersen> jbott: #startmeeting
08:02:59 <maxandersen> LOL :)
08:03:08 <jbott> maxandersen: Error: "#startmeeting" is not a valid command.
08:03:08 <maxandersen> ah there we go
08:03:18 <maxandersen> #topic Doc readyness for Final
08:03:28 <maxandersen> he seems a bit slow ;)
08:03:55 <mcasperson> ok, jbott good to go?
08:04:04 <maxandersen> ok mcasperson, anything for that topic ?
08:04:13 <maxandersen> yup - jbott seems all ready - just slow starter apparently.
08:04:48 <mcasperson> yeah. I fixed up what I could with the JIRAs that have come in. A few wanted new features which I'll have to put into the next release. What I have now has been submitted to Dominick for QE
08:05:10 <maxandersen> #info I fixed up what I could with the JIRAs that have come in. A few wanted new features which I'll have to put into the next release. What I have now has been submitted to Dominick for QE (via mcasperson)
08:05:30 <mcasperson> so at this point I'm really just waiting to hear back from QE
08:05:40 <maxandersen> ok sounds good QE gets some time looking at docs.
08:05:50 <mcasperson> do I have to use the hash tags for the bot?
08:05:59 <maxandersen> mcasperson: just for the items you want in the meeting minutes.
08:06:09 <mcasperson> ok
08:06:31 <mcasperson> i've been reluctant to modify the docs before (or while) they are being QE'ed
08:06:41 <maxandersen> the rest will also be available for a full log but highlights that are done via the hashtags gets summarized.
08:06:50 <maxandersen> mcasperson: understandably.
08:07:08 <maxandersen> so for the overall docs, the ball is primarily at QE right now, right ?
08:07:34 <maxandersen> #idea next time this close to GA we should ensure to get QE on this meeting ;)
08:08:03 <maxandersen> #nick dpospisi
08:08:20 <maxandersen> #action dpospisi to come back with feedback on Docs
08:08:38 <mcasperson> #info Sounds like a good idea. The only thing that needs to be done is getting the install docs as part of the JDBS download. But again I'm waiting for the QE (because the install procedure document is just a subsection of the getting started guide)
08:08:57 <maxandersen> ok
08:10:02 <maxandersen> With respect to other docs I really need to find some time to go over them at least just briefly to see if there are ancient stuff in there…i.e. do we still have the exadel studio migration guide in there  ? (maybe that was already removed)
08:10:31 <mcasperson> no, that doc has been removed
08:11:39 <mcasperson> I suspect that there is a lot of old information in the docs themselves. to be honest I don't know the tools well enough to know if the content in the docs is relevant.
08:11:57 <mcasperson> but there have not been too many JIRAs about out of date content, so it might be ok
08:12:21 <maxandersen> well, I think/fear thats probably more to do with devs not checking ;)
08:12:44 <mcasperson> i thought that might be the case...
08:12:54 <maxandersen> which I really need/want to get better for this next round.
08:13:24 <mcasperson> I'll need to get some details from you about posting the docs on jboss.org
08:13:42 <mcasperson> Isaac mentioned it was a sftp copy job, but i don't have any details
08:14:11 <maxandersen> at least have the plugins reference docs kept uptodate by devs and then you guys can focus on more highlevel/crosscutting docs and possibly "humanification"/review of the produced ref guides.
08:14:32 <maxandersen> #action maxandersen to outline reference guide goals/push to devs
08:14:41 <maxandersen> #topic jboss.org doc uploads
08:15:10 <maxandersen> yeah so jboss.org - let me see if I can recall that..
08:16:18 * maxandersen frantically searching mails/jboss.org
08:16:45 <maxandersen> #link http://community.jboss.org/wiki/HowtoWriteDocumentationforJBDSandJBossTools#Upload_to_the_site should have had the info but doesnt ;(
08:17:26 <maxandersen> getting closer - upload is to filemgmt.jboss.org
08:18:05 <mcasperson> ftp, sftp, ssh...?
08:18:53 <maxandersen> got it.
08:19:07 <maxandersen> possible commands are  scp sftp rsync
08:19:26 <maxandersen> no ssh unfortunately which would have been great for uploading zip and then unzip.
08:19:43 <maxandersen> so yeah, we need to get your ssh key uploaded to that server.
08:20:08 <maxandersen> #action maxandersen send request to helpdesk about granting mcasperson access to tools@filemgmt.jboss.org
08:20:44 <mcasperson> I expect https://issues.jboss.org/browse/JBIDE-7775 ties in with that
08:21:01 <maxandersen> #action mcasperson send me his public ssh key to use with the filemgmt request
08:21:29 <maxandersen> mcasperson: yes #link https://issues.jboss.org/browse/JBIDE-7775 relates to that
08:21:42 * maxandersen wonders if hashtags work in midsentence..
08:22:00 <maxandersen> #idea check if unzip works on sftp
08:22:27 <maxandersen> nope ;(
08:22:45 <maxandersen> #action maxandersen to ask if unzip is somehow doable on filemgmt.
08:23:03 <maxandersen> okey, I think that covers that issue - agreed ? additions ?
08:23:16 <mcasperson> Thats fine. I just emailed you my public key
08:23:36 <maxandersen> mcasperson: its cheating to do actions items before meeting notes are done ;) (jk)
08:23:46 <maxandersen> great
08:23:57 <maxandersen> #topic Release Notes
08:24:19 <maxandersen> so I know you have sent me a few emails and I haven't replied to all of them (I was on partial PTO)
08:24:37 <maxandersen> are there any outstanding questions I haven't answered/reacted to ? mcasperson ?
08:25:28 <mcasperson> Not as far as release notes go. I've documented the Known Issues as best I can (the JIRAs aren't much help for these bugs).
08:25:50 <mcasperson> I expect what I have done will have to do. The developers are a bit slow responding to my emails for more information.
08:26:20 <maxandersen> #info Not as far as release notes go. I've documented the Known Issues as best I can (the JIRAs aren't much help for these bugs).
08:26:30 <maxandersen> I expect what I have done will have to do. The developers are a bit slow responding to my emails for more information. (via mcasperson)
08:27:01 <maxandersen> okey - about developers being slow; is that to react on jira, direct emails or the mailnglist requests ?
08:27:12 <mcasperson> I've been emailing them directly
08:27:52 <maxandersen> #idea mail devs directly but cc the list too; and even better assign the matching jira to them on top of that.
08:28:28 <maxandersen> then I and everyone else - including devs can see what is outstanding.
08:28:40 <mcasperson> that would be the external exadel list?
08:28:59 <maxandersen> mcasperson: yes
08:29:37 <mcasperson> ok. Josh actually wanted the list of docs that are to go public posted to him by tomorrow, so I might have to go with what I have for now
08:29:46 <maxandersen> mcasperson: optimally jbds specfiic stuf goes there and jbosstools stuff goes to jbosstools-dev list - but lets just keep it simple for now. external exadel list.
08:29:57 <maxandersen> mcasperson: yikes ;)
08:30:11 <maxandersen> so for main docs it should be "fine"
08:30:21 <maxandersen> my main concern is install docs and release notes
08:30:33 <maxandersen> #action maxandersen to review release notes and install docs
08:30:55 <maxandersen> #action mcasperson send maxandersen link to the latest version of release notes and install docs
08:31:15 <mcasperson> Ok. I'll put the current version of the release notes up on the stage and send you the link
08:31:32 <maxandersen> mcasperson: excellento!
08:32:02 <maxandersen> mcasperson: and feedback is simplest to add into TOOLSDOC jira, correct ?
08:32:11 <mcasperson> I think so
08:32:23 <maxandersen> ok
08:32:33 <maxandersen> #topic TOOLSDOC jira
08:32:43 <maxandersen> on that note...
08:32:57 <maxandersen> #info im seeing a bunch of issues in TOOLSDOC assigned for isacc rooskov
08:33:17 <maxandersen> maybe those should get autoassigned to you instead now that isac aint around at the moment ?
08:33:29 <maxandersen> i.e. jira TOOLSDOC-98
08:33:54 <maxandersen> TOOLSDOC-107,108,110,139 and 141
08:34:07 <maxandersen> all set to the final release.
08:34:42 <mcasperson> Issac did mention that most of these would probably have to be dealt with in the next release
08:34:52 <maxandersen> mcasperson: comments?
08:35:08 <mcasperson> I think it's unlikely that anything meaningful could be done before the 16th
08:35:25 <mcasperson> so these JIRAs will have to be incorporated into the next planning phase
08:36:15 <maxandersen> #action maxandersen to set default assignee  to mcasperson until isaac returns
08:36:24 <maxandersen> i've done that now btw.
08:36:34 <mcasperson> ok
08:36:50 <maxandersen> #action mcasperson go over the TOOLSDOC issues and set apropriate fixversion
08:37:03 <maxandersen> just so things are cleaned up and somewhat matches reality
08:38:02 <maxandersen> #info i.e. if they arent to be fixed for GA then set it to the next realistic version - and if you are missing versions to assign to you should be able to add those; if not let me know and ill add them or grant you any lacking permissions.
08:38:26 <maxandersen> mcasperson: ok?
08:38:36 <mcasperson> OK. I'll take a look at those over the next week or so.
08:38:46 <maxandersen> coolio
08:38:56 <maxandersen> now onto a more fun topic ;)
08:39:05 <maxandersen> #topic Face2Face meeting
08:40:09 <mcasperson> intriguing
08:40:19 <maxandersen> #info as sent out yesterday we're planning on setting up a F2F meeting in April, in Brno, Czech - primarily because all of QE guys are there so cheaper.
08:40:57 <maxandersen> I've asked Rodney Russ and Mark Y. to once again ping Doc managers to see if there is budget for getting a doc guy over.
08:41:21 <maxandersen> Last year we got denied until 1-2 days before so it fell through (no time to book/fly out)
08:41:38 <maxandersen> this year - I *hope* that they have remembered what they managed to agree on last time.
08:42:11 <maxandersen> so I don't know who of you can/will go; but either mcasperson or irooskov I hope will be asked to go.
08:42:35 <mcasperson> so is this something Josh is aware of?
08:42:45 <mcasperson> He hasn't mentioned anything
08:42:54 <maxandersen> mcasperson: I hope he will be soon.
08:43:53 <mcasperson> well, i'd certainly be happy to go
08:44:04 <mcasperson> but I guess that is probably a decision for Josh
08:44:14 <maxandersen> the time (April) was agreed on yesterday; I sent request to Rodney/Mark about the doc request yesterday…..if they haven't asked yet then ill ping them again today and toorrow and monday and so forth ;)
08:44:41 <maxandersen> yeah - first we need the budget and then you guys can battle it out about who can/will go ;)
08:44:59 <mcasperson> well, I'll keep it in mind
08:45:35 <maxandersen> irooskov will basically be returning from Europe a few days before April so not sure he'll be ready to got out that soon ;)
08:46:02 <mcasperson> no, probably not
08:46:12 <mcasperson> i'll dig up my pasport just in case
08:46:34 <maxandersen> I told irooskov last week that we were planning on doing it but he couldn't give a definitive answer because we didnt have fixed time ;)
08:47:22 <maxandersen> so anyway, just wanted to let you know that it is cooking but as always - our budget doesn't cover you guys - its Paul Gampe and jwulf that needs convincing ;)
08:48:40 <mcasperson> nice. i'll see what Josh has to say when he gets back in
08:50:06 <maxandersen> mcasperson: be easy on him ;)
08:50:22 <mcasperson> lol
08:50:41 <maxandersen> #topic anything else ?
08:50:59 <mcasperson> most of the other issues i have are things that are probably best dealt with when planning the next round of docs
08:51:16 <maxandersen> #info most of the other issues i have are things that are probably best dealt with when planning the next round of docs (via mcasperson)
08:51:26 <maxandersen> ok
08:51:36 <mcasperson> which is a whole new can of worms :P
08:52:08 <maxandersen> yeah - we'll have a busy time ahead after GA outlining what to do/work on; getting one of you guys to the F2F would help *immensly*
08:52:36 <mcasperson> definitely. I feel like I am playing catch up most of the time
08:53:02 <mcasperson> it would be nice to have a plan, rather than react to JIRAs and the like
08:53:31 <maxandersen> mcasperson: yes!
08:53:41 <maxandersen> #idea it would be nice to have a plan, rather than react to JIRAs and the like (via mcasperson)
08:54:24 <maxandersen> #agreed we need a plan!
08:54:44 <maxandersen> and F2F would make that so much more costeffective.
08:54:54 <mcasperson> Josh did run through the planning process briefly
08:55:08 <mcasperson> it looks good in theory
08:55:26 <maxandersen> well if that planning process is the one bound by PRD's being ready first then not gonna fly unless a miracle happens ;)
08:55:37 <mcasperson> but I imagine it will be difficult to grasp the scope and impact of the changes over email
08:55:51 <maxandersen> mcasperson: yes
08:56:27 <mcasperson> Hmmm. I think our planning is kinda contingent on a PRD
08:56:37 <maxandersen> my  "plan" is that after GA get the breather to be able to sit down and figure out what are going to be the "headlines" for JBDS 5
08:56:48 <mcasperson> oh well ;)
08:57:26 <mcasperson> that sounds like a problem for another week
08:57:43 <maxandersen> that will be fed into the PRD and PM's etc input will go into but before that falls into place we kinda already need to get started on things.
08:57:53 <maxandersen> yes
08:58:04 <maxandersen> okey - so all good for this week ?
08:58:13 <maxandersen> if yes, ill tell jbott to end the meeting
08:58:28 <mcasperson> i think so. I emailed you the release notes URL. I just tagged them private now, so they should be online in about an hour or so
08:58:38 <mcasperson> but thats everything from me
08:59:53 <mcasperson> good timing, they are starting to switch off the lights in the building.
09:00:12 <mcasperson> so i'll catch you next week maxandersen
09:01:01 <maxandersen> #endmeeting