09:05:28 <maxandersen> #startmeeting
09:05:32 <jbott> Meeting started Thu Feb 17 09:05:28 2011 UTC.  The chair is maxandersen. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:05:32 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:05:46 <Grid_> hahah, cool!
09:05:57 <dart> #topic
09:06:10 <maxandersen> hi guys, so long time we've had a chat to sync up - hope you enjoyed your vacation ;)
09:06:19 <dart> thank you
09:06:23 <maxandersen> dart:  without ann operator in here #topic wont work.
09:06:27 <Grid_> thank you
09:07:26 <Grid_> maxandersen, did you get my username of github?
09:07:33 <Grid_> it is ok?
09:07:38 <maxandersen> Grid_: yes you emailed it to me ;)
09:07:43 <maxandersen> haven't checked it yet
09:07:47 <Grid_> ok
09:08:35 <maxandersen> #info about github - please everyone get that setup so we can get the svn2git mirror configured properly. if you don't then your contributions to jbosstools won't be linked to your github identity.
09:09:12 <maxandersen> #action dart dennybj fqian add your github username to .org profile if you haven't already done it.
09:09:16 <maxandersen> ok ?
09:09:20 <dart> ok
09:09:24 <Grid_> have done
09:09:33 <dennybj> done
09:09:37 <maxandersen> have you guys worked/experimented with git ?
09:09:43 <Grid_> no
09:10:05 <maxandersen> dennybj: I guess you do for working with the drools repos ?
09:10:11 <dart> no
09:10:15 <dennybj> yes
09:11:02 <dennybj> Drools are moving to git too
09:11:25 <dennybj> I have set up the git environment in my local laptop
09:11:30 <maxandersen> they have already moved - we aren't moving (yet)…just setting up a svn/git mirror to start seeing where we can go with it.
09:11:42 <maxandersen> dennybj: how is that working out for you ? like it / hate it ?
09:11:59 <dennybj> the Eclipse plugin is not good
09:12:31 <dennybj> so I have to use command, but I still hope to have a good eclipse tool to do it
09:12:37 <Grid_> maxandersen, why does jboss tools want to move to git?
09:12:41 <maxandersen> egit ?
09:12:47 <maxandersen> Grid_: because its waay faster
09:13:02 <Grid_> Ha, got it
09:13:06 <maxandersen> because we need to split up the gigantic repo anyway at some point
09:13:10 <dennybj> yes
09:13:42 <maxandersen> and because it would allow us to have a bit more structured set of commits flowing in versus everyone doing experimental work in trunk/branches all the time.
09:14:25 <Grid_> ok
09:14:44 <maxandersen> doing those thing in SVN is just hard and github provides a much more collaborative way to work together.
09:15:16 <maxandersen> it will be a challenge no matter what but with github its more open/faster than with svn.
09:15:21 <dart> when will we start to move the project to github?
09:15:52 <Grid_> make sense
09:15:57 <maxandersen> dart: not decided yet - im just setting up the mirror to make it worth trying out.
09:16:32 <maxandersen> dart: but no matter what - we need github usernames to make the mirror properly and same author/username list will have to be collected for a possible move going forward.
09:16:59 <dart> make sense
09:17:09 <maxandersen> #topic jira
09:17:18 <maxandersen> ah that worked ;)
09:17:44 <Grid_> yes
09:17:48 <dennybj> when start moving to git, we have to commit to svn repository and git repository at the same time?
09:18:32 <maxandersen> dennybj: the svn repo will just work like a git master - you just use git dcommit instead of git commit.
09:18:54 <maxandersen> remember for git you commit at least twice anyway - locally and then remote.
09:19:21 <dennybj> got it
09:19:55 <Grid_> maxandersen, what's meaning 'git dcommit instead of git commit'?
09:20:16 <maxandersen> dcommit goes to the svn repo
09:20:36 <maxandersen> its actually git svn dcommit not just git dcommit
09:20:47 <Grid_> ha, got it
09:23:13 <maxandersen> okey - on topic of jira
09:23:52 <dennybj> where does the resource actually located, in our own server or in github.org?
09:24:16 <maxandersen> #info please take care always marking issues with proper fix version and leave comments on what you've done on them - simplest is to just do an informative svn commmit message that mentions the jira(s) and copy it over to the jira when resolving/commenting on it.
09:24:27 <maxandersen> dennybj: which resource ? the git repo ?
09:24:48 <dennybj> all codes we committed
09:25:06 <maxandersen> dennybj: for now that will synced with svn on our own server but it will push automatically to github.
09:25:10 <dennybj> since our git account are registered from github.org
09:25:23 <dennybj> got it
09:25:36 <maxandersen> dennybj: for now this is just a mirror . if we once move jboss.org/red hat will start cloning it regularly afaik.
09:25:46 <maxandersen> thats the beauty of distributed version controll.
09:26:13 <dennybj> yes, very cool
09:26:40 <maxandersen> I talked with dart yesterday and he was not aware that you could mention multiple jiras in commits - so just want to be sure you know that too ;)
09:27:23 <Grid_> ok, got it
09:27:29 <maxandersen> of course doing one commit that touch multiple jiras should be avoided as much as possible but sometimes a fix touches multiple jiras or sometimes it was simply the only way to get a patch in.
09:28:31 <maxandersen> and yeah - leaving a comment on the commit with more info than a jira reference is really recommended. setting up the git svn mirror i noticed *alot* is just putting the jira reference which doesn't say anything when looking through history to figure out why a change was done.
09:29:06 <Grid_> make sense
09:29:20 <dart> maxandersen: I leave the "reproduce steps" and a flash demo URL when I commit the codes
09:29:52 <maxandersen> dart: in the commit messages ? haven't seen that. got an example ?
09:30:05 <maxandersen> aren't you talking about the jira comments you just added ?
09:30:09 <dart> sorry , not in the commit
09:30:13 <maxandersen> ok
09:30:17 <dart> I mean in the jira comment
09:31:50 <maxandersen> dart - yes thanks - also please update the jira fix version to be correct - i believe that one is fixed in 3.3.0.M1 but still needs to get fixed in 3.2.x, right ? (thus need to stay open)
09:32:31 <dart> which one ?
09:34:37 <maxandersen> dart:  the one with the graph layout.
09:34:44 <dart> get it
09:34:49 <dart> yes , it is
09:34:58 <maxandersen> all the isuses you recently updated was targeted for 3.2.x inclusion right ?
09:35:40 <dart> yes
09:36:01 <dart> so , all of them are targeted for 3.3 also ?
09:37:41 <maxandersen> dart - you fixed them in trunk right ? that is 3.3
09:38:02 <dart> yes
09:41:55 <maxandersen> #topic docs
09:42:39 <maxandersen> about docs I saw Grid_ did some WS docs suggestions - unfortunately matt havene't had time to incorporate them for GA. next time we'll need to be out earlier with doc updates.
09:42:44 <maxandersen> but good we have them now.
09:42:54 <maxandersen> have you guys otherwise looked at docs
09:42:58 <maxandersen> ?
09:43:10 <dart> yes
09:43:28 <dart> but everything in the docs is the old one
09:43:59 <dart> I didn't if Tom wrote the docs for new features
09:44:27 <maxandersen> dart:  have you reported that ? mentioned it to Tom ? talked with docs ?
09:45:00 <dart> not yet , let me review the docs again
09:45:06 <dart> maybe i miss it
09:46:11 <maxandersen> dart - you need to be more proactive about these things - not just think others are doing things you notice are missing ;)
09:46:38 <dart> ok
09:48:55 <dennybj> ok, need to review related docs before every release,
09:50:47 <maxandersen> yes - or even better - while finishing of a feature and its stable then sync/provide update to docs.
09:51:03 <Grid_> got it
09:51:45 <maxandersen> ok guys - i need to run soon - you guys have any other questions ?
09:52:01 <dennybj> can we update docs directly or just ask doc team guys to do ti?
09:52:05 <dennybj> it
09:53:09 <maxandersen> btw. once GA is out ill start sending out overall plans/themes for next major release(s) but for SOA that will be via Brian F.
09:53:13 <Grid_> I no questions
09:54:03 <dennybj> ok
09:54:37 <maxandersen> dennybj: depends on the kind of update - if larger texts i would create a patch, open TOOLSDOC jira and ping docs about it and figure out best way to get it in.
09:54:57 <dennybj> got it
09:56:09 <maxandersen> ok - if nothing else ill end the meeting.
09:56:13 <maxandersen> #endmeeting