21:00:12 <lightguard_jp> #startmeeting
21:00:12 <jbott> Meeting started Wed Jun  8 21:00:12 2011 UTC.  The chair is lightguard_jp. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:12 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:00:22 <lightguard_jp> Welcome everyone!
21:00:28 <jose_freitas> hola
21:00:31 <lightguard_jp> Thanks for coming
21:00:33 <antoine_sd> salut
21:00:40 <gastaldi> Olá ! :)
21:01:00 <lightguard_jp> First order of business
21:01:06 <lightguard_jp> #topic Seam Reports 3.0.0.Alpha1
21:01:28 <lightguard_jp> gastaldi is working on this and should be out this week
21:01:35 <gastaldi> oh yeah, I wanted to release it before the meeting started, but got no luck since then :)
21:01:37 <lightguard_jp> gastaldi: Shane said there were some problems when he tried to do the release.
21:01:40 <lightguard_jp> Did he email you?
21:01:53 <gastaldi> lightguard_jp: Cool, I need to check with him what is wrong
21:02:13 <gastaldi> #action: Check with sbryzak what´s wrong about the Seam Reports release
21:02:29 <gastaldi> nope
21:02:29 <lightguard_jp> I didn't get an email either, so I'm not sure what the problems were
21:02:40 <lightguard_jp> #chair mojavelinux
21:02:40 <jbott> Current chairs: lightguard_jp mojavelinux
21:02:58 <gastaldi> I would like to add also the need for automation in the release process
21:03:02 <lightguard_jp> #action sbryzak Will get with gastaldi to discuss problems with Reports Alpha release
21:03:19 <lightguard_jp> We're going to be working on it
21:03:30 <kenfinnigan> +1 to automated releases
21:03:31 <lightguard_jp> We need someone to do some research and see what's required to do this
21:03:36 <gastaldi> As you all may know, there is a Jenkins running in Cloudbees (just to context)
21:03:41 <gastaldi> Yeah
21:04:08 <lightguard_jp> gastaldi: Do you want to do the research and get back to us by next meeting with your findings?
21:04:40 <gastaldi> I am afraid I won´t have enough time to do that, but I can help
21:05:02 <lightguard_jp> Is there anyone else that would like to help with the research?
21:05:18 <antoine_sd> +1 for automation
21:05:58 <gastaldi> I believe it´s an easy task, just need to make CloudBees set up properly
21:06:28 <lightguard_jp> #agreed automating the releases is what we all want
21:06:44 <lightguard_jp> Okay, we'll dig some then and see what we can find.
21:06:54 <lightguard_jp> Next topic
21:06:56 <kenfinnigan> I guess the thing though is would we want it to make a release every time a cloudbees build succeeds? or be able to trigger it?
21:07:09 <gastaldi> #link Supported plugins in CloudBees: http://web-static-cloudfront.s3.amazonaws.com/docs/supportedPlugins.pdf
21:07:09 <lincolnthree1> Should be able to choose a successful build/tag and release that.
21:07:11 <lightguard_jp> No, it would be triggered
21:07:19 <lincolnthree1> Not completely automatic.
21:07:21 <kenfinnigan> ok cool
21:07:21 <lightguard_jp> gastaldi: URI first, then text
21:07:26 <gastaldi> Oh, sorry
21:07:40 <gastaldi> #link http://web-static-cloudfront.s3.amazonaws.com/docs/supportedPlugins.pdf Supported Plugins in CloudBees
21:08:03 <lightguard_jp> We'll look and see what we can find, also we'll talk to CloudBees and see what they have to say
21:08:14 <lightguard_jp> #topic Action items from last week
21:08:22 <lightguard_jp> I'll take my two first
21:08:35 <lightguard_jp> Errai had the changes that were requested
21:08:38 <lightguard_jp> That one is done
21:08:48 <lightguard_jp> #info Errai changes complete
21:09:02 <lightguard_jp> #info git flow task will be discussed further in depth later in the meeting
21:09:16 <lightguard_jp> sbryzak: Are you here?
21:09:51 <lightguard_jp> :( maybe not
21:10:06 <lightguard_jp> cbrock isn't here either
21:10:11 <gastaldi> :(
21:10:34 <lightguard_jp> NickServ hasn't seen him for a while either
21:10:36 <jose_freitas_aw> sorry guys, have to go
21:10:43 <lightguard_jp> jose_freitas_aw: np
21:10:53 <lightguard_jp> I guess we'll have to follow up with Shane or Mike later
21:11:01 <jose_freitas_aw> bye
21:11:08 <gastaldi> jose_freitas_aw: bye
21:11:45 <gastaldi> lightguard_jp: Next topic then ?
21:11:45 <lightguard_jp> I don't think adding the vote date to the Google calendar was completed
21:11:47 <antoine_sd> jose_freitas_aw: see you
21:11:55 <lightguard_jp> mojavelinux: Did you take care of it?
21:12:30 <gastaldi> I guess mojavelinux is not here either :)
21:12:32 <mojavelinux> nope, not yet. do we have a calendar? I was just going to add it to my calendar
21:12:39 <gastaldi> ah there he is
21:13:01 <mojavelinux> hehehe
21:13:04 <mojavelinux> i'm lurking :)
21:13:05 <gastaldi> :)
21:13:24 <lightguard_jp> The Seam Google calendar
21:13:37 <lightguard_jp> I might have the creds floating around somewhere to change it
21:13:40 <lightguard_jp> I'll have to look
21:14:11 <mojavelinux> ah, okay...well, if you find it, how about publish those creds to (or make them available to the core team so we can share them when need be)
21:14:11 <lightguard_jp> #action Either lightguard_jp or mojavelinux will make the changes to the official Seam Google calendar about the community position elections
21:14:43 <lightguard_jp> Will do
21:14:59 <mojavelinux> it should be Dec. 1
21:15:06 <lightguard_jp> Makes sense
21:15:10 <mojavelinux> #info The next votes for community roles will be Dec 1, 2011
21:15:11 <gastaldi> cool
21:15:36 <gastaldi> Is there a possibility of re-election ? :)
21:15:41 <lightguard_jp> Hm
21:15:44 <mojavelinux> of course, it's more of a check-in
21:15:45 <kenfinnigan> absolutely
21:15:52 <lightguard_jp> We didn't talk about that, but I don't see why not
21:16:20 <kenfinnigan> i would say if you want the position and no one else is nominated then its an automatic renewal
21:16:29 <lightguard_jp> #agreed reelections of community spots are okay
21:16:46 <lightguard_jp> Makes sense
21:16:52 <gastaldi> Jason will be our Jedi man ! :)
21:17:03 <lightguard_jp> mojavelinux: We should probably write these down on the site
21:17:48 <lightguard_jp> Any other questions or comments about the elections?
21:18:20 <kenfinnigan> not from me
21:18:22 <lightguard_jp> Okay :)
21:18:31 <lightguard_jp> #topic JRebel Licenses
21:18:35 <gastaldi> yay !
21:18:57 <lightguard_jp> Five licenses went out to members of the community. If you want one let us know and we can hook you up
21:19:06 <lightguard_jp> Let's see if I can remember who they went to.
21:19:16 <antoine_sd> I've got one
21:19:25 <gastaldi> Of course, you need to be a contributor or a committer on any module
21:19:35 <gastaldi> I got one too
21:19:49 <lightguard_jp> Here we go
21:20:30 <lightguard_jp> #info licenses went to Jason, Brian, George, Jose, Lincoln and Antoine
21:21:23 <lightguard_jp> #info according to the license it's an OSS license for Seam and is usable for as many computers as we need
21:21:27 <mojavelinux> for those of you with licenses, I encourage you to give the jrebel forge plugin a go
21:21:53 <gastaldi> what ? I didn´t know there was a jrebel forge plugin ! :P
21:22:04 <lincolnthree1> there is?
21:22:07 <lincolnthree1> where?
21:22:16 <lightguard_jp> Thought someone was working on one
21:22:17 <gastaldi> omg
21:22:30 <lincolnthree1> Someone is supposedly working on one, I don't know that it works or is workign yet
21:22:57 <mojavelinux> oh, well, the dialog w/ jrebel is open
21:23:02 <mojavelinux> lincoln has their coordinates
21:23:13 <lincolnthree1> :) trying to get them into it
21:23:18 <lincolnthree1> it would be a great partnership
21:23:26 <gastaldi> agreed
21:23:30 <lincolnthree1> people who want to make development easy come to seam :)
21:23:30 <mojavelinux> they'll give us more licenses :)
21:23:42 <antoine_sd> #agreed
21:24:07 <gastaldi> cool
21:24:13 <lightguard_jp> I know those who have used it really love it.
21:24:20 <lightguard_jp> No idea if it works with AS7 yet though
21:24:29 <gastaldi> lightguard_jp: Yeah, I was one of those :)
21:25:16 <lightguard_jp> Cool, next item then, unless there are questions?
21:25:19 <antoine_sd> count me also : it changed my life (drinking less coffee)
21:25:26 <lightguard_jp> haha
21:25:47 <lightguard_jp> #topic TeamSpeak Server
21:26:07 <lightguard_jp> Shane has a TeamSpeak 3 (TS 2 clients won't work) server that's open for Seam use
21:26:24 <lightguard_jp> The info is in the topic (during non meeting times) if you'd like to use it
21:26:57 <lightguard_jp> We may use it to augment meetings, but I think IRC will still be the primary place for meetings because of jbott and meeting minutes
21:27:17 <antoine_sd> Is there only one room in TS server ?
21:27:23 <lightguard_jp> Currently
21:27:30 <lightguard_jp> We could ask Shane to create some others though
21:27:44 <gastaldi> The only thing that sucks is that it does not support proxies
21:27:44 <antoine_sd> I'm thinking about work group like code review
21:27:49 <lightguard_jp> It has 15 spots for users currently. If we need more we can upgrade.
21:28:08 <lightguard_jp> antoine_sd: That would be a very good use of it!
21:28:18 <gastaldi> #agreed
21:28:30 <kenfinnigan> like the workgroup review idea
21:28:42 <kenfinnigan> or group planning discussions where it would be easier to speak than type
21:28:56 <lightguard_jp> Yeah.
21:29:15 <mojavelinux> can you explain work group in more detail?
21:29:16 <antoine_sd> I could share my horrible french accent with you guys
21:29:17 <lightguard_jp> I think however, at least starting a meeting with jbott when something happens so it's captured somewhere needs to happen as well.
21:29:56 <kenfinnigan> definitely, even though discussion might be on TS, any actions and info, etc should be recorded textually as well
21:30:18 <antoine_sd> #agreed
21:30:30 <gastaldi> is the conversation on TeamSpeak logged somewhere ?
21:30:55 <mojavelinux> exactly, voice communication is great for everything except remembering what you discussed
21:31:01 <mojavelinux> so, it needs to be "externalized"
21:31:05 <mojavelinux> externalize aggressively
21:31:05 <lightguard_jp> #agreed Any info discussed on teamspeak that ends up with actions, info, etc should also be logged via jbott in irc
21:31:20 <lightguard_jp> gastaldi: Not unless someone does the capturing
21:31:45 <mojavelinux> many a great conversation fell victim to memory loss
21:31:52 <kenfinnigan> indeed
21:31:57 <lightguard_jp> kenfinnigan: Would you mind explaining your idea of the work group a bit more?
21:32:06 <lightguard_jp> I think mojavelinux wanted to explore it a bit more
21:32:19 <antoine_sd> but code review is a good candidate for speach
21:32:53 <lightguard_jp> #action ask shane to create more rooms in TS, or give the core developers admin rights
21:33:05 <gastaldi> I like having TeamSpeak as a collab tool. It makes you feel more envolved with the team
21:33:05 <kenfinnigan> my idea of a work group would be an adhoc/organized gathering of several experienced project members
21:33:32 <kenfinnigan> that get together to discuss/review an important API change, new module, new direction of a module, etc
21:33:42 <kenfinnigan> kind of like a branstorming/design session
21:33:46 <lightguard_jp> kenfinnigan: a more formalized idea of what has naturally happened many times here in the channel?
21:33:56 <kenfinnigan> essentially yes
21:34:02 <lightguard_jp> I like it
21:34:10 <mojavelinux> ah, got it
21:34:11 <kenfinnigan> and if there are regular items for discussion then it would meet on a semi regular basis
21:34:28 <lightguard_jp> Would we have required people there?
21:34:40 <lightguard_jp> Maybe one of the core developers if we're talking api or design?
21:34:46 <mojavelinux> yes, one thing we are lacking is pausing to look back and review the project, at times we need to look the module level and at times a bigger picture
21:34:49 <kenfinnigan> could be an elected group, or just one or two people that if possible attend all to provide continuity
21:35:14 <mojavelinux> I'm sort of thinking a time is best, then we can arrive at that time for who wants to be involved
21:35:16 <kenfinnigan> that should be all meetings
21:35:16 <lightguard_jp> I like the idea of another elected group / position
21:36:09 <lightguard_jp> Either elected or time frame would work.
21:36:22 <mojavelinux> something not too frequent to cause distractions...helps make quick progress on some of these long living threads about how to design an api
21:36:34 <kenfinnigan> you could have an elected chair/leader that runs it in conjunction with a core team member
21:36:41 <mojavelinux> like bi-weekly?
21:36:54 <mojavelinux> less often? more often?
21:36:56 <kenfinnigan> at least once a month
21:37:02 <kenfinnigan> possibly a couple more depending on workload
21:37:15 <mojavelinux> okay, how about once a month, with planned follow ups
21:37:23 <mojavelinux> if necessary
21:37:41 <kenfinnigan> sounds good
21:37:42 <lightguard_jp> I like it
21:37:46 <mojavelinux> so you say "okay, this was a good review, we aren't quite done...repeat next week"
21:38:05 <mojavelinux> or you get everything done and you just say "until next month..."
21:38:09 <lightguard_jp> #agreed a work group will meet once a month (more often if required) to discuss API / design issues as they come up
21:38:16 <mojavelinux> this would supplament discussions on the mailinglist, or could help bring them to a resolution
21:38:31 <gastaldi> #agreed with lightguard_jp
21:38:33 <gastaldi> :)
21:38:42 <kenfinnigan> definitely
21:38:56 <mojavelinux> nice
21:38:58 <lightguard_jp> Do we like the idea of an elected community member and a core member to head up the group?
21:39:07 <kenfinnigan> any major discussions from mailing list that don't get answered can be tabled to this working group
21:39:36 <mojavelinux> if you are asking if we need "architects" (cursed, did I really say that) I think the answer is that we do
21:39:52 <kenfinnigan> i would agree
21:39:55 <mojavelinux> but instead of calling them architects, we can call them designers
21:40:07 <kenfinnigan> need to move out of cowboy mode and into organized and cohesive module design
21:40:17 <gastaldi> yeah
21:40:18 <lightguard_jp> bleathem: welcome!
21:40:27 <bleathem> hey all!
21:40:35 * bleathem fresh off the plane
21:40:36 <kenfinnigan> bleathem: hope the RH induction went well!
21:40:39 <lightguard_jp> Sounds like we're agreed then?
21:40:53 <bleathem> went really well - they sure do serve good tasting kool-aid!
21:41:00 <kenfinnigan> lol#
21:41:19 <mojavelinux> we don't want to "architect" solutions to the problems, we want to "design" them, so that the framework as a stack fits in an aesthetic and efficient way
21:41:35 <mojavelinux> hahaha
21:41:39 <lightguard_jp> #agreed a work group will consist of one community elected member and a core developer to head up the design work group
21:41:45 <mojavelinux> yep, in fact, this is something jason and I have been discussing a lot lately
21:42:07 <kenfinnigan> cohesive design?
21:42:21 <mojavelinux> the core values at Red Hat seems to be best described in orientation and you often have to fight to get the old hats to remember them
21:42:25 <kenfinnigan> i know it's a concern you've raised that the modules have had relatively silo'd design/dev
21:42:29 <lightguard_jp> #info please email lightguard_jp or mojavelinux if you're interested in seeking that position
21:43:11 <lightguard_jp> #info we'll vote next week via Doodle.
21:43:23 <mojavelinux> this is the really fun position :) you get to play with code
21:43:30 <lightguard_jp> #info please get submissions in by Monday to allow time for the vote
21:43:48 <lightguard_jp> Yeah, better than answering questions on the forum ;P
21:44:15 <mojavelinux> speaking of which, we should propose that policy I suggested
21:44:19 <kenfinnigan> just realized, we're still on the TS topic
21:44:28 <kenfinnigan> does that need to be changed for these items in the log?
21:44:53 <lightguard_jp> It kinda grew out of the TS topic
21:45:02 <kenfinnigan> ok
21:46:05 <lightguard_jp> Alright then, last planned topic
21:46:09 <lightguard_jp> #topic git flow
21:46:15 <lightguard_jp> I'll field questions :)
21:46:20 <lightguard_jp> I sent out some links to the list
21:46:30 <lightguard_jp> We want to adopt this project wide
21:46:42 <kenfinnigan> +1 to that
21:46:46 <lightguard_jp> So we're going to be answering questions and getting people up to speed
21:46:58 <lightguard_jp> So we can do it and hopefully not surprise a lot of people.
21:47:05 <gastaldi> Cool
21:47:28 <gastaldi> any naming conventions on features/hotfixes ?
21:47:31 <lightguard_jp> Of those that have seen the screencast or read some of the blogs, who has questions?
21:47:33 <gastaldi> I suggest the JIRA issue number
21:47:37 <lightguard_jp> +1
21:47:43 <kenfinnigan> JIRA issue number works for me
21:47:56 <antoine_sd> +1
21:48:01 <gastaldi> cool
21:48:01 <antoine_sd> already using it
21:48:07 <lightguard_jp> #agreed feature / hotfix branches should reference a JIRA ticket
21:48:10 <gastaldi> And what about the Support branches ?
21:48:19 <lightguard_jp> I doubt we'll be using them
21:48:23 <antoine_sd> yeah I'm using Mylyn for that
21:48:24 <gastaldi> hum, ok
21:48:53 <gastaldi> I opened https://bugs.eclipse.org/bugs/show_bug.cgi?id=348610 and JBIDE-9080
21:48:54 <jbossbot> jira [3JBIDE-9080] Extend EGit to allow use of git-flow [10Open (Unresolved) Feature Request,7 Major,6 Unassigned] https://issues.jboss.org/browse/JBIDE-9080
21:48:56 <kenfinnigan> is it worth prefixing features/hotfix/develop changes with a char and the JIRA to signify the type of development?
21:49:06 <gastaldi> To allow using git-flow with EGit
21:49:15 <gastaldi> I suggest all of you vote on it :)
21:49:16 <kenfinnigan> ie. F_SEAMINTL-7 for a feature?
21:49:18 <lightguard_jp> gastaldi: There's actually been quite a bit of internal JBoss chatter on the mailing lists because of that request
21:49:26 <sbryzak> morning all.. i slept in
21:49:34 <gastaldi> welcome back sbryzak !
21:49:46 <lightguard_jp> kenfinnigan: What's the point?
21:49:46 <gastaldi> lightguard_jp: Really ? Good or bad ? :)
21:49:54 <antoine_sd> hi sbryzak
21:50:03 <lightguard_jp> feature/branch_name hotfix/branch_name kinda gives you that
21:50:05 <mojavelinux> I wouldn't mix underscore and dash, so F-SEAMINTL-7 (maybe i'm just nit picking)
21:50:06 <jbossbot> jira [3SEAMINTL-7] Provide TypeSafe Messaging API [10Open (Unresolved) Feature Request,7 Blocker,6 Ken Finnigan] https://issues.jboss.org/browse/SEAMINTL-7
21:50:13 <lightguard_jp> gastaldi: It's been good, mostly people wondering what it is.
21:50:23 <kenfinnigan> lightguard_jp: true, ignore me
21:50:24 <gastaldi> yay again !! :)
21:50:39 <mojavelinux> jboss devs tend to be a little behind the curve on these things, but I'll attribute that to hard work on AS 7
21:50:52 <gastaldi> feature/JIRAISSUE and hotfix/JIRAISSUE
21:50:53 <lightguard_jp> It was actually Max who started it
21:51:00 <lightguard_jp> gastaldi: Yep
21:51:14 <gastaldi> Cool
21:51:16 <lightguard_jp> Max is kind of a git n00b anyway :)
21:51:26 <kenfinnigan> lightguard_jp: does it still show that when merged back into develop?
21:51:29 <lightguard_jp> But he learns quickly
21:51:29 <gastaldi> lol
21:51:35 <lightguard_jp> kenfinnigan: Yep
21:51:38 <kenfinnigan> I thought the merge just took the commit name, and not the branch name?
21:51:47 <lightguard_jp> merges happen with --no-ff flag
21:51:54 <kenfinnigan> oh ok
21:52:08 <mojavelinux> yep, I never question the brightness of jboss devs, just sometimes a bit slow on the uptake
21:52:10 <lightguard_jp> Some may not like it, but that's they way it is :)
21:52:26 <lightguard_jp> I personally like seeing where stuff came frome
21:52:30 <lightguard_jp> from*
21:52:57 <gastaldi> mojavelinux: That´s why I opened the issue first on JBoss tools :)
21:52:59 <lightguard_jp> The straight line history is too much like svn / cvs where you have no idea what came in, just some code.
21:53:20 <lightguard_jp> gastaldi: There was some talk about gerrit, but I don't think people understood what git flow was about.
21:53:31 <mojavelinux> yeah, I think we should adopt git as it is intended and not try to make it to weird stuff just because it's more familiar to us
21:53:41 <mojavelinux> I defer to matthew on recommendations there
21:54:22 <lightguard_jp> Yep
21:54:23 <gastaldi> nice
21:54:29 <gastaldi> Is there any other Jboss project using git-flow ?
21:54:42 <lightguard_jp> Not that I know of
21:54:49 <lightguard_jp> Infinispan kinda
21:54:57 <lightguard_jp> They're own homegrown process it seems
21:55:20 <gastaldi> Hum, that could become standard in JBoss, just like trunk/branches/tags is for SVN
21:55:28 <mojavelinux> arquillian I believe
21:55:33 <mojavelinux> to some degree
21:55:54 <gastaldi> nice
21:56:11 <lightguard_jp> aslak doesn't like the --no-ff for the merges
21:56:22 <lightguard_jp> I think Lincoln is in that camp too :)
21:56:56 <mojavelinux> what does matthew think?
21:57:30 <mojavelinux> we can take that offline
21:57:35 <mojavelinux> i'm just curious
21:57:56 <kenfinnigan> ok all, dinner on the table, need to run
21:58:12 <sbryzak> gastaldi: the seam reports distribution needs a little work before we release it
21:58:14 <mojavelinux> see ya ken! thanks for attending
21:58:23 <lightguard_jp> Matthew I think is somewhat indifferent.
21:58:23 <lightguard_jp> Kinda up to the project and how they want their history to look
21:58:23 <lightguard_jp> For me, development isn't linear, why force your history to be?
21:58:56 <lightguard_jp> That's actually good timing
21:58:57 <antoine_sd> I prefer --no-ff
21:59:08 <gastaldi> sbryzak: Can you email me what needs to be changed on Seam Reports?
21:59:09 <lightguard_jp> We're pretty much wrapping up I think
21:59:30 <mojavelinux> yep, anything else on the list?
21:59:33 <sbryzak> gastaldi: it's a pretty short list, i can just tell you
21:59:52 <gastaldi> sbryzak: ok, shoot
21:59:52 <lightguard_jp> Nope
22:00:02 <lightguard_jp> I think we're done.
22:00:04 <sbryzak> gastaldi: re the design, is a user supposed to pick either one reports implementation or the other?
22:00:05 <lightguard_jp> Good meeting all!
22:00:11 <lightguard_jp> Great ideas brought up.
22:00:15 <lightguard_jp> I love this community!
22:00:31 <mojavelinux> +1
22:00:38 <lightguard_jp> #endmeeting