#seam-dev Meeting

Meeting started by mojavelinux at 21:04:49 UTC (full logs).

Meeting summary

  1. Action Items from last week (lightguard_jp, 21:06:07)
    1. I spoke with Jay re: the dataexport from jsf data tables (bleathem, 21:08:13)
    2. short answer is RichFaces 4 planned to add support for this, but not shceduled for a release version yet (bleathem, 21:08:56)
    3. follow-up for further discussion on the RichFaces forums, to discuss any Seam tie-in (bleathem, 21:09:18)
    4. http://seamframework.org/Community/CommunityRoles (mojavelinux, 21:12:44)
    5. http://seamframework.org/Community/CommunityRoles (lightguard_jp, 21:13:39)
    6. AS7 can be embedded cleanly for arquillian tests (lightguard_jp, 21:14:09)
    7. there is no GWT Module (mojavelinux, 21:18:10)
    8. rather, we have Errai CDI (mojavelinux, 21:18:21)
    9. Errai CDI brings the CDI programming model to GWT, both on the client and server side (mojavelinux, 21:18:38)
    10. Errai is the bus that handles the event roundtripping (mojavelinux, 21:18:57)
    11. ACTION: lightguard_jp finish the GWT module -> Errai CDI (lightguard_jp, 21:19:30)
    12. IDEA: use Errai to power Seam Remoting (or other Ajax/push technology stacks) (mojavelinux, 21:23:10)
    13. http://refcardz.dzone.com/refcardz/nodejs-building-scalability (mojavelinux, 21:24:37)
    14. ACTION: sbryzak will talk with cbrock about errai and flesh out the seam remoting / errai idea (lightguard_jp, 21:33:18)
    15. also need to get Jay involved in this for RichFaces push (lightguard_jp, 21:33:40)
    16. https://github.com/seam/ticket-monster (gastaldi, 21:38:07)
    17. ACTION: Shane will copy paste the ticket monster (bastard) design documents to the Seam wiki so more people can play (mojavelinux, 21:41:03)
    18. ACTION: or, put them in a design.md file in the source tree (mojavelinux, 21:41:14)

  2. Results of the Polls (lightguard_jp, 21:43:15)
    1. Community integrator was a pretty tight race (lightguard_jp, 21:43:49)
    2. George Gastaldi will be our next Community Integrator (lightguard_jp, 21:44:03)
    3. Forum Jedi support overwhelmingly went in favor of Jason Porter (lightguard_jp, 21:46:23)
    4. AGREED: revote for these positions again in 6 months (lightguard_jp, 21:48:07)
    5. ACTION: set event in calendar for next vote on community roles (mojavelinux, 21:48:07)

  3. Code Reviews (lightguard_jp, 21:50:33)
    1. ACTION: take steps to shift modules to using git flow; first step is to clarify what it is on the mailinglist (mojavelinux, 21:56:44)
    2. ACTION: lightguard_jp will field questions about git flow after the meeting or at some other time (lightguard_jp, 22:01:47)

  4. Meet bi-weekly instead of each week (lightguard_jp, 22:02:07)
    1. IDEA: schedule along with the agenda (lightguard_jp, 22:05:51)
    2. AGREED: Create a schedule along with next week's agenda (lightguard_jp, 22:06:33)
    3. AGREED: meetings will continue each week (lightguard_jp, 22:06:40)

  5. Compatibility Module (lightguard_jp, 22:09:15)


Meeting ended at 22:18:37 UTC (full logs).

Action items

  1. lightguard_jp finish the GWT module -> Errai CDI
  2. sbryzak will talk with cbrock about errai and flesh out the seam remoting / errai idea
  3. Shane will copy paste the ticket monster (bastard) design documents to the Seam wiki so more people can play
  4. or, put them in a design.md file in the source tree
  5. set event in calendar for next vote on community roles
  6. take steps to shift modules to using git flow; first step is to clarify what it is on the mailinglist
  7. lightguard_jp will field questions about git flow after the meeting or at some other time


Action items, by person

  1. lightguard_jp
    1. lightguard_jp finish the GWT module -> Errai CDI
    2. lightguard_jp will field questions about git flow after the meeting or at some other time
  2. sbryzak
    1. sbryzak will talk with cbrock about errai and flesh out the seam remoting / errai idea
  3. UNASSIGNED
    1. Shane will copy paste the ticket monster (bastard) design documents to the Seam wiki so more people can play
    2. or, put them in a design.md file in the source tree
    3. set event in calendar for next vote on community roles
    4. take steps to shift modules to using git flow; first step is to clarify what it is on the mailinglist


People present (lines said)

  1. mojavelinux (191)
  2. lightguard_jp (78)
  3. gastaldi (76)
  4. bleathem (57)
  5. kenfinnigan (30)
  6. sbryzak (30)
  7. johnament (20)
  8. jose_freitas (16)
  9. jbossbot (8)
  10. jharting (7)
  11. rruss (4)
  12. jbott (4)
  13. PeteRoyle (2)
  14. clerum (2)


Generated by MeetBot 0.1.4.