21:05:53 <lightguard_jp> #startmeeting
21:05:59 <jbott> Meeting started Wed May 11 21:05:53 2011 UTC.  The chair is lightguard_jp. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:05:59 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:05:59 <bleathem> edburns: I don't know if you noticed yet, but Seam Faces converts all JSF scopes into CDI scopes - meaning a developer can use the javax.faces.bean scopes
21:06:04 <lightguard_jp> #chair sbryzak
21:06:09 <jbott> Current chairs: lightguard_jp sbryzak
21:06:15 <lightguard_jp> #topic Seam University
21:06:21 <lightguard_jp> Thanks everyone for showing up.
21:06:32 <lightguard_jp> The first things on our agenda is Seam University.
21:06:43 <lightguard_jp> What it is, what we're planning on doing, questions, etc.
21:06:52 <lightguard_jp> For that I'll let sbryzak talk about it.
21:07:12 <sbryzak> ok, though it may take a few minutes for my brain to warm up
21:07:29 <lightguard_jp> Okay, I can start then :)
21:07:47 <lightguard_jp> #info Seam University will be the main information hub for things related to seam
21:08:11 <lightguard_jp> People will be able to post links to blogs, post presentations, video, tweets, module spotlights etc
21:08:36 <lightguard_jp> The current idea is building it in Java, using Seam 3 modules.
21:08:45 <lightguard_jp> Hopefully hosting on OpenShift as well
21:08:54 <sbryzak> it's basically a site for the seam community to share seam-related content
21:09:00 <lightguard_jp> Shane and I will be heading it up, but all are welcome to help out
21:09:12 <bleathem> CMS style? or Wiki style?
21:09:17 <sbryzak> i've been dissatisfied for some time that we have had to post stuff like the seam module spotlights to in.relation.to
21:09:40 <lightguard_jp> #link https://github.com/sbryzak/university Seam University code repo
21:09:44 <jose_freitas> is going to be open?
21:09:49 <jose_freitas> anyone could post links?
21:09:53 <sbryzak> and that we don't have a central place to collate blog posts and articles about seam
21:10:12 <lightguard_jp> We're thinking the first post or so will go through an approval process
21:10:24 <lightguard_jp> But once you're setup as someone that can post you can post freely.
21:10:28 <sbryzak> one moment and i'll post a screen mockup to twitpic
21:10:55 <jose_freitas> btw, tiggr is a great tool for this
21:11:29 <lightguard_jp> jose_freitas: True, but Shane has been busy mocking up images :)
21:12:53 <gastaldi> brb
21:13:19 <jose_freitas> looks fancy
21:13:23 <sbryzak> jose_freitas: we have some very specific requirements that an out of the box solution won't address
21:13:47 <sbryzak> http://twitpic.com/4wdt7d/full
21:14:01 <lightguard_jp> #link http://twitpic.com/4wdt7d/full Seam University mockup
21:14:08 <jose_freitas> I meant that tiggr is great for prototyping screens
21:14:15 <sbryzak> http://twitpic.com/4wdsxv/full
21:14:20 <kenfinnigan> Looks cool
21:14:27 <sbryzak> they're pretty much prototyped ;)
21:14:33 <sbryzak> it's going to be quite a simple site
21:14:57 <sbryzak> it will heavily depend on the community submitting content
21:15:02 <lightguard_jp> #info Seam University will also be used as an R&D playground for other Seam modules / ideas
21:15:28 <sbryzak> but at least we'll have one single location where we can index all seam related content that people create
21:15:32 <gastaldi> cool !
21:16:18 <gastaldi> just like mastertheboss.com
21:16:52 <sbryzak> i haven't seen that site before
21:17:02 <sbryzak> but yes, something like that ;)
21:17:11 <gastaldi> Great
21:17:15 <lightguard_jp> #info Those that are interested in helping out contact sbryzak or lightguard_jp and we'll include you on the design Google Doc.
21:17:23 <sbryzak> the site will be owned by the community though
21:17:28 <gastaldi> It could be extended to other JBoss products as well
21:17:36 <lightguard_jp> gastaldi: Yep
21:17:41 <sbryzak> gastaldi: one step at a time ;)
21:17:45 <gastaldi> yea
21:17:49 <gastaldi> :)
21:18:15 <gastaldi> nice one
21:18:25 <gastaldi> And do we have a schedule to implement it?
21:18:36 <gastaldi> Running on Openshift would be nice
21:18:40 <lightguard_jp> #info we're also going to be prototyping a different view layer with this which sbryzak is working on
21:18:44 <sbryzak> i'm hoping we'll have a beta version sometime in june
21:19:12 <lightguard_jp> It may also help get some modules moving that have been a little stagnant (if we need them)
21:19:49 <lightguard_jp> Do we have other questions about Seam University at this time?
21:19:53 <sbryzak> definitely, it will be the first real application created by the team that uses seam 3
21:20:24 <gastaldi> lightguard_jp: I think the objective is pretty clear on that
21:20:38 <lightguard_jp> Great! Moving on then
21:20:43 <lightguard_jp> #topic Module Status (Cron, JCR, JMS, Mail)
21:20:48 <gastaldi> questions should arise during time I think
21:21:00 <lightguard_jp> I think we have everyone here
21:21:04 <lightguard_jp> On that list
21:21:17 <gastaldi> Who wants to be the first ?
21:21:21 <lightguard_jp> PeteRoyle: If you don't mind talking about the current status for Cron, I know you've been working on it recently
21:21:47 <PeteRoyle> Sure. So progress wise...
21:22:20 <PeteRoyle> @Scheduled seems to be working ok and Diablo-D3 has been giving it a bit of a bash.
21:22:35 <lightguard_jp> Diablo-D3: Thanks for helping test
21:22:52 <PeteRoyle> I rouded out @Asynchronous yesterday adding support for @Observes and returning Future<>
21:22:57 <PeteRoyle> That's about it
21:23:01 <gastaldi> PeteRoyle: I think the impl should be improved though
21:23:06 <PeteRoyle> Outstanding issues
21:23:10 <lightguard_jp> Great
21:23:37 <gastaldi> But that´s another issue, ok
21:23:47 <PeteRoyle> Funny classloading issue on redeployment. It could be a bug in Cron, AS, Weld, Eclipse or other, and I don't get it ever (using NetBeans) so not too panicy about it yet
21:23:51 <lightguard_jp> PeteRoyle: is it getting close to a release?
21:24:10 <PeteRoyle> And finally the modules needs to conform to the proper structure which is the most pressing outstanding issue I think
21:24:31 <lightguard_jp> PeteRoyle: do you need some help with the issues?
21:24:45 <PeteRoyle> lightguard_jp: With the module restructure it could be released.
21:25:03 <PeteRoyle> I'm running out of time for the next week or so, so if anyone wants to do some work on the restructuring that would help
21:25:10 <lightguard_jp> We can help you out with that.
21:25:21 <PeteRoyle> lightguard_jp: awesome
21:25:32 <lightguard_jp> #action lightguard_jp will help PeteRoyle with the Cron restructure.
21:25:40 <lightguard_jp> Should we shoot for a release date?
21:26:01 <lightguard_jp> Couple of weeks perhaps?
21:26:45 <PeteRoyle> Sounds plausible. That will be the api and a single underlying implementation for each feature (@Schedule => Quatrz, @Asynchronous -> Thread)
21:27:00 <lightguard_jp> Great!
21:27:06 <gastaldi> Nice
21:27:12 <lightguard_jp> #agreed Cron will shoot for a release in two weeks
21:27:17 <PeteRoyle> as gastaldi said, the implemnetations need to be improved and expanded upon, but that shouldn't stop us getting it out the door I dont think
21:27:27 <gastaldi> PeteRoyle: agreed
21:27:31 <lightguard_jp> Excellent
21:27:45 <lightguard_jp> gastaldi: Would you like to talk about JCR?
21:28:07 <johnament> hi
21:28:15 <lightguard_jp> johnament: Welcome
21:28:28 <lightguard_jp> johnament: you're up next for a status on the jms module
21:28:32 <johnament> So JCR.. we haven't touched much lately
21:28:37 <gastaldi> Seam JCR is not getting many updates recently.
21:28:41 <johnament> lightguard_jp: not JCR?
21:28:53 <lightguard_jp> johnament: didn't see you went I asked gastaldi, sorry :)
21:29:00 <johnament> its cool.
21:29:05 <johnament> George can continue
21:29:09 <johnament> i might drop off
21:29:40 <lightguard_jp> I may be able to help out with JCR as I'm thinking of using Modeshape for Seam University.
21:29:51 <lightguard_jp> We need to get it back and running.
21:30:07 <gastaldi> Seam JCR is pretty usable by now, but there are some features that we need to rethink
21:30:12 <lightguard_jp> Are there features that are missing from it currently?
21:30:32 <lightguard_jp> Are there JIRA issues open?
21:30:38 <gastaldi> Yes, there are
21:30:43 <lightguard_jp> Perfect
21:31:02 <lightguard_jp> Anything else for JCR?
21:31:34 <gastaldi> There are some things on JCR that may apply only to Modeshape, don´t know if that´s the case by now
21:32:05 <lightguard_jp> Okay, we can work through those. As long as they're up on JIRA so they're not forgotten about.
21:32:42 <lightguard_jp> johnament: JMS update?
21:32:46 <gastaldi> Ok
21:33:15 <bleathem> johnament: or anything to add JCR-wise?
21:33:25 <gastaldi> Welcome mojavelinux.
21:33:29 <lightguard_jp> mojavelinux: Welcome, we're talking about JMS
21:33:46 <mojavelinux> hi from tje
21:34:04 <mojavelinux> hi from the floor of google io
21:34:14 <jose_freitas> hey mojavelinux
21:34:31 <jose_freitas> long time no see
21:34:41 <gastaldi> johnament ? You there ?
21:35:00 <lightguard_jp> Hm, maybe not.
21:35:11 <lightguard_jp> I know we talked about JMS a bit during JUDCon
21:35:15 <mojavelinux> wowthis web client sux tryimn native
21:35:23 <lightguard_jp> He has a forge plugin going that works with HornetQ
21:35:30 <gastaldi> cool
21:35:50 <lightguard_jp> We may need to follow up with him later
21:36:00 <lightguard_jp> #action follow up with johnament about JMS status
21:36:05 <gastaldi> Wanna go on with Seam Mail ?
21:36:10 <lightguard_jp> Yep
21:36:15 <lightguard_jp> clerum: You're up
21:36:33 <clerum> Not really any progress from my end
21:36:45 <lightguard_jp> Dan, Lincoln, and I were talking about it last week
21:36:50 <johnament> im back
21:36:54 <clerum> like I said in last email I really need someone to assist in getting the tests running
21:36:59 <clerum> the arquillian
21:37:03 <clerum> test
21:37:09 <lightguard_jp> We think as long as we have a wrapper around what's there so the user doesn't have to worry about Instance we're ready to go
21:37:25 <clerum> also needing to add an async send method but it sounds like Cron has that
21:37:36 <gastaldi> Yeah, leave it to Cron
21:38:06 <lightguard_jp> #help Cody needs some help with Arquillian tests working in Mail
21:38:20 <clerum> the Seam Render tests won't run
21:38:27 <clerum> thats the main one
21:38:37 <lightguard_jp> Will that (async) an optional dep?
21:39:09 <clerum> if it can be
21:39:13 <gastaldi> I think that async send method should be ignored for Seam Mail.
21:39:25 <gastaldi> After all Seam Cron will handle that
21:39:40 <lightguard_jp> We'll get someone to help out with the tests and Seam Render, hopefully we can pull Lincoln away for a few minutes to help
21:40:15 <clerum> yeah it may make more sense to just call your send method as async
21:40:48 <kenfinnigan> Would imagine all async req's would just use cron
21:40:57 <lightguard_jp> Probably
21:41:05 <gastaldi> Agreed
21:41:09 <lightguard_jp> Or JMS if you want to go that route
21:41:20 <gastaldi> Then Seam Cron would depend on Seam JMS for that :)
21:41:29 <kenfinnigan> clerum: Might have time to take look at seam render tests later, will let u know
21:41:52 <lightguard_jp> sbryzak: Do you have other questions about module status?
21:41:58 <clerum> k. It's a solder thing I beleive
21:42:03 <gastaldi> I have a question about Seam Render, but it might be wiser on the next topic
21:42:08 <sbryzak> no i think that covers it
21:42:12 <lightguard_jp> Okay
21:42:17 <lightguard_jp> #topic Report Module volunteer
21:42:26 <lightguard_jp> We need to get the Report / Doc module off the ground
21:42:36 <lightguard_jp> #info gastaldi has volunteered to lead the module
21:42:40 <sbryzak> gastaldi has volunteered for that ;)
21:42:46 <gastaldi> As I replied on the email, I volunteered for that
21:42:51 <gastaldi> Thanks lightguard_jp !
21:42:55 <gastaldi> :)
21:43:00 <bleathem> Does the Render module include creating excel spreadsheets from JSF datatables?
21:43:12 <lightguard_jp> I don't see the point in doing it from a datatable
21:43:20 <lightguard_jp> Nearly every rich ui component library has that
21:43:52 <kenfinnigan> Will the reports module expand on the spreadsheet work that Nik did for seam 2?
21:43:56 <lightguard_jp> I think the big parts of this module are going to be PDF and Excel sheets that aren't on the UI
21:44:00 <sbryzak> we don't have a reports module yet in GitHub, so we have to create it
21:44:05 <gastaldi> Will Seam Render be merged on this ?
21:44:09 <lightguard_jp> sbryzak: Can you take that up?
21:44:26 <sbryzak> sure, i'll take care of it
21:44:41 <lightguard_jp> gastaldi: Possibly, I think talking to clerum and seeing if we can pull out a general templating jar for Seam 3 it would be best.
21:44:46 <sbryzak> what does render do so far?
21:44:58 <lightguard_jp> #action sbryzak will set up reports github space
21:45:02 <gastaldi> I have a proposal on using xhtmlrenderer for the PDF generation
21:45:23 <lightguard_jp> sbryzak: It's a templating solution Lincoln was hacking on, using mvel
21:45:27 <sbryzak> do we want to call it Seam Reports or Seam Reporting?
21:45:32 <sbryzak> my +1 is for Seam Reports
21:45:37 <bleathem> lightguard_jp: Are you saying the Spreadsheet download for JSF datatables belongs with RichFaces?
21:45:42 <clerum> afaik render does text templating like freemarker and velocity
21:45:46 <lightguard_jp> I think we had been referring to it as documents
21:45:51 <gastaldi> Seam Reports looks cooler
21:46:05 <sbryzak> are we using render anywhere?
21:46:11 <lightguard_jp> bleathem: Seems like the proper place for it, I can see others wanting the ability but not wanting to use Seam.
21:46:19 <clerum> mail uses it as an optional impl
21:46:24 <lightguard_jp> bleathem: We may need to talk to jay about that and see what he thinks
21:46:29 <kenfinnigan> But does that have the connotation of building a report as opposed to viewing a doc?
21:46:33 <clerum> choice of freemarker, velocity or render
21:46:40 <gastaldi> clerum: Yes
21:46:53 <bleathem> lightguard_jp: agreed.  It's functionality lost from Seam 2.
21:47:08 <clerum> are file downloads from seam 3 covered yet?
21:47:16 <gastaldi> I am thinking of incorporating compilation, population and rendering for reports on this module
21:47:31 <lightguard_jp> clerum: No, but I seriously doubt that needs to be in Seam.
21:47:51 <gastaldi> Jasper could be another impl
21:47:55 <gastaldi> And Birt
21:48:10 <sbryzak> i think jasper is quite popular
21:48:14 <lightguard_jp> gastaldi: We'll leave it to you :)
21:48:21 <gastaldi> lightguard_jp: Thanks :)
21:48:32 <gastaldi> Yeah, I use Jasper my entire life :)
21:48:38 <clerum> lightguard_jp: how do I handle the case where I geneate a pdf as bytes and I need to send it to the user
21:48:53 <sbryzak> right, so i'll create a reports repository
21:49:01 <gastaldi> sbryzak: cool
21:49:06 <lightguard_jp> Do we have other questions? We have one last item left on the agenda and are running out of time :(
21:49:10 <sbryzak> and we'll leave the render module as it is for now?
21:49:14 <gastaldi> clerum has a question
21:49:20 <clerum> currently that is handled by the documentStore in seam 2
21:49:28 <lightguard_jp> clerum: I'd still say look to your component kit or UI layer for that.
21:49:32 <clerum> or that is how I do it
21:49:46 <clerum> richfaces handles that then?
21:49:51 <lightguard_jp> If there's a strong need from the community though we can look into it.
21:49:55 <clerum> I'll take a look
21:50:10 <gastaldi> Any more volunteers for Seam Reports ?
21:50:15 <lightguard_jp> clerum: I know Primefaces does (pretty sure ICEfaces does as well), not sure about RichFaces
21:51:11 <lightguard_jp> #topic Seam 2 Compatibility Module
21:51:17 <lightguard_jp> Moving along then
21:51:22 <lightguard_jp> #link http://www.seamframework.org/Community/Seam23MigrationHowToStart
21:51:37 <lightguard_jp> At JUDCon some former coworkers of mine were asking about this
21:51:46 <lightguard_jp> We also discussed last week about this a bit.
21:52:06 <lightguard_jp> That thread I linked will be a gathering of information and needs for those looking to migrate to Seam 3
21:52:10 <bleathem> I fielded question about this at JUDCon too.  Hot topic
21:52:15 <lightguard_jp> Yes it is,
21:52:26 <lightguard_jp> and we've done a poor job of answering it IMO
21:52:36 <lightguard_jp> sbryzak: Do you want to talk about what we discussed last week?
21:52:57 <sbryzak> oh, yes definitely
21:53:07 <sbryzak> there's some new people in the room ;)
21:53:11 <sbryzak> mojavelinux: you there?
21:53:29 <lightguard_jp> He's having problems getting online
21:53:34 <lightguard_jp> I think
21:53:46 <sbryzak> in that case, let's put it off until he's available
21:53:54 <lightguard_jp> Okay
21:54:13 <lightguard_jp> For now if people start asking, please point them to that thread I linked so we can gather all the questions.
21:54:28 <gastaldi> Great
21:54:36 <lightguard_jp> Also if you have solutions please feel free to answer questions that come up there as well.
21:54:42 <gastaldi> What´s the module name for Seam Reports again ?
21:54:58 <gastaldi> I see a documents module there Is that it ?
21:55:12 <bleathem> I had a question about Seam University if we are through our topics...
21:55:17 <sbryzak> no, i'll create a repository called reports
21:55:26 <gastaldi> sbryzak: Oh, ok
21:55:35 <gastaldi> sbryzak: What´s that document module ?
21:55:44 <lightguard_jp> we'll need to create a section on sfwk.org too
21:55:49 <bleathem> What view technology is Seam University going to be built with?
21:56:05 <sbryzak> documents was the first draft i believe
21:56:10 <kenfinnigan> I think documents was the original name for reporting
21:56:17 <gastaldi> bleathem: JSF 2.0 and Rest I suppose
21:56:21 <clerum> yeah I think it's a dupe
21:56:26 <sbryzak> it's just an empty project
21:56:33 <sbryzak> well, it's got the module skeleton there
21:56:40 <gastaldi> yeah, I figured that out now
21:56:46 <lightguard_jp> https://github.com/seam/documents is what we are now calling reports it sounds like
21:57:06 <gastaldi> cool
21:57:11 <lightguard_jp> we can rename the project
21:57:15 <gastaldi> yes
21:57:19 <sbryzak> bleathem: we're writing a new view layer
21:57:24 <sbryzak> lightguard_jp: ah, that would be easier
21:57:28 <lightguard_jp> There are two watchers and no forks
21:57:32 <bleathem> sounds ambitious
21:57:36 <lightguard_jp> Not a big deal if we rename it.
21:57:43 <sbryzak> and... done
21:57:47 <gastaldi> sbryzak: How about using jQuery and jQuery UI  for that ?
21:58:00 <sbryzak> gastaldi: already got something big underway
21:58:30 <lightguard_jp> I think that's all we had for this week's meeting, officially
21:58:51 <lightguard_jp> Please follow up on the mailing list if something wasn't covered.
21:59:05 <lightguard_jp> #endmeeting