#seam-dev Meeting
Meeting started by lightguard_jp at 21:13:45 UTC
(full logs).
Meeting summary
- Report on action items from last meeting - Jason (mojavelinux, 21:15:39)
  - All action items from last week have been
    finished (lightguard_jp,
    21:16:36)
- source code formatting should apply to code in
    docs (mojavelinux,
    21:21:39)
- XML files also get 4 spaces, no tabs
    (mojavelinux,
    21:21:52)
- http://seamframework.org/Seam3/DevelopmentGuidelines
    (mojavelinux,
    21:23:19)
- ACTION: the
    information in the build module needs to reflect spacing for xml
    files (lightguard_jp,
    21:28:52)
 
 
- Seam Spotlight - Shane (mojavelinux, 21:29:02)
  - http://errai-blog.blogspot.com/2011/04/latest-enhancements-to-errai-cdi.html
    (mojavelinux,
    21:33:51)
- ACTION: sbryzak will
    author the seam spotlight on Seam Security (lightguard_jp,
    21:34:52)
- ACTION: mojavelinux
    or stuartdouglas will write about Seam Persistence next (lightguard_jp,
    21:36:09)
 
 
- Briefly discuss development methodologies (please come prepared to discuss methodologies that you have used which worked) (mojavelinux, 21:39:50)
  - we plan to release the seam stack every 6
    months, but we need to est the first target date (mojavelinux,
    21:56:17)
- we are considering setting a goal that we have
    at least one module release happen every two weeks to keep seam
    active and to give community new bits (mojavelinux,
    21:56:59)
- we are looking for other ideas that would make
    the seam development process more tangible, but which would respect
    the distributed nature of the team and the volunteer-based
    membership (mojavelinux,
    21:58:48)
- next week's meeting (mojavelinux,
    22:01:01)
 
 
- next week's meeting (mojavelinux, 22:01:09)
  - no meeting next week on IRC, but for those at
    JUDCon, we will have an informal gathering/brainstorm/meeting after
    the hackfest monday ~21:30ish (mojavelinux,
    22:01:49)
 
 
- git workflow (mojavelinux, 22:02:30)
  - git workflow proposal
    http://nvie.com/posts/a-successful-git-branching-model/ (mojavelinux,
    22:04:15)
- http://nvie.com/posts/a-successful-git-branching-model/
    (lightguard_jp,
    22:04:29)
- it would allow collaboration on a branch, and
    it will keep master stable (mojavelinux,
    22:04:34)
- ci should build from develop in this proposed
    git workflow (mojavelinux,
    22:06:16)
 
 
- documentation (mojavelinux, 22:06:39)
  - http://blip.tv/file/4881071
    writing good documentation (mojavelinux,
    22:06:56)
- writing documentation/blogs makes you famous
    and get jobs :) (mojavelinux,
    22:08:09)
- IDEA: We should
    probably schedule a documentation review soon (lightguard_jp,
    22:08:52)
 
Meeting ended at 22:12:34 UTC
(full logs).
Action items
  - the information in the build module needs to reflect spacing for xml files
- sbryzak will author the seam spotlight on Seam Security
- mojavelinux or stuartdouglas will write about Seam Persistence next
Action items, by person
  -  mojavelinux 
    - mojavelinux or stuartdouglas will write about Seam Persistence next
 
-  sbryzak 
    - sbryzak will author the seam spotlight on Seam Security
 
People present (lines said)
  - mojavelinux (128)
- lightguard_jp (74)
- sbryzak (65)
- bleathem (32)
- kenfinnigan (20)
- lincolnthree (10)
- antoine_sd (6)
- jbossbot (4)
- gastaldi (4)
- jbott (3)
Generated by MeetBot 0.1.4.