#seam-dev: 2011-04-20 Meeting

Meeting started by lightguard_jp at 21:00:54 UTC (full logs).

Meeting summary

  1. Formatting change must be done by May 1st (lightguard_jp, 21:03:59)
    1. source formatting was talked about in a previous meeting, also formatting is in the build module (lightguard_jp, 21:04:50)
    2. We will change modules that don't have it done by the 1st (lightguard_jp, 21:05:27)
    3. ACTION: lightguard_jp Will create JIRA issues in modules that need to be converted (lightguard_jp, 21:06:46)

  2. New Community Integrator (mojavelinux, 21:07:56)
  3. Formatting change must be done by May 1st (mojavelinux, 21:09:07)
  4. New Community Integrator (mojavelinux, 21:13:28)
    1. Jason was previously the community integrator (mojavelinux, 21:13:37)
    2. Brian Leathem now has the role of community integrator (mojavelinux, 21:15:00)
    3. bleathem is the new Community Integrator (lightguard_jp, 21:15:12)
    4. The Community Integrator is to help distribute the work of merging in patches when a module lead can't get to it, so you have the ability to help if you are available (no requirement) (lightguard_jp, 21:18:49)
    5. second is to make sure the community has equal voice with core devs...so a balance of "power" though I don't like that word (lightguard_jp, 21:19:19)

  5. SEAMXML -> SEAMCONFIG (mojavelinux, 21:21:00)
    1. one of the remaining inconsistencies from the Seam Config rename was the JIRA key; can't change a JIRA key unfortunately (mojavelinux, 21:21:43)
    2. all issues have been migrated to the new key, so now the module is officially config all the way through (mojavelinux, 21:22:21)

  6. Git workflow (mojavelinux, 21:24:00)
    1. Jason has also migrated all projects to the official Git workflow that JBoss IT created from my original prototype workflow (mojavelinux, 21:24:23)
    2. you shouldn't notice any change, but it's good that we are aligned (mojavelinux, 21:24:37)

  7. JIRA hookup in GitHub (mojavelinux, 21:25:57)
    1. contact lightguard_jp if you want JIRA issue resolution in your github module (lightguard_jp, 21:29:13)
    2. ACTION: lightguard_jp will add the JIRA integration to Seam Faces (lightguard_jp, 21:29:45)
    3. we also now have commit emails going to those who commit to the projects (lightguard_jp, 21:30:14)
    4. ACTION: lightguard_jp will add JIRA integration to Seam JMS (lightguard_jp, 21:31:02)
    5. ACTION: lightguard_jp will add JIRA integration to Seam JCR (lightguard_jp, 21:32:30)
    6. ACTION: lightguard_jp change the email from in the commit emails to seam-commits-owner@lists.jboss.org (lightguard_jp, 21:36:22)

  8. Development Methodology for Seam (mojavelinux, 21:37:40)
  9. seam 2 migration guide, how can we get it off the ground (mojavelinux, 21:43:05)
  10. forge plugins (mojavelinux, 21:51:48)
    1. https://lists.jboss.org/mailman/listinfo/forge-dev (lincolnthree, 21:53:05)
    2. https://github.com/forge (lincolnthree, 21:55:40)

  11. JUDCon meetup(s) (mojavelinux, 21:56:58)
    1. http://community.jboss.org/wiki/BostonJBossUserGroup-LetsGetReadyToRumble2 (mojavelinux, 21:57:15)
    2. IDEA: Good time to plan the development methodology. (lightguard_jp, 22:06:09)
    3. IDEA: we can talk about techs to get into, how to challenge competitors and how to be more relevant to app devs (lightguard_jp, 22:06:23)
    4. AGREED: Good time to plan the development methodology. (mojavelinux, 22:07:00)
    5. AGREED: Community meeting Monday night after hackfest (lightguard_jp, 22:08:00)


Meeting ended at 22:09:48 UTC (full logs).

Action items

  1. lightguard_jp Will create JIRA issues in modules that need to be converted
  2. lightguard_jp will add the JIRA integration to Seam Faces
  3. lightguard_jp will add JIRA integration to Seam JMS
  4. lightguard_jp will add JIRA integration to Seam JCR
  5. lightguard_jp change the email from in the commit emails to seam-commits-owner@lists.jboss.org


Action items, by person

  1. lightguard_jp
    1. lightguard_jp Will create JIRA issues in modules that need to be converted
    2. lightguard_jp will add the JIRA integration to Seam Faces
    3. lightguard_jp will add JIRA integration to Seam JMS
    4. lightguard_jp will add JIRA integration to Seam JCR
    5. lightguard_jp change the email from in the commit emails to seam-commits-owner@lists.jboss.org


People present (lines said)

  1. mojavelinux (187)
  2. lightguard_jp (94)
  3. bleathem (54)
  4. sbryzak (30)
  5. lincolnthree (25)
  6. johnament (24)
  7. johnament_ (11)
  8. kenfinnigan (8)
  9. oranheim (4)
  10. jbossbot (3)
  11. jbott (3)


Generated by MeetBot 0.1.4.