#seam-dev Meeting
Meeting started by lightguard_jp at 21:06:01 UTC
(full logs).
Meeting summary
- announcements (mojavelinux, 21:06:44)
  - Jordan is enjoying his new job, but it's
    requiring a lot of his time, so he said he can't realistically lead
    the JMS module in the near term (mojavelinux,
    21:08:25)
- john ament has volunteered to be the JMS module
    lead; he has been working with Jordan recently and also got a strong
    recommendation from Jordan (mojavelinux,
    21:09:49)
- we are looking for contributors to Seam
    JMS (mojavelinux,
    21:12:41)
- Seam JMS should have a new release soon
    (mojavelinux,
    21:12:45)
- Seam JMS
    http://seamframework.org/Seam3/JMSModule (mojavelinux,
    21:13:15)
- the next release is expected to be
    3.0.0.Beta1 (johnament,
    21:14:46)
- http://seamframework.org/Seam3/JMSModule
    Seam JMS  module (mojavelinux,
    21:15:28)
- Beta1 will come after 3.0.0.Final for the main
    Seam modules (johnament,
    21:15:42)
- Seam 3.0.0.Final is schedule before the end of
    the month, though QE is going to push back if we don't have issues
    resolved (mojavelinux,
    21:16:18)
- we are currently facing some problems with seam
    security due to what appears to be another glassfish visibility
    issue, but we can't reproduce in a testing environment; see
    SEAMSECURITY-42 (mojavelinux,
    21:18:03)
- snapshots of weld osgi bundles are now
    published to the jboss snapshots repository (mojavelinux,
    21:18:38)
- https://repository.jboss.org/nexus/content/repositories/snapshots/org/jboss/weld/weld-osgi-bundle/
    Weld OSGi bundle snapshots (mojavelinux,
    21:19:58)
- AGREED: Seam 3 can
    target Weld 1.1.1 instead of working around problems in vanilla
    GlassFish 3.1 if Weld 1.1.1 is released soon (mojavelinux,
    21:25:19)
- AGREED: Seam
    3.0.0.Final will be much better off if a Weld 1.1.1 release could
    happen first (mojavelinux,
    21:35:27)
- when searching in JIRA, all projects between
    Seam 3 Distribution and Seam Validation are the Seam 3 modules (no
    other projects get stuck in the middle) (mojavelinux,
    21:46:12)
- https://issues.jboss.org/secure/IssueNavigator.jspa?mode=hide&requestId=12314294
    (bleathem,
    21:50:14)
- ACTION: split table
    of modules into two tables, one for modules in the stack, one for
    modules not in the stack
    http://seamframework.org/Seam3/Status (mojavelinux,
    21:50:21)
- ACTION: kenfinnigan
    add a list of modules in the stack release to the dist
    readme.txt (mojavelinux,
    21:55:14)
- seam-bom sets module versions as a convenience
    to the end developer and as a recommendation of compatible
    versions (mojavelinux,
    21:59:49)
- ;modules and/or applications can set the
    version of a module explicitly (mojavelinux,
    21:59:57)
- modules should request the update in the next
    seam-bom release and remove the version once it is there
    (mojavelinux,
    22:00:17)
- but it does not have to happen urgently
    (mojavelinux,
    22:00:29)
- ACTION: document the
    seam-bom version policy on the coding guidelines page (mojavelinux,
    22:01:41)
- ACTION: document the
    purpose of the seam-bom in the seam module refguide <- this
    should be a jira (mojavelinux,
    22:01:53)
 
Meeting ended at 22:08:23 UTC
(full logs).
Action items
  - split table of modules into two tables, one for modules in the stack, one for modules not in the stack http://seamframework.org/Seam3/Status
- kenfinnigan add a list of modules in the stack release to the dist readme.txt
- document the seam-bom version policy on the coding guidelines page
- document the purpose of the seam-bom in the seam module refguide <- this should be a jira
Action items, by person
  -  kenfinnigan 
    - kenfinnigan add a list of modules in the stack release to the dist readme.txt
 
- UNASSIGNED
    - split table of modules into two tables, one for modules in the stack, one for modules not in the stack http://seamframework.org/Seam3/Status
- document the seam-bom version policy on the coding guidelines page
- document the purpose of the seam-bom in the seam module refguide <- this should be a jira
 
People present (lines said)
  - mojavelinux (159)
- kenfinnigan (25)
- gmorling (20)
- bleathem (11)
- lightguard_jp (5)
- johnament (4)
- jbott (3)
- lincolnthree1 (2)
- jbossbot (2)
- stuartdouglas (1)
- jharting (1)
Generated by MeetBot 0.1.4.