21:01:57 <mojavelinux> #startmeeting
21:02:04 <jbott> Meeting started Wed Mar 16 21:01:57 2011 UTC.  The chair is mojavelinux. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:04 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:02:26 <jbossbot> git [12forge] push 10master7 1564c17.. 6Lincoln Baxter, III began refactoring ShellImpl into smaller more maintainable pieces
21:02:30 <jbossbot> git [12forge] push 10master7 e46c038.. 6Lincoln Baxter, III SEAMFORGE-70
21:02:35 <jbossbot> jira [3SEAMFORGE-70] Ls and Rm do not function on JavaResource members [10Closed (Done) Bug,7 Major,6 Lincoln Baxter III] https://issues.jboss.org/browse/SEAMFORGE-70
21:02:39 <jbossbot> git [12forge] push 10master URL: http://github.com/seam/forge/compare/ac99201...e46c038
21:02:43 <mojavelinux> #topic international concerns, vanity committing and release countdown
21:03:28 <lincolnthree> oops, sorry :)
21:03:33 <mojavelinux> we have stuart but shane is still snoozing...stuart, would one hour earlier be too painful?
21:03:53 <mojavelinux> we had to shift this week because ben franklin invented dst
21:04:13 <stuartdouglas> Shane is having customer meetings in Sydney today
21:04:24 <kenfinnigan> Sorry I'm late
21:04:47 <mojavelinux> no worries, we are still on time and date
21:05:00 <stuartdouglas> One our earlier is 6:00am for Shane, 7:00am for me
21:05:07 <mojavelinux> yeah, kind of painful for shane
21:05:15 <stuartdouglas> I am fine with it, but 6 is a bit early :-)
21:05:21 <mojavelinux> but we have guys on the east that are on the edge of the work day
21:05:29 <jose_freitas> 6:00 is really painful
21:05:39 <mojavelinux> we are going to try this time, which is 7 for shane, 8 for you stuart
21:05:46 <johnament> well, what about 6am eastern?
21:05:58 <mojavelinux> if I stay up one extra hour, I might make it :)
21:06:02 <mojavelinux> hahaha
21:06:18 <jose_freitas> lol
21:06:59 <lightguard_jp> 6 AM Eastern and you won't see Cody, or myself :)
21:07:04 <mojavelinux> #agreed try 5pm east coast to keep shane sane
21:07:12 <lincolnthree> won't see me at 6am est
21:07:20 <mojavelinux> yeah, hopefully that was a joke
21:07:29 <johnament> no one else is an early bird?
21:07:37 <lincolnthree> not unless i'm still up from the night before
21:07:42 <mojavelinux> yep
21:07:46 <johnament> i'm usually heading in to work at 6am...
21:07:51 <mojavelinux> okay, so we were discussing the SeamManaged annotation
21:08:11 <mojavelinux> which we moved into solder, but in thinking about solder as a general purpose library, it would make more sense to try to name the annotation according to it's fundtion
21:08:15 <mojavelinux> rather than overreach the brand
21:08:29 <mojavelinux> so, john and I were discussing ModuleManaged (john) or ExtensionManaged (dan)
21:08:44 <mojavelinux> that way, it's not restrictive to just seam modules (for others using solder)
21:08:54 <mojavelinux> it's the opposite of container-managed
21:10:25 <mojavelinux> so, any votes?
21:10:35 <mojavelinux> let's see them...we have money on it
21:10:40 <johnament> ModuleManaged
21:10:50 <lightguard_jp> ExtensionManaged
21:10:54 <jose_freitas> I like ModuleManaged better
21:11:03 <GunnarMorling> +1 for ExtensionManaged
21:11:16 <mojavelinux> alright, come on voters
21:11:21 <bleathem> ExtensionManaged
21:11:25 <lincolnthree> ExtensionManaged
21:11:32 <kenfinnigan> ExtensionManaged
21:11:40 <lincolnthree> sorry johnament
21:11:49 <johnament> its cool
21:11:57 <mojavelinux> stuart, got a vote?
21:12:07 <lincolnthree> his vote doesn't count anymore
21:12:21 <lincolnthree> 5/2
21:12:26 <mojavelinux> hey now, don't be dissin' the bread winner
21:12:30 <lincolnthree> just sayin' ;)
21:13:33 <bleathem> What's next?
21:13:42 <mojavelinux> okay, next up...
21:13:51 <mojavelinux> btw, we are running with a meeting bot thanks to jason
21:13:55 <bleathem> or should we record that result in the miutes somehow
21:13:59 <mojavelinux> for those that weren't at the party last night
21:14:04 <lightguard_jp> Put an #agreed to that final vote please
21:14:20 <lightguard_jp> I'm not a chair, so I can't.
21:14:45 <bleathem> #action SeamManaged annotation shall henceforth be referred to as ExtensionManaged
21:14:49 <mojavelinux> #agreed rename SeamManaged to ExtensionManaged to reflect it's function over branding, despite pleads by john to name it ModuleManaged
21:14:53 <lightguard_jp> #info Vote for ModuleManged vs ExtetnionManged: 2/5
21:15:09 <mojavelinux> #action file a jira for previous agreed
21:15:27 <bleathem> sorry, I got a little meetbot keen there
21:15:36 <lightguard_jp> bleathem: :)
21:15:41 <stuartdouglas> sorry, I was having a shower, only just woke up :-)
21:16:14 <stuartdouglas> ExtensionManaged is better than ModuleManaged though
21:16:20 <mojavelinux> #info let the record show that john and jose put in a good fight, and lincoln tried to insult our fearless bread winner
21:16:40 <lightguard_jp> Ouch
21:16:49 <lightguard_jp> So let it be written....
21:16:59 <mojavelinux> #info vote now 2/10 in favor of ExtensionManaged
21:17:04 <lincolnthree> #rebuttal lincoln merely tried to state the fact that there wee too many votes to overcome
21:17:08 <kenfinnigan> In bot blood
21:17:15 <mojavelinux> because lincoln's insult means that stuart's vote doubled the side
21:17:40 <mojavelinux> okay, upwards
21:17:45 * lincolnthree goes back to writing awesome forge code
21:17:50 <mojavelinux> #info onwards is now upwards
21:18:10 <bleathem> note to self, disregard info comments in meeting minutes :P
21:18:41 <mojavelinux> ken and I did much deliberating, and we think we worked out the division between i18n concerns in solder and international
21:19:02 <mojavelinux> solder is going to provide the annotations for typed loggers and message bundles
21:19:15 <bleathem> #topic division between i18n concerns in solder and international
21:19:20 <mojavelinux> and be based on the system locale
21:19:49 <lightguard_jp> bleathem: Topic lasts for whole meeting, and only a chair can change it
21:19:57 <mojavelinux> and international handles all the configuration and client locale concerns, and extending the typed loggers and message bundles if we wanted to do stuff like load from a database or whatever
21:20:20 <mojavelinux> ignore bleathem feeble attempts to change topic :)
21:20:25 <mojavelinux> hehehe
21:20:29 <kenfinnigan> Lol
21:20:33 <bleathem> lightguard_jp: oh, how do we track what we're talking about?
21:20:37 <mojavelinux> even though his actions were noble
21:21:08 <mojavelinux> so, here is how the annotations will fall, we are looking for objections only
21:21:12 <jose_freitas> lol
21:21:16 <lightguard_jp> bleathem: I'd have to go over the commands again
21:21:25 <bleathem> #commands
21:21:29 <jbott> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #rejected #restrictlogs #save #startmeeting #topic #unchair #undo #unlurk
21:21:33 <mojavelinux> org.jboss.seam.solder.i18n.Message
21:21:37 <mojavelinux> org.jboss.seam.solder.i18n.MessageBundle
21:21:42 <mojavelinux> org.jboss.seam.solder.i18n.Locale
21:21:46 <mojavelinux> org.jboss.seam.solder.i18n.Formatter
21:21:50 <mojavelinux> org.jboss.seam.solder.logging.Log
21:21:54 <mojavelinux> org.jboss.seam.solder.logging.MessageLogger
21:21:58 <mojavelinux> org.jboss.seam.solder.logging.Category
21:22:03 <mojavelinux> org.jboss.seam.solder.logging.Cause
21:22:07 <mojavelinux> oh, there is #meetingtopic and #topic
21:22:12 <mojavelinux> so I guess #topic is short term? well, anyway, we'll see
21:22:16 <mojavelinux> oops
21:22:20 <mojavelinux> sorry, that was a mistake
21:22:25 <mojavelinux> paste again
21:22:29 <kenfinnigan> Thought Message was in messaging not i18n?
21:22:43 <mojavelinux> org.jboss.seam.solder.messages.Message
21:22:47 <mojavelinux> org.jboss.seam.solder.messages.MessageBundle
21:22:52 <mojavelinux> org.jboss.seam.solder.messages.Locale
21:22:56 <mojavelinux> org.jboss.seam.solder.messages.Formatter
21:23:01 <mojavelinux> org.jboss.seam.solder.logging.Log
21:23:05 <mojavelinux> org.jboss.seam.solder.logging.MessageLogger
21:23:10 <mojavelinux> org.jboss.seam.solder.logging.Category
21:23:14 <mojavelinux> org.jboss.seam.solder.logging.Cause
21:23:18 <mojavelinux> there we go
21:23:23 <mojavelinux> and now we have this
21:23:27 <kenfinnigan> Ok, thought I was going crazy for a sec
21:23:41 <mojavelinux> @MessageLogger
21:23:45 <mojavelinux> public interface MyLogMessages {
21:23:50 <mojavelinux> @Log(level = INFO) @Message("Seam rocks")
21:23:54 <mojavelinux> void seamRocks();
21:23:58 <mojavelinux> }
21:24:02 <mojavelinux> so some optimizations and cleanups of packaging
21:24:07 <mojavelinux> and the status messages will be like this
21:24:59 <mojavelinux> @StatusReporter public interface BookingStatusReporter {
21:25:04 <mojavelinux> @Status @Message("Hotel booked!")
21:25:08 <mojavelinux> void hotelBooked();
21:25:12 <mojavelinux> }
21:25:16 <mojavelinux> ken, we didn't work out what @StatusReporter would be yet, something parallel to @MessageLogger
21:25:27 <mojavelinux> i'll let you ponder that unless you've worked it out already
21:25:31 <kenfinnigan> Not @MessageBundle?
21:25:47 <kenfinnigan> That is the current usage
21:25:56 <mojavelinux> oh, yeah, I guess we can double it up
21:26:00 <mojavelinux> k
21:26:15 <mojavelinux> cool, so that's coming along, just some heads up about that
21:26:36 <mojavelinux> so we've been beat-up a bunch about the glassfish issues
21:27:13 <mojavelinux> I did a whole bunch of digging on that and if I can ever finish it, I have a blog entry that will restate our committment to portability and explain why glassfish is giving us trouble
21:27:25 <mojavelinux> I have written some additional tests in the solder "compat" package
21:27:34 <mojavelinux> many of which fail on glassfish 3.1 due to the same issue
21:27:47 <bleathem> #topic glassfish 3.1 issues
21:27:52 <mojavelinux> i'll have details, but in short here, it's the alpha bravo issue
21:28:20 <mojavelinux> extensions and beans in an alpha.jar can see beans in the bravo.jar
21:28:24 <mojavelinux> but not the other way around
21:28:29 <mojavelinux> has to do with alphabetical order of jars
21:28:33 <johnament> alpha bravo?
21:28:37 <mojavelinux> a b
21:28:41 <bleathem> alphabetical, really!?!
21:28:47 <johnament> yep
21:28:52 <mojavelinux> yep, that's why we had problems with @Inject Messages
21:28:56 <bleathem> wow
21:29:00 <stuartdouglas> that is retarded
21:29:05 <johnament> makes sense
21:29:09 <jose_freitas> holy sh**
21:29:13 <mojavelinux> because international comes after faces
21:29:17 <mojavelinux> and faces was like huh?
21:29:22 <johnament> lol
21:29:26 <mojavelinux> where is Messages?
21:29:30 <bleathem> motion to rename faces to zFaces
21:29:35 <mojavelinux> hahaha
21:29:39 <kenfinnigan> Genius
21:29:43 <johnament> rename solder to alpha
21:29:47 <mojavelinux> yep, and that's why the Loggers are not satisified
21:29:51 <mojavelinux> because solder can't process classes in servlet
21:29:56 <bleathem> The fix for this will be in Weld 1.1.1?
21:30:01 <mojavelinux> correct, according to ales
21:30:09 <bleathem> any timeframe?
21:30:31 <mojavelinux> not sure, just "soon"
21:30:35 <lightguard_jp> bleathem: It's not a problem in weld
21:30:42 <bleathem> (ie. before Seam 3.0.0.Final)
21:30:47 <lightguard_jp> It's the integration code in glassfish
21:30:51 <mojavelinux> actually, it is a problem in weld, in a sense
21:30:55 <lightguard_jp> Really?
21:30:59 <lightguard_jp> Thought it was gf integration code
21:31:04 <stuartdouglas> I think it is actually a bit of both
21:31:15 <mojavelinux> yep, probably best said that way, it's sort of both needed to change to get past the problem
21:31:22 <mojavelinux> because of the way bdas are handled in glassfish
21:31:29 <mojavelinux> jboss as 6 is flat, so it didn't matter
21:31:35 <mojavelinux> as 7 would have had the same issue
21:31:44 <mojavelinux> given that it's more structured, right stuart?
21:32:12 <stuartdouglas> yea, it has the weld related problems, but the visibility code is all correct
21:32:27 <stuartdouglas> AS6 did not see the problems cause it did not implement the spec correctly
21:32:41 <mojavelinux> #info glassfish 3.1 out of the box processes bdas in such a way that alphabetical order of jars affects visibility of extensions and beans
21:32:54 <stuartdouglas> GF also has a problem where WEB-INF/lib beans cannot see WEB-INF/classes beans
21:33:02 <stuartdouglas> and this is all them
21:33:07 <mojavelinux> yep, that's another issue, I call that something
21:33:56 <mojavelinux> i don't know what it was, the "don't look over your shoulder" or something hehehe
21:34:04 <mojavelinux> glassfish 3.0.1 is definitely out for seam 3
21:34:08 <mojavelinux> in a major way
21:34:32 <mojavelinux> it has a serious bug in weld...where weld fails the first time it sees a reference to any class that doesn't exist
21:34:45 <mojavelinux> which means about 50% of the seam modules will just fail outright
21:34:56 <stuartdouglas> that bug is still there in 1.1
21:35:00 <mojavelinux> such as persistence, which has references to Hibernate classes
21:35:05 <stuartdouglas> It just does not show up as often
21:35:09 <mojavelinux> ah
21:35:14 <mojavelinux> well, I can at least use persistence on glassfish 3.1
21:35:19 <mojavelinux> so maybe they swallow it
21:35:23 <stuartdouglas> I did a fix for it yesterday
21:35:28 <mojavelinux> good
21:35:35 <mojavelinux> that's called the overeager scanner problem
21:35:40 <bleathem> Hope it makes it in to 1.1.1
21:35:44 <johnament> my hero
21:35:49 <mojavelinux> hyperactive scanner
21:35:54 <stuartdouglas> no, now it only happens if a superclass of a bean references a non-existant class
21:35:58 <mojavelinux> I have names for all this :)
21:36:10 <mojavelinux> we had a dangling web fragment reference in seam servlet
21:36:14 <mojavelinux> which I committed a fix for
21:36:18 <mojavelinux> lame
21:36:39 <mojavelinux> in relative ordering, if you reference a web fragment like PrettyFaces
21:36:43 <mojavelinux> and you aren't using PrettyFaces
21:36:47 <mojavelinux> deployment fails
21:36:56 <mojavelinux> so it sort of defeats the whole point of relative ordering
21:37:02 <lincolnthree> that's pretty lame
21:37:06 <mojavelinux> which happens to be kind of an important thing
21:37:13 <mojavelinux> yep, so they committed a fix to glassfish
21:37:18 <mojavelinux> jboss as fixed it in AS 6
21:37:22 <mojavelinux> final
21:37:27 <mojavelinux> and jetty fixed it in 8.0.0.M1
21:37:32 <mojavelinux> but Tomcat still fails
21:37:36 <johnament> who would be using pretty faces??
21:37:47 <bleathem> johnament you don't want to know :P
21:37:53 <mojavelinux> actually, the real purpose was to order in relation to Weld Servlet
21:38:00 <mojavelinux> because that matters or else Seam Servlet fails
21:38:09 <johnament> i heard the guy who used to work on it is now busy with CLIs.
21:38:14 <mojavelinux> however, Weld Servlet doesn't even use a web fragment yet, so that was a premature optimization anyway
21:39:05 <mojavelinux> our problem with not having concrete typed logger and typed message bundles classes is now behind us, thanks to james and ken
21:39:09 <mojavelinux> they kicked ass
21:39:20 <mojavelinux> the annotation scanner is portable to any annotations you want to use
21:39:30 <mojavelinux> so solder now has it's own annotations for defining these things
21:39:40 <kenfinnigan> My pleasure. Though most of it was James
21:39:57 <mojavelinux> and the annotation processor can be used for generating any sort of typed stuff
21:40:02 <mojavelinux> as we go down the road
21:40:16 <mojavelinux> good reuse of code...for now just focused on the original goal and also for the typed stuff in seam international
21:40:20 <mojavelinux> so that can move forward
21:40:50 <mojavelinux> more importantly, no more of this having to tell people to use the jboss.i18n.generate-proxies system property just to use seam modules
21:40:54 <kenfinnigan> Indeed. Lots of ideas to put together
21:41:03 <mojavelinux> so that should solve a lot of complaining
21:41:22 <mojavelinux> now, to get seam to run on glassfish 3.1 out of the box without any visibility problems and no upgrade to weld
21:41:27 <mojavelinux> which you know people are going to try
21:41:32 <mojavelinux> you know it
21:41:38 <mojavelinux> one solution is to shade all the seam modules together
21:41:50 <mojavelinux> the other is to deal with each problem in turn
21:41:56 <mojavelinux> which I've done all except for one problem in seam servlet
21:42:01 <mojavelinux> which is just a pita
21:42:36 <stuartdouglas> Does anyone know where we are with regard to a weld 1.1 release ?
21:42:41 <stuartdouglas> 1.1.1
21:42:45 <kenfinnigan> +1 for fully shaded jar that can be used by those that want everything
21:42:49 <mojavelinux> so seam booking works if you compile the branch temporary-logger-fix of seam servlet
21:43:14 <kenfinnigan> Might also make it easier to incorporate in EAP going forward
21:43:18 <mojavelinux> I think the seam 3.0 final release should be shaded together as an option for people that just want the "one jar to rule them all" approach
21:43:36 <mojavelinux> plus, it will shut the codi guys up :) not that they are annoying me over this issue
21:44:08 <mojavelinux> we are not sure where we are with a 1.1.1 release, we haven't gotten word from ales about a date
21:44:12 <mojavelinux> he just said "soon"
21:44:18 <bleathem> Maybe have a "web profile" shaded jar, with "essential" modules in it
21:44:25 <mojavelinux> exactly what I was thinking
21:44:30 <mojavelinux> you read my mind
21:44:34 <bleathem> :D
21:44:39 <mojavelinux> seam-web-profile.jar
21:44:53 <bleathem> I'd use that
21:44:57 <kenfinnigan> Sounds good
21:45:01 <mojavelinux> or we can just call it
21:45:15 <mojavelinux> compare-this-to-codi-gehard.jar
21:45:21 <bleathem> #idea seam 3.0 final release should be shaded together as an option for people that just want the "one jar to rule them all" approach
21:45:29 <bleathem> #idea have a "web profile" shaded jar, with "essential" modules in it
21:45:36 <bleathem> lol
21:45:41 <bleathem> I like that name better
21:45:58 <mojavelinux> I just love the chart where he says
21:46:09 <mojavelinux> codi                        seam-faces
21:46:17 <mojavelinux> persistence                   check                                  no
21:46:29 <mojavelinux> right, because you get persistence from seam-faces
21:46:56 <bleathem> The uber-seam-jar would have an inverse looking chart!
21:47:03 <bleathem> when compared to codi
21:47:11 <mojavelinux> yeah, we can just shade all 28 modules
21:47:15 <mojavelinux> :)
21:47:36 <mojavelinux> boom!
21:47:41 <GunnarMorling> may there be an problem with dependencies?
21:47:52 <GunnarMorling> Validation e.g. depends on HV 4.2Beta2
21:47:57 <mojavelinux> haha, we are just kidding :)
21:48:34 <mojavelinux> but I think having a stack jar of seam would be an attractive idea, and it's come to my mind a couple of times in the past, for the people who don't like the a la carte option
21:48:43 <mojavelinux> microwave dinner
21:48:59 <mojavelinux> arquillian alpha5 release is emminent
21:49:11 <GunnarMorling> I think the idea is generally good, too
21:49:15 <mojavelinux> and jason got the glassfish 3.1 container adapter working for that
21:49:19 <kenfinnigan> Might be easier for those moving from Seam 2 where it was all in one
21:49:34 <mojavelinux> yep, just an option, it wouldn't shade dependencies, just the seam bits
21:49:44 <mojavelinux> the dependencies would be dependencies of the shaded thing
21:50:56 <mojavelinux> ah, almost forgot
21:51:04 <mojavelinux> we've moved transactions into org.jboss.seam.transaction package
21:51:13 <mojavelinux> but I think we should just go ahead and make the transaction module now
21:51:18 <mojavelinux> because jcr is going to need it anyway
21:51:55 <mojavelinux> #action create transaction module for seam 3.0 final release
21:52:14 <mojavelinux> seam booking needs security in it, for two reasons
21:52:23 <mojavelinux> 1. to prove that it isn't causing deployment problems (always a good thing)
21:52:27 <mojavelinux> 2. to demonstrate it
21:53:30 <mojavelinux> oh
21:53:40 <bleathem> I'll be looking at SEAMFACES-33 next
21:53:44 <mojavelinux> #action lincoln needs to do a proper release of render so cody can integrate it into mail
21:53:49 <jbossbot> jira [3SEAMFACES-33] Create a solution for consolidated page-flow, transactional control, security constraints and URL-rewriting configuration [10Open (Unresolved) Feature Request,7 Blocker,6 Brian Leathem] https://issues.jboss.org/browse/SEAMFACES-33
21:53:59 <bleathem> if that relates to the security in booking
21:54:03 <mojavelinux> yep, and once that seam-faces issue is resolved, we'll integrate that into booking as well
21:54:07 <mojavelinux> there are two parts
21:54:12 <mojavelinux> authentication part can be done now
21:54:20 <mojavelinux> authorization part can be done after 33
21:54:47 <mojavelinux> I would push url-rewriting
21:54:54 <mojavelinux> because that's a bigger issue imho
21:55:11 <mojavelinux> and right now we are using pretty faces in booking to solve that problem...we just need to look into how to make that configuration integrated
21:55:24 <bleathem> Do we have an issue for it?
21:55:28 <mojavelinux> because we don't want to start over with url rewriting :)
21:55:33 <mojavelinux> not sure, but I think it needs to be 101
21:55:37 <mojavelinux> if not
21:56:20 <mojavelinux> he stuart, is as 7 ready to host a cdi + jpa app?
21:56:31 <stuartdouglas> as of yesterday, yes
21:56:44 <mojavelinux> cause we should test the forge scaffold and the archetypes on it
21:56:48 <mojavelinux> see whether they fly
21:56:53 <kenfinnigan> As of beta1?
21:57:00 <mojavelinux> likely two example apps people will try
21:57:04 <mojavelinux> also, we should try booking
21:57:20 <mojavelinux> btw, awesome
21:57:45 <stuartdouglas> however given that JPA was added about 24 hours before the beta went out, and the weld integration was added about 4 hours before the beta went out, I am not giving any guarentee's
21:58:20 <mojavelinux> hehe, got it
22:00:54 <mojavelinux> okay, time is up...if you have extra cycles, it would be good to focus on getting bugs resolved, it would be super appreciated
22:01:54 <mojavelinux> and before we wrap up, we have stellar news
22:02:09 <mojavelinux> lightguard_jp is joining the Seam Team at Red Hat
22:02:14 <lightguard_jp> :)
22:02:21 <stuartdouglas> congratulations
22:02:25 * lightguard_jp cheers
22:02:30 <kenfinnigan> Congrats!
22:02:34 <GunnarMorling> congrats :-)
22:02:51 <lightguard_jp> Thank you all
22:03:00 <lightguard_jp> Looking forward to hepling out more and moving things along
22:03:08 <mojavelinux> he's been more patient than you can possibly imagine while we worked through HR
22:03:21 <kenfinnigan> Ciao guys. Dinner time. Should be back later
22:03:26 <bleathem> lightguard_jp congrats!
22:03:37 <lightguard_jp> kenfinnigan: See ya
22:03:42 <mojavelinux> yep, now we are really going to get stuff done!
22:04:12 <mojavelinux> #endmeeting