15:04:14 <balunasj_mtg> #startmeeting
15:04:14 <jbott> Meeting started Wed Jun 29 15:04:14 2011 UTC.  The chair is balunasj_mtg. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:14 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:04:47 <balunasj_mtg> #info Agenda for this meeting:
15:04:55 <balunasj_mtg> #link http://community.jboss.org/wiki/RichFacesTeamMeetingAgenda6-29-2011
15:05:17 <balunasj_mtg> #topic AS7 & OpenShift Blogs, videos
15:05:45 <balunasj_mtg> #info Lets start with the work that is going on with lfryc and getting showcase to AS7
15:06:07 <balunasj_mtg> lfryc: Can you update the status of that work?  hopefully the presentations today was helpful
15:06:36 <lfryc> sure
15:06:59 <lfryc> balunasj_mtg: #info as part of work on showcase deployable to OpenShift and works on Push, I have started to prototype support for AS7
15:07:44 <lfryc> #info I'm trying to deploy whole demo without need to configure the server manually before
15:07:59 <lfryc> #info there are some issues which must be solved in management interface compatibility
15:08:09 <balunasj_mtg> lfryc: what config issues are needed now?
15:08:48 <lfryc> balunasj_mtg: I have configured topics required for Push through JMX, they are up and running (visible through management)
15:09:07 <lfryc> balunasj_mtg: this access is compatible between AS6 and AS7
15:09:30 <lfryc> balunasj_mtg: but the problem is these topics can't be obtained from InitialContext
15:09:33 <balunasj_mtg> lfryc: ah ok - did not know if something more than the JMS stuff
15:09:47 <lfryc> balunasj_mtg: which is the access which uses Push internally
15:09:55 <lfryc> balunasj_mtg: and I'm using it in demo too
15:10:17 <balunasj_mtg> lfryc: can you try to send a JMS manually?  There is an example in tweetstream
15:10:20 <balunasj_mtg> I'll get the link
15:10:46 <lfryc> balunasj_mtg: setup JMS manually?
15:11:02 <lfryc> balunasj_mtg: yes, it would be good to start from creating it manually
15:11:38 <balunasj_mtg> lfryc: I mean using base JMS api, not RichFaces helper method
15:11:44 <balunasj_mtg> the example is here https://github.com/richfaces/tweetstream/blob/develop/jbw/src/main/java/org/richfaces/examples/tweetstream/dataserver/listeners/ServerContentUpdateListener.java#L108
15:11:51 <lfryc> balunasj_mtg: will verify, as I know, there might be some consequences by managing AS7 via JMX
15:12:03 <balunasj_mtg> But I'm not sure if that will help you if the problem is the initialcontext
15:12:26 <balunasj_mtg> lfryc: You had mentioned it might be a config you need to "turn on" for AS7?
15:12:54 <lfryc> balunasj_mtg: not sure about it, asked Heikko to help me figure out what's going on here
15:13:36 <lfryc> balunasj_mtg: I will know more details tomorrow
15:14:05 <balunasj_mtg> lfryc: ok great
15:14:15 <lfryc> balunasj_mtg: second issue is in current configuration of AS7
15:14:33 <balunasj_mtg> lfryc: just to clearify - you're using AS7 CR1 ?
15:14:34 <lfryc> balunasj_mtg: you need to change one config which turns the HornetQ on
15:14:38 <lfryc> balunasj_mtg: yes
15:15:36 <lfryc> balunasj_mtg: will also work on this to clarify what steps are right ones using JMS in CR1
15:15:57 <lfryc> balunasj_mtg: at least we need to choose preview configuration by passing argument to startup script
15:16:14 <balunasj_mtg> lfryc: ok great - because hopefully that can be turned on by a config setting in the example so we don't need a manual step
15:16:33 <lfryc> balunasj_mtg: hope so
15:16:46 <balunasj_mtg> lfryc: ok, well hopefully that will be cleared up - it will be good to know.
15:17:11 <lfryc> it might be issue which can be solved in Final anyway
15:17:21 <lfryc> will cooperate with AS7 guys
15:17:31 <balunasj_mtg> lfryc: perfect - was just going to say that!
15:18:07 <balunasj_mtg> #action lfryc Continue investigation, work with AS7 guys for any issues, and try to prep a blog mid next week
15:18:25 <balunasj_mtg> #link https://issues.jboss.org/browse/RFPL-1506 created
15:18:27 <jbossbot> jira [RFPL-1506] RichFaces 4 & AS7 integration blog [Open (Unresolved) Task, Critical, Lukáš Fryč] https://issues.jboss.org/browse/RFPL-1506
15:19:02 <balunasj_mtg> #info Also going to be working on a screencast for OpenShift but that is a little farther out - 2-3 weeks
15:19:16 <balunasj_mtg> #info we can discuss that further in another meeting
15:19:31 <balunasj_mtg> #link https://issues.jboss.org/browse/RFPL-1507
15:19:32 <jbossbot> jira [RFPL-1507] RichFaces 4.0 & openshift deployment and integration screencast [Open (Unresolved) Task, Critical, Wesley Hales] https://issues.jboss.org/browse/RFPL-1507
15:19:47 <balunasj_mtg> ok lets move on
15:20:01 <balunasj_mtg> #topic 4.1 Mobile showcase app
15:20:31 <balunasj_mtg> #info this is currently planned for M2 - although I need to flush out the details
15:21:07 <balunasj_mtg> #info Current planning it to be the same application, but with device detection, and changes added.
15:21:29 <balunasj_mtg> #info this would use similar steps as tweetstream
15:21:29 <ppitonak> balunasj_mtg: does it make sense to include all components?
15:21:58 <balunasj_mtg> ppitonak: No - I think that is one of the things that must be updated.  The list of components needs to be modified based on support
15:22:25 <balunasj_mtg> ppitonak: So one question is do you just not show the components, or somehow group them in a "now fully supported" section ?
15:22:32 <balunasj_mtg> what do you guys think?
15:23:02 <ppitonak> balunasj_mtg: imho not show
15:23:03 <wyer> balunasj_mtg, do mobile support components target html 5 ?
15:23:43 <balunasj_mtg> ppitonak: good option - only concern is users asking where are they?  if not addressed, but also cleaner if just not there
15:24:15 <balunasj_mtg> wyer: Not specifically, but that may be part of the updates because of wide html5 support in mobile webkit browsers
15:24:22 <lfryc> balunasj_mtg: it would make sense two things - create one separate application for full-blown mobile support showcase and fix current showcase to support mobile as much as possible
15:24:27 <ppitonak> balunasj_mtg: question is whether it makes sense to support e.g. EDT on mobile phones
15:24:59 <wyer> balunasj_mtg, yeah the bang for buck value of targeting html 5 would possibly make it worthwhile
15:25:51 <balunasj_mtg> lfryc: The mobile support for the showcase should model what we hope developers will also do
15:25:55 <wyer> balunasj_mtg, its also puts more of the onus on the mobile browser than hacking device support into components
15:26:09 <balunasj_mtg> lfryc: I personally don't like separate links for mobile versions
15:26:55 <balunasj_mtg> ppitonak: That is a good question about EDT - determining that is one of the tricky things.  In most mobile UI guidelines tables like that don't fit well with mobile
15:27:12 <lfryc> balunasj_mtg: for application what should work on mobile we would need to use CSS3 features
15:27:31 <wyer> balunasj_mtg, for reference http://html5test.com/results.html scroll down to mobile
15:27:32 <balunasj_mtg> wyer: so one concern with going full blown HTML5 is backwards compatiblity
15:28:18 <balunasj_mtg> wyer: So we still need to support browsers that don't implement it yet - so in some cases it will make sense to not just use HTML5, or use a mix, etc...
15:28:30 <balunasj_mtg> lfryc: agreed
15:28:46 <wyer> balunasj_mtg, of course
15:28:47 <balunasj_mtg> lfryc: I'm not saying use the same view - I'm saying use the same app
15:29:21 <balunasj_mtg> take a look at https://github.com/richfaces/tweetstream/blob/develop/tweetstream/src/main/webapp/pages/home.xhtml
15:29:50 <balunasj_mtg> This is just a simple page from tweetstream that can customize based on device
15:30:14 <balunasj_mtg> I'm thinking something like that - or even try to extend into a RichFaces feature - but not sure about that with timing
15:31:10 <lfryc> balunasj_mtg: ok, it makes sense
15:31:19 <balunasj_mtg> lfryc: This way we are using JSF2 templating, CSS, etc... to make the changes for us.
15:31:52 <balunasj_mtg> lfryc: however its possible we get in there, and find we need to change too much
15:32:17 <balunasj_mtg> lfryc: if that is the case we may go with your thought of 2 apps.  Hopefully not - it is fairly modulized as is
15:32:38 <balunasj_mtg> any other thoughts on this before we move on for now?  All good points though?
15:32:47 <balunasj_mtg> ?=.
15:32:56 <lfryc> I like this idea
15:33:07 <lfryc> not from me
15:33:27 <ppitonak> neither from me
15:33:53 <balunasj_mtg> #topic 4.1 Editor
15:34:21 <balunasj_mtg> #info lfryc you've been spending some more time on this
15:34:34 <balunasj_mtg> #info any quick updates?
15:34:53 <lfryc> #info I have started with initial inspections of CKEditor and from perspective of JS integration it seems very promising!
15:35:17 <lfryc> #info I need to investigate in other directions: skinning and modal panel customization
15:35:38 <lfryc> #info I have also collected all requirements from wiki and issue tracking
15:35:59 <lfryc> #info so next week I should have available wiki page with editor requirements
15:36:19 <lfryc> #info from these requirements can we separate what should be integrated in scope of M1
15:36:31 <lfryc> *developed
15:36:52 <balunasj_mtg> lfryc: excellent - have you looked into how 3.3 editor was developed to give you some base info?
15:37:21 <balunasj_mtg> might help with integration issues, but don't worry - you don't have to use the same way if there is a better :-)
15:37:21 <lfryc> balunasj_mtg: yes, I'm taking docs and initial wiki requirements docs for 3.3  into consideration
15:37:46 <lfryc> balunasj_mtg: many issues was caused there by seam text integration and also parsers implementations
15:37:56 <balunasj_mtg> lfryc: perfect - I also know that you are working the AS7 stuff as a priority - so we'll see what you can get in next week.
15:38:05 <balunasj_mtg> lfryc: yes the seam-text integration was a problem
15:39:15 <lfryc> #info CKEditor has also strong JavaScript API giving us possibility to extend functionality in future
15:39:41 <balunasj_mtg> lfryc: We'll need to discuss seam-text and check with plans from seam team - I'm not sure that is a blocker for 4.1
15:39:46 <lfryc> things like selection API, dialog management, dirty checking..
15:39:59 <balunasj_mtg> lfryc: That is good stuff
15:40:45 <lfryc> balunasj_mtg: I would like to list these ideas in the requirements wiki and we can use it as start point in discussions what should be improved in later releases
15:41:10 <balunasj_mtg> #action lfryc list these ideas in the requirements wiki and we can use it as start point in discussions what should be improved in later releases
15:41:14 <balunasj_mtg> #agree
15:41:25 <balunasj_mtg> lfryc: anything else for now with this?
15:41:33 <lfryc> balunasj_mtg: that's all from me
15:41:39 <wyer> just that ck editor rocks :)
15:41:45 <balunasj_mtg> lfryc: ok thanks
15:41:51 <lfryc> balunasj_mtg: one thing..
15:42:03 <lfryc> balunasj_mtg: many guys has requested to go with TinyMCE in 4.x
15:42:07 <balunasj_mtg> #info quote " wyer just that ck editor rocks :-)"
15:42:24 <balunasj_mtg> lfryc: I scene some of the posts
15:42:26 <lfryc> balunasj_mtg: since they want not to confuse users
15:43:03 <balunasj_mtg> lfryc: It might be worth looking into their latest versions, see if things have improved - i.e. as part of your investigation
15:43:17 <wyer> i have a comment on this
15:43:30 <lfryc> wyer: please continue..
15:43:43 <wyer> my fiance does some stuff with joomla sites for her clients, adds content etc etc
15:43:49 <wyer> she loves ckeditor
15:43:59 <wyer> can't stand tinymce
15:44:22 <wyer> now she is probably the target audience for a wsiwyg editor
15:44:29 <lfryc> balunasj_mtg: we could do some kind of testing backward compatibility fro user perspective...
15:44:36 <wyer> it may be worth getting feedback from such an audience
15:44:38 <balunasj_mtg> wyer: good feedback - is there somethings should could outline in more detail?
15:45:04 <balunasj_mtg> lfryc: True
15:45:07 <wyer> since developers tend to be polarized they used tinymce once now they want tinymce
15:46:08 <balunasj_mtg> wyer: That is my thinking
15:46:36 <balunasj_mtg> ok - lets move on for now - wyer if you or your wife has more details we would love to hear them
15:46:50 <balunasj_mtg> #topic 4.1 Select updates
15:47:09 <balunasj_mtg> #info wyer has been looking and working on some updates to the select component
15:47:28 <balunasj_mtg> #info can you share current thoughts, and status?
15:47:33 <balunasj_mtg> wyer: ^
15:48:02 <wyer> sure
15:48:36 <wyer> to start with the manual input problem, i intend on addressing this as discussed on the forum
15:49:14 <wyer> i have been going through the select.js and have a pretty good idea on where to start
15:49:34 <balunasj_mtg> wyer: great
15:49:40 <wyer> at the same time i got a good idea of what i need to do with the onlistpopup / hide events that i will add
15:50:02 <wyer> i think those will help users quite a bit
15:50:17 <balunasj_mtg> wyer: If you have questions, or issue please let us know - these are good updates.
15:50:35 <wyer> then i've just got to push the fix for setValue('')
15:50:35 <balunasj_mtg> wyer: as i mentioned it might be a good blog opportunity for you as well
15:51:05 <balunasj_mtg> wyer: I would hope that is fairly simple - but you never know till you jump in
15:51:08 <wyer> and i'll update the reference for rich:select with regards to .setValue as well
15:51:24 <balunasj_mtg> perfect!
15:51:34 <wyer> balunasj_mtg, yeah its simple made the changes at the master -> develop switch
15:51:48 <balunasj_mtg> wyer: :-)
15:51:48 <wyer> just need to retest now that i've sorted my maven :P
15:52:14 <wyer> thats the updates from my side
15:52:14 <balunasj_mtg> wyer: nice so you think you'll be able to get to all of these things in July?
15:52:44 <wyer> balunasj_mtg, definitely next week we can review and i can pickup some more issues maybe
15:53:03 <balunasj_mtg> wyer: btw - you should be updated to post on dev forum, and are part of the RF contributors group in jira - just like juank_prada :-)
15:53:11 <balunasj_mtg> wyer: that is great!
15:53:21 <balunasj_mtg> Lets move on to the last topic
15:53:37 <juank_prada> balunasj_mtg: i though i already was :P
15:53:46 <balunasj_mtg> #topic 4.1 Git Build updates
15:54:33 <balunasj_mtg> #info wyer has already started some updates and helper scripts, and I'm also curious to get juank_prada feedback with the git and build stuff
15:55:07 <balunasj_mtg> #info lets start with juank_prada how has been your experience so far?  I know you had some maven hiccups
15:55:17 <balunasj_mtg> #info anything from a git usage point of view?
15:55:56 <juank_prada> I dont have any complains on git, nor do i consider myself an expert
15:56:27 <juank_prada> but i did found it hard to get used to github... just because i've never used it
15:56:29 <balunasj_mtg> juank_prada: But running through it for the first time - if you run into issues let us know - if you are seeing something other likely do to.
15:57:09 <juank_prada> really, the only issue i had was finding the info on the wiki to get started, thats why i kept asking here
15:57:40 <balunasj_mtg> juank_prada: ok - perhaps we can update the overview page - I'll think on that
15:57:45 <juank_prada> i did updated the Building Richfaces 4 from source guide  and updated the wiki front page to show a link to this guide as
15:58:00 <balunasj_mtg> juank_prada: awesome!
15:58:15 <juank_prada> I couldnt find it easy enough, others might be in the same situation
15:58:33 <juank_prada> sorry for the splitted sentence... i can't get used to this keyboard
15:58:42 <wyer> balunasj_mtg, i'll also update the wiki with my current checkout.sh changes and as lfryc pulls future changes. on this can wiki updates be prepped before hand ?
15:59:40 <balunasj_mtg> juank_prada: I'm not sure how to call out the gettings started guides more - perhaps clean up the overview page
15:59:51 <balunasj_mtg> wyer: That would be great as well
16:00:16 <juank_prada> balunasj_mtg: i was thinking the same, I'll try to do it this week if possible
16:00:31 <balunasj_mtg> #info lets talk about some of the updates wyer has done with the scripts this might help as well.
16:01:01 <balunasj_mtg> #action juank_prada Try to review and update wiki overview to better highlight getting started info - both user, and developer based
16:01:25 <balunasj_mtg> #info wyer can you describe what you've already done and some of your plans
16:01:32 <wyer> so the current enhancements to the scripts are checking out your personal forks of richfaces modules and then setting the upstream automatically
16:01:50 * balunasj_mtg thinking how awesome community is!!
16:02:01 <wyer> to allow this i have added a -u option to checkout.sh which takes your github username as the argument
16:02:44 <balunasj_mtg> Nice - I'm going to try this out this afternoon once I clear some other todos
16:02:44 * lfryc must agree, thanks to Justin it is now pretty simple to start contribution in few steps!
16:02:47 <wyer> future plans are a -m option to checkout richfaces modules of your choice so no need to edit the script
16:03:14 <wyer> and the big one is automatic forking support for modules
16:03:39 <balunasj_mtg> wyer: in the current status is it one module at a time?
16:03:48 <wyer> this will require curl to be available on the path and the script will degrade gracefully if this not possible
16:03:53 <balunasj_mtg> wyer: might be good to have an "all" option
16:04:04 <wyer> balunasj_mtg, no modules are specified at the top of a script in a varible MODULES
16:04:30 <wyer> balunasj_mtg, indeed "all" will be an option
16:04:32 <balunasj_mtg> #link https://github.com/richfaces/build/blob/develop/scripts/checkout.sh
16:04:56 <wyer> automatic forking will require the user has signed up to github
16:05:14 <wyer> and it will prompt for their github password
16:05:21 <wyer> to pass to curl
16:05:45 <wyer> as forking api call requires authentication for obvious reasons
16:05:48 <juank_prada> wyer: isnt a github account required right now to clone the git repo?
16:05:52 <balunasj_mtg> wyer: see that would be perfect too - people could get this one file, and have everything set up.
16:06:26 <balunasj_mtg> juank_prada: I believe you can clone anything but you just could not update
16:06:26 <wyer> juank_prada, no you can fork anonymously
16:06:37 <wyer> juank_prada, err clone i mean
16:06:44 <juank_prada> got it
16:07:13 <wyer> balunasj_mtg, thats the idea
16:07:23 <wyer> then i have a few more ideas as well
16:07:26 <balunasj_mtg> wyer: if you get a chance could you create a dev forum thread with your ideas here, then we can create jira's etc..
16:07:34 <balunasj_mtg> wyer: love ideas :-)
16:07:35 <wyer> balunasj_mtg, will do
16:07:40 <balunasj_mtg> excellent
16:08:03 <balunasj_mtg> #action wyer Create a dev forum topic on plans and ideas for build scripts
16:08:28 <balunasj_mtg> might also want to change from "checkout.sh" to "clone.sh" or rf_git.sh or something like that
16:08:39 <balunasj_mtg> checkout is sooo "svn"... ;-)
16:08:54 * balunasj_mtg yes I know you checkout in git too - just making a joke :-)
16:08:56 <wyer> balunasj_mtg, yeah renaming was one of those ideas, since i want it to do more than just clone
16:09:32 <balunasj_mtg> ok I need to drop off, but all good stuff
16:10:02 <balunasj_mtg> Thanks all!
16:10:05 <balunasj_mtg> #endmeeting