15:01:38 <balunasj_mtg> #startmeeting
15:01:48 <jbott> Meeting started Tue May 24 15:01:38 2011 UTC.  The chair is balunasj_mtg. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:48 <jbott> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:14 <balunasj_mtg> #info Agenda posted http://community.jboss.org/wiki/RichFacesTeamMeetingAgenda5-24-2011
15:02:33 <balunasj_mtg> lfryc: I saw your comment we can talk about that for sure.
15:02:43 <balunasj_mtg> #topic Meetbot
15:03:06 <balunasj_mtg> #info started using this so that meeting minutes are not such a pain
15:03:34 <balunasj_mtg> #info Who ever is running the meeting will be responsible for using meetbot commands
15:03:50 <balunasj_mtg> bleathem_: Hi Brian
15:04:08 <bleathem_> hi Jay
15:04:19 <balunasj_mtg> #info this will be a learning process with it
15:04:26 <balunasj_mtg> #info basic instructions are here http://wiki.debian.org/MeetBot
15:04:32 <bleathem_> using meetbot?
15:04:38 <bleathem_> nice
15:04:54 <balunasj_mtg> bleathem_: Yup just started today - I know seam-dev does it as well
15:05:03 <balunasj_mtg> so if you have any suggestions please let me know.
15:05:09 <bleathem_> will do
15:05:16 <balunasj_mtg> The agenda for today is : http://community.jboss.org/wiki/RichFacesTeamMeetingAgenda5-24-2011
15:05:54 <balunasj_mtg> Any other comments or concerns with meet bot before we move on?
15:06:20 <lfryc> no, I'm looking forward for minutes generated from that :-)
15:06:26 <balunasj_mtg> #action balunasj_mtg will post links to the minutes on the meeting information page as usual.
15:06:43 <balunasj_mtg> ok so lets move on
15:06:52 <balunasj_mtg> #topic Git migration
15:07:21 <balunasj_mtg> #info Status of the git migration, and remaining steps
15:07:37 <balunasj_mtg> lfryc: Feel free to use the meetbot commands for high level points
15:07:50 <balunasj_mtg> lfryc: Can you just give a high level summary of where we stand?
15:08:18 <lfryc> #info code base is migrated but needs further changes
15:08:26 <bleathem_> I think if lfryc is not a chair, he can't record to the minutes
15:08:33 <lfryc> #info especially finalize release process (SCM settings)
15:08:38 <bleathem_> I'm not sure that #info will record
15:08:44 <lfryc> after that I will reupload the repositories
15:08:54 <lfryc> #info do not clone repositories currently
15:09:00 <balunasj_mtg> bleathem_: hmm - ok - I'll make chair
15:09:07 <lfryc> bleathem_: good point :-)
15:09:15 <balunasj_mtg> let me look that up ;-)
15:09:40 <bleathem_> /chair lfryc i think
15:09:54 <balunasj_mtg> #chair lfryc
15:09:59 <jbott> Current chairs: balunasj_mtg lfryc
15:10:04 <balunasj_mtg> cool
15:10:11 <lfryc> okay will try again :-)
15:10:17 <lfryc> #info code base is migrated but needs further changes
15:10:22 <lfryc> #info especially finalize release process (SCM settings)
15:10:28 <lfryc> #info do not clone repositories yet
15:10:34 <lfryc> bleathem_: okay? :-)
15:10:40 <bleathem_> you bet!
15:11:03 <lfryc> #info the final migration end will be announced on the forums
15:11:28 <balunasj_mtg> lfryc: estimates on timing for this?
15:11:48 <lfryc> balunasj_mtg: today/tomorrow
15:11:54 <balunasj_mtg> #action lfryc will post to dev forums when migration and updates are complete
15:12:15 <balunasj_mtg> lfryc: ok great
15:12:38 <balunasj_mtg> lfryc: Will that include wiki updates, or just the source all updates in git?
15:13:06 <lfryc> balunasj_mtg: all updates.. I hope I will be able to find whole records across wiki
15:13:13 <lfryc> *all records
15:13:53 <balunasj_mtg> #action lfryc will update all wiki pages, and build process pages with latest approach - estimate is tomorrow/next day
15:13:59 <balunasj_mtg> lfryc: ok good
15:14:37 <balunasj_mtg> lfryc: once there we will be closing down svn usage in trunk
15:14:44 <balunasj_mtg> alexsmirnov: ^
15:15:25 <lfryc> balunasj_mtg: I think we have no JIRA to cover that, should I create it?
15:15:34 <balunasj_mtg> Then we'll have all 4.1 in git
15:15:48 <balunasj_mtg> lfryc: the closing of /trunk - sure
15:16:23 <balunasj_mtg> Once QE and docs migrate the only things we'll need in svn are legacy items
15:16:52 <balunasj_mtg> #action lfryc will create a jira to cover closing of /trunk and any other modules we have migrated.
15:17:15 <lfryc> https://issues.jboss.org/browse/RFPL-1469
15:17:21 <jbossbot> jira [RFPL-1469] Close SVN /trunk and /modules/build [Open (Unresolved) Sub-task, Major, Lukáš Fryč] https://issues.jboss.org/browse/RFPL-1469
15:17:48 <balunasj_mtg> #info RFPL-1469 created by lfryc
15:17:54 <jbossbot> jira [RFPL-1469] Close SVN /trunk and /modules/build [Open (Unresolved) Sub-task, Major, Lukáš Fryč] https://issues.jboss.org/browse/RFPL-1469
15:18:25 <balunasj_mtg> #info other items to discuss with git is workflow, and migration plans for docs and QE
15:19:08 <balunasj_mtg> ppitonak: When do you want to migrate the QE items?
15:19:34 <ppitonak> balunasj_mtg: I would wait a week or so after /trunk is migrated
15:20:07 <ppitonak> balunasj_mtg: so that we have enough time to verify that everything works
15:20:42 <balunasj_mtg> #agree QE will wait about a week after primary project migration
15:21:23 <balunasj_mtg> lfryc: Did you create jira's for the QE and docs migration to git?  can't remember if we talked about it or now?
15:21:28 <balunasj_mtg> not?
15:21:54 <lfryc> balunasj_mtg: no, I have not created such.. we have leaved for the future.. going to create that ones
15:22:31 <balunasj_mtg> #agree QE and docs can manage their own migration to git with their own jira's
15:22:43 <lfryc> and docs will be assigned to me, since Sean is out currently
15:23:12 <balunasj_mtg> #info sean is not able to work on RichFaces for a little bit - so we'll be taking over doc updates where needed.
15:23:25 <balunasj_mtg> #info this would include migration of docs
15:23:33 <lfryc> okay
15:23:38 <balunasj_mtg> #action balunasj_mtg will create the needed jira's for this
15:25:14 <balunasj_mtg> bleathem_:  do you have any idea if there is a sub-topic command?
15:25:25 <bleathem_> yes there is
15:25:33 <bleathem_> #help
15:26:20 <bleathem_> on second thought, maybe not - sorry
15:26:26 <balunasj_mtg> I thought help was asking someone for help?
15:26:32 <bleathem_> it is!  my bad
15:26:53 <balunasj_mtg> bleathem_: np
15:27:22 <balunasj_mtg> #info Next topic is discussing git workflow
15:27:59 <balunasj_mtg> #info What process we should take - benevolent dictator? integration manager, etc..?
15:28:13 <balunasj_mtg> lfryc: you've been working the migration - what are your thoughts?
15:28:35 <bleathem_> have you seen this: http://nvie.com/posts/a-successful-git-branching-model/
15:28:40 <balunasj_mtg> bleathem_: What seems to be working for seam?
15:28:55 <lfryc> lfryc: I think the best approach will be have several integration managers and contributors will need to open pull requests
15:29:00 <balunasj_mtg> bleathem_: looking...
15:29:29 <bleathem_> not really the people side of the workflow, but useful nevertheless
15:29:40 <bleathem_> it's what the Seam project is adopting
15:29:56 <balunasj_mtg> #chair bleathem_
15:30:02 <jbott> Current chairs: balunasj_mtg bleathem_ lfryc
15:30:10 <balunasj_mtg> bleathem_: please comment for the logs on that?
15:30:20 <bleathem_> lfryc: agreed several integration managers will be required
15:30:26 <bleathem_> #link http://nvie.com/posts/a-successful-git-branching-model/
15:30:48 <bleathem_> #info the Git Wrokflow being adopted by the Seam Project
15:30:57 <bleathem_> I probably got the order of those commands reversed
15:31:06 <balunasj_mtg> #agree We don't want a single bottleneck for git - we will need multiple integration managers
15:31:20 <balunasj_mtg> bleathem_: no worries
15:31:26 <lfryc> some of modules may have only one manager, e.g. showcase, CDK for necessity of reviewing
15:32:20 <balunasj_mtg> Crap - did that just drop the meeting?
15:32:25 <bleathem_> no
15:32:41 <balunasj_mtg> ok good
15:32:48 <bleathem_> it's still going (maybe because you had multiple chairs?)
15:32:54 <balunasj_mtg> sorry about that.
15:33:00 <bleathem_> no worries, we didn't make any big decisions while you were gone
15:33:06 <balunasj_mtg> lfryc: Please use the #info or #idea for that.
15:33:13 <bleathem_> :P
15:33:19 <balunasj_mtg> bleathem_: it would have been a good time for it ;-)
15:33:26 <lfryc> #idea some of modules may have only one manager, e.g. showcase, CDK for necessity of reviewing
15:34:33 <balunasj_mtg> lfryc: bleathem_ : Do you think we'll have a single list of managers, but some repo's only one will be needed.
15:34:39 <balunasj_mtg> ?
15:35:18 <bleathem_> sounds good, but I'm not familiar enough yet with the new structure to comment
15:35:31 <bleathem_> I can say how Seam does it...
15:35:53 <balunasj_mtg> On my initial look at http://nvie.com/posts/a-successful-git-branching-model/ it seems like a good flow - we only need to figure out the integration process for updates.
15:36:06 <balunasj_mtg> bleathem_: sure what does seam do currently?
15:36:34 <bleathem_> where each module lead is authoritative for their module, their is one community integrator who can accept pull requests for all modules, and a number of JBoss engineers who can do the same
15:36:50 <bleathem_> but Seam 3 if highly modular
15:37:00 <bleathem_> highly independent modules
15:37:28 <balunasj_mtg> bleathem_: our modules are not as independent - although we hope they will be more independent as we move forward.
15:38:06 <lfryc> balunasj_mtg: it will probably require also components separation
15:38:11 <bleathem_> but I would think a core group of integrators who accept pull requests would work well
15:38:21 <bleathem_> all pull requests would need to be tied to a jira
15:38:31 <bleathem_> and integrators should hold off on accepting what they don't know about
15:38:38 <balunasj_mtg> #agree all pull requests would need to be tied to a jira
15:38:44 <lfryc> #idea we should reuse Git Pull Request Workflow in JBoss JIRA
15:39:00 <balunasj_mtg> lfryc: agree
15:39:05 <bleathem_> #agree the Git pull Request Workflow in Jira works very well
15:39:32 <balunasj_mtg> #action lfryc Please be sure to document that in the wiki updates for the workflow
15:40:09 <lfryc> balunasj_mtg: okay
15:40:29 <balunasj_mtg> #agree We'll have 3 integrators at first lfryc bleathem_ and myself - we'll adjust as needed
15:41:16 <bleathem_> how much activity are we expecting in terms of pull requests? are there a lot of external commits?
15:41:22 <balunasj_mtg> #info obviously anyone can still fork, and make updates, and pull requests - just that we'll manage the merging to the main repos <--FYI
15:42:01 <balunasj_mtg> any other questions or concerns on the workflow from http://nvie.com/posts/a-successful-git-branching-model/ ?
15:42:21 <balunasj_mtg> #action All - review git workflow in more detail - http://nvie.com/posts/a-successful-git-branching-model/
15:43:02 <balunasj_mtg> ok - good
15:43:12 <ppitonak> balunasj_mtg: for QE repository all members will be integrators
15:43:58 <lfryc> balunasj_mtg: what about docs management? Only Sean would be able to integrate?
15:44:36 <balunasj_mtg> ppitonak: You could manage that however you wanted - but likely limited to you and maybe 1-2 others?
15:45:05 <balunasj_mtg> lfryc: That would need to be the same as the other repos for now - sean got pulled onto another doc project for a while
15:45:10 <ppitonak> balunasj_mtg: yes, that I is what I meant
15:45:50 <balunasj_mtg> #agree The test repo will have ppitonak and 1-2 others for integration managers
15:46:18 <balunasj_mtg> #agree Docs will be the same integration manages as the rest of the project
15:46:54 <balunasj_mtg> I'll need to do some investigation on the integration manager side, but this all sounds good.
15:47:09 <balunasj_mtg> lfryc: Anything else you wanted to cover specific to git migraiton?
15:47:21 <balunasj_mtg> any other comments from anyone on git migration?
15:47:27 <lfryc> balunasj_mtg: no, one more point
15:47:51 <balunasj_mtg> lfryc: sure - please use meetbot for it
15:47:59 <lfryc> #action setting up 'Git Author Names' and 'github Username' in jboss.org user profiles
15:48:33 <lfryc> #info it is needed to proper bounding between JBoss issue tracking (JIRA, FishEye) and GitHub
15:49:14 <lfryc> all comitters should do that and I will point that in process
15:49:27 <balunasj_mtg> lfryc: somewhat related - how many people replied to the request for author information for the migration?
15:49:49 <lfryc> balunasj_mtg: not much
15:50:24 <lfryc> balunasj_mtg: I have extracted the information in various sources.. (community.jboss.org)
15:50:43 <lfryc> balunasj_mtg: and was able to fill in all informations
15:51:19 <lfryc> balunasj_mtg: https://issues.jboss.org/browse/RFPL-1449
15:51:25 <jbossbot> jira [RFPL-1449] Request and collect github usernames for authors file [Resolved (Done) Sub-task, Major, Lukáš Fryč] https://issues.jboss.org/browse/RFPL-1449
15:52:28 <alexsmirnov> lfryc: from former exadel team, I didn't know who got request for gin names. How did you send it ?
15:52:40 <balunasj_mtg> alexsmirnov: Dev forum
15:53:18 <balunasj_mtg> alexsmirnov: your name was already there
15:53:31 <balunasj_mtg> ilya replied to the jira
15:53:43 <balunasj_mtg> nbelaevski: You have a github username right?
15:53:54 <nbelaevski> yes, it's nbelaevski
15:53:59 <balunasj_mtg> artdaw: as do you?
15:54:13 <nbelaevski> just like JBoss ID
15:54:23 <balunasj_mtg> nbelaevski: ok you are already in the list anyway - so that is good
15:54:42 <nbelaevski> balunasj_mtg: right I saw that - thansk
15:54:55 <balunasj_mtg> artdaw: right now you are set to artdaw = Gleb Galkin <ggalkin@exadel.com>
15:55:34 <balunasj_mtg> nbelaevski: if you can - can you ping the other guys to see if they are interested, or could reply to the jira before we make our final update.
15:55:39 <balunasj_mtg> ?
15:56:03 <nbelaevski> balunasj_mtg: I'll try to do that
15:56:26 <balunasj_mtg> nbelaevski: thanks - if they are not interested it is ok - it is really for them - if they want it.
15:57:32 <balunasj_mtg> #info discussed authors file for git hub migration - most are entered there.
15:58:17 * balunasj_mtg this new irc client is driving me crazy....
15:58:42 <balunasj_mtg> lfryc: anything else for the authors or for git migration in general?
15:58:48 <lfryc> balunasj_mtg: but what we need to also update is jboss.org accounts (as stated my previous action)
15:59:16 <balunasj_mtg> #agree JBoss.org accounts should be updated with github info
15:59:36 <nbelaevski> balunasj_mtg: pinged Konstantin & Pavel
15:59:41 <balunasj_mtg> #action balunasj_mtg Ask on dev forums for users to add this.
15:59:46 <lfryc> balunasj_mtg: that's all from my side currently
16:00:10 <balunasj_mtg> lfryc: ok
16:00:27 <balunasj_mtg> #action balunasj_mtg will contact Bernard to get his info
16:00:39 <balunasj_mtg> ok so we'll move on to 4.1 quickly
16:00:49 <balunasj_mtg> #topic RichFaces 4.1
16:01:26 <balunasj_mtg> #info With my vacation last week, and other issues I was not able to complete the minutes or the 4.1 items from the last team meeting on 5-10-2011
16:02:20 <balunasj_mtg> #action Review transcript for 5-10-2011 meeting and create abbreviated minutes from it.
16:03:16 <balunasj_mtg> #action balunasj_mtg jira review and updates for 4.1 before end of week
16:03:37 <balunasj_mtg> #action create an initial plan based on resources, timing, etc... for the release.
16:04:18 <balunasj_mtg> #info we are still planning on Fall release for 4.1 - the exacts dates at TBD for now.
16:05:11 <balunasj_mtg> #info there are some obvious additions like rich:editor, picklist, etc...  also likely are rich:columns, and rich:notify from bernard
16:05:50 <balunasj_mtg> #info non-component focus will be on cdk, forge, performance, mobile/html integration
16:05:58 <lfryc> rich:editor would be great endurance test for CDK!
16:06:03 <bleathem_> I like the CDI support for rish:push
16:06:09 <bleathem_> rich: push
16:06:38 <balunasj_mtg> bleathem_: I was just listing new components.
16:06:44 <balunasj_mtg> :-)
16:07:03 <lfryc> bleathem_:  I would be working on rich:push controlled by CDI this week
16:07:08 <balunasj_mtg> bleathem_: but that is in the plan + CSV updates
16:07:12 <bleathem_> sorry, I got excited reading the Rodmap in the forums !
16:07:17 <balunasj_mtg> bleathem_: sure :-)
16:08:00 <balunasj_mtg> #info existing updates for components include push with CDI, CSV updates with new constraints, fileupload issues
16:08:30 <balunasj_mtg> lfryc: You had discuss skinning, and create a new skin or two - right?
16:08:59 <lfryc> balunasj_mtg: exactly - I would like to create one or two cool skins which will be based on design from jboss.org guys
16:09:21 <balunasj_mtg> #action include ne or two cool skins which will be based on design from jboss.org guys in the planning
16:09:48 <lfryc> + let QA guys to create one skin to verify that skinability is really simple and straigtforward and that it has no issues in docs
16:10:02 <balunasj_mtg> #info there is also various jira's and other items that will be reviewed and made part of the plan
16:10:22 <balunasj_mtg> #info Need to keep in mind timing and release blocks.
16:10:28 <lfryc> + verify styling of the components - some styles cannot be overriden in standard way
16:10:54 <balunasj_mtg> lfryc: agreed - please use the meetbot #action or #idea for those
16:11:00 <lfryc> ppitonak: ^ what do you think?
16:11:23 <lfryc> ppitonak: I think this is "nice to have" category
16:11:53 <ppitonak> lfryc: balunasj_mtg yes, we definitely can try to create a new skin
16:12:09 <lfryc> #action create JIRAs for QE to cover one skin and one for styling current components
16:12:14 <ppitonak> lfryc: how do you want to verify all classes?
16:12:32 <balunasj_mtg> ppitonak: we don't have time to get into that right now - it will have to be offlist
16:12:37 <balunasj_mtg> :-(
16:12:54 <lfryc> I will create JIRAs and we will discuss there
16:13:12 <balunasj_mtg> So in the next two weeks I would like to have 4.1 planning complete, and then just get going on the implementations.
16:13:34 <balunasj_mtg> If we continue to use the monthly releases, and milestone approach ( worked well imo )
16:13:58 <balunasj_mtg> Lets just use october for an example.
16:14:06 <balunasj_mtg> Release 4.1 in October
16:14:15 <balunasj_mtg> CR1 in September
16:14:24 <balunasj_mtg> M2 in August
16:14:30 <balunasj_mtg> M1 in July
16:14:47 <balunasj_mtg> So there is really not too much time to get this going.
16:15:02 <balunasj_mtg> Anything else for 4.1 for now?
16:15:26 <balunasj_mtg> I'll have more in the forums and via updates
16:15:59 <balunasj_mtg> ok lfryc had a couple of minor items to follow up with on git
16:16:08 <balunasj_mtg> #topic git follow up items
16:16:17 <balunasj_mtg> lfryc: go ahead
16:17:07 <lfryc> #action need to migrate sandbox to Git
16:17:32 <lfryc> it should not be much more effort than for docs and tests
16:17:57 <lfryc> should be covered by standard git-svn clone
16:18:13 <lfryc> #action I suggest rename the examples
16:18:20 <balunasj_mtg> lfryc: ok good - we'll just need to touch base with bernard as well.
16:18:41 <balunasj_mtg> lfryc: what do you suggest for the examples?
16:19:09 <lfryc> #info examples repository contains developer examples which may be taken by community but it is not recommended, because it is quite a messy
16:19:22 <lfryc> #info I suggest to go with developer-examples instead
16:19:34 <balunasj_mtg> lfryc:  how about dev-examples?
16:20:02 <ppitonak> balunasj_mtg: I'm for dev-examples
16:20:08 <lfryc> we have already showcase out of samples and when we grew some more usable community examples, we can migrate that to top-level repo
16:20:15 <lfryc> #agree dev-examples sounds good
16:20:24 <balunasj_mtg> lfryc: like tweetstream for another example
16:20:31 <lfryc> exactly
16:20:36 <bleathem_> #agree dev-examples +1
16:20:42 <balunasj_mtg> #agree lets go with dev-examples
16:20:58 <balunasj_mtg> ok - we are running 20 min over - at this point anything else for now?
16:21:10 <balunasj_mtg> we can cover anything else via forums, etc..
16:21:19 <lfryc> sure
16:21:35 <balunasj_mtg> ok then - thanks all
16:21:40 <lfryc> one more point - I will comment on forums
16:21:46 <bleathem_> great meeting!
16:21:53 <balunasj_mtg> #endmeeting