#rhq Meeting

Meeting started by pilhuhn at 15:02:10 UTC (full logs).

Meeting summary

  1. Possible additions to RHQ to better support AS7 (and others) (pilhuhn, 15:02:19)
    1. http://rhq-project.org/display/RHQ/RHQ_AS7 (pilhuhn, 15:02:35)
    2. http://rhq-project.org/display/RHQ/Current+setup (pilhuhn, 15:02:35)
    3. http://rhq-project.org/display/RHQ/Needed+-+Relations (pilhuhn, 15:09:27)
    4. IDEA: allow properties/traits to be hyperlinks to point to other resources (pilhuhn, 15:11:16)
    5. IDEA: bring back perspectives :) (mazz, 15:12:46)
    6. http://etherpad.org/public-sites/ (ccrouch, 15:14:22)
    7. http://piratepad.net/Ih4kQsoFae (ccrouch, 15:14:23)
    8. AGREED: to use http://piratepad.net/JYzMyK4IYh as etherpad for questions (pilhuhn, 15:15:36)
    9. IDEA: Have "dependent values" as also described on http://rhq-project.org/display/RHQ/Needed+-+dependent+properties (pilhuhn, 15:18:54)
    10. IDEA: look at JDobie's code for filling properties from external sources (pilhuhn, 15:20:29)

  2. admin down (pilhuhn, 15:22:09)
    1. AGREED: on implementing dependent-values for drop-downs etc. (pilhuhn, 15:25:06)

  3. Autoimport new managed servers (pilhuhn, 15:33:52)
    1. HELP: Mazz I guess that is your field of experience (pilhuhn, 15:35:38)
    2. ACTION: Rethink admin-down and investigate what needs to change (pilhuhn, 15:37:13)
    3. IDEA: auto-uninventory if such a managed-as is removed from the domain by the admin (pilhuhn, 15:39:41)
    4. ACTION: pilhuhn add auto-uninventory to that wiki-page (pilhuhn, 15:39:53)
    5. IDEA: Extending dynagroups to detect resources to auto-imported (pilhuhn, 15:41:53)
    6. AGREED: We need auto-import for certain kinds of resources (pilhuhn, 15:42:16)
    7. AGREED: no auto-import of platforms (pilhuhn, 15:45:00)
    8. ACTION: investigate more on ways to do auto-import (pilhuhn, 15:47:22)

  4. DynaGroup definitions (pilhuhn, 15:47:41)
    1. IDEA: put hardcoded group definitions in the server (pilhuhn, 15:48:38)
    2. ACTION: pilhuhn Investigate more about the semantic of linking between items in the RHQ model (pilhuhn, 15:55:38)
    3. AGREED: Dynagroup push has low priority (pilhuhn, 15:56:35)

  5. Hide default config on resource creation http://rhq-project.org/display/RHQ/Needed+-+Hide+default+template+for+resource-config+when+creating+a+child (pilhuhn, 15:57:30)
    1. HELP: on those configuration related things (pilhuhn, 15:59:49)
    2. ACTION: pilhuhn Check with as7 about audit logging of as7 operations (pilhuhn, 16:04:21)

  6. deployment handling (pilhuhn, 16:05:27)
    1. ACTION: pilhuhn write a wiki page about this deployment handling (or find the existing one) (pilhuhn, 16:06:44)
    2. IDEA: simulate with operations on the deployments (pilhuhn, 16:07:50)
    3. HELP: ips on figuring out how this might work and be implemented (pilhuhn, 16:09:14)
    4. ACTION: ips helps with figuring out how this can be done (pilhuhn, 16:11:35)

  7. Pseudo-Platforms (pilhuhn, 16:11:49)
    1. http://rhq-project.org/display/RHQ/Needed+-+pseudo+platforms (pilhuhn, 16:12:06)
    2. IDEA: Require to have an agent on each platform with a HC for now (pilhuhn, 16:20:07)
    3. AGREED: Require to have an agent on each platform with a HC for now (pilhuhn, 16:22:57)
    4. ACTION: Investigate more what it takes to support pseudo-platforms and agentless management (pilhuhn, 16:23:24)
    5. ACTION: pilhuhn Add this stream of toughts to the above wiki page (pilhuhn, 16:30:54)
    6. IDEA: detect remote OS and use correct platform resource type (with some isPseudo flag) (pilhuhn, 16:35:09)


Meeting ended at 16:39:02 UTC (full logs).

Action items

  1. Rethink admin-down and investigate what needs to change
  2. pilhuhn add auto-uninventory to that wiki-page
  3. investigate more on ways to do auto-import
  4. pilhuhn Investigate more about the semantic of linking between items in the RHQ model
  5. pilhuhn Check with as7 about audit logging of as7 operations
  6. pilhuhn write a wiki page about this deployment handling (or find the existing one)
  7. ips helps with figuring out how this can be done
  8. Investigate more what it takes to support pseudo-platforms and agentless management
  9. pilhuhn Add this stream of toughts to the above wiki page


Action items, by person

  1. ips
    1. ips helps with figuring out how this can be done
  2. pilhuhn
    1. pilhuhn add auto-uninventory to that wiki-page
    2. pilhuhn Investigate more about the semantic of linking between items in the RHQ model
    3. pilhuhn Check with as7 about audit logging of as7 operations
    4. pilhuhn write a wiki page about this deployment handling (or find the existing one)
    5. pilhuhn Add this stream of toughts to the above wiki page
  3. UNASSIGNED
    1. Rethink admin-down and investigate what needs to change
    2. investigate more on ways to do auto-import
    3. Investigate more what it takes to support pseudo-platforms and agentless management


People present (lines said)

  1. pilhuhn (163)
  2. lkrejci (35)
  3. ccrouch (34)
  4. mazz (33)
  5. ips (21)
  6. jsanda (6)
  7. asantos (4)
  8. jshaughn (2)
  9. jbott (2)
  10. dmlloyd (1)


Generated by MeetBot 0.1.4.