#hibernate-dev Meeting

Meeting started by emmanuel at 17:03:15 UTC (full logs).

Meeting summary

  1. @inject (emmanuel, 17:04:54)
    1. ACTION: Support @Inject @QueryBuilder(for=Entity.class, overridesForFields = …) (we can support overridesForFields later) (emmanuel, 17:36:22)
    2. ACTION: support @Inject SearchFactory (multiple PUs won't be supported and will require users to write a qualified producer and write the unwrapping code themselves) (emmanuel, 17:37:24)
    3. ACTION: Sanne checks if Analyzers provided to users via SearchFactory.getAnalyzer() must be closed by the user or not (my guess is not) (emmanuel, 17:46:29)
    4. ACTION: sannegrinovero open a JIRA to close Analyzers at shutdown :) (emmanuel, 17:47:33)
    5. ACTION: Support @Inject @Analyzer (the HSearch annotation) Analyzer analyzer; if @Analyzer has no param set, inject the global analyzer, otherwise inject the requested analyzer (emmanuel, 17:49:20)
    6. ACTION: SearchFactory and QueryBuilder are the most important wrt injectability, the others would be nice to have (emmanuel, 17:54:18)
    7. ACTION: explore the idea of providing CDI Hibernate Search events for backend exceptions, mass indexing end of work etc (emmanuel, 18:10:25)
    8. ACTION: let Filter implementations be managed beans like bridges (emmanuel, 18:12:56)
    9. ACTION: explore further the idea of a declarative fitlter activation / desactivation by annotating managed beans with @Filter and associate @Filter with a CDI interceptor https://gist.github.com/1049434 One possible implementation is to stick the list of activated filters in a thread local context and let Hibernate Search HSQueryImpl read this TL. The implementation details are still a bit unclear (emmanuel, 18:34:18)
    10. ACTION: hardy why is FacetManager an SPI? (emmanuel, 18:38:42)
    11. ACTION: let Hardy think about useful injections wrt faceting. Maybe it would make sense to wait until after we have annotation driven / programmatic configuration for facet definitions (emmanuel, 18:39:26)
    12. on filters => sannegrinovero approach is to have globally enabled filters that are managed beans and get their activation and parameters injected by CDI (from scoped / qualified providers). This is elegant but does it go too far? (emmanuel, 18:46:27)
    13. https://github.com/LightGuard/seam-example-confbuzz/blob/develop/src/main/java/seam/example/confbuzz/PersistenceProducer.java (lightguard_jp, 18:52:16)
    14. ACTION: lightguard_jp asks on seam-dev where hsearch-cdi should live (brand wise) (emmanuel, 19:03:07)
    15. ACTION: lightguard_jp takes the coordinating lead to get thinks started and delegates at will :) (emmanuel, 19:03:39)


Meeting ended at 19:04:26 UTC (full logs).

Action items

  1. Support @Inject @QueryBuilder(for=Entity.class, overridesForFields = …) (we can support overridesForFields later)
  2. support @Inject SearchFactory (multiple PUs won't be supported and will require users to write a qualified producer and write the unwrapping code themselves)
  3. Sanne checks if Analyzers provided to users via SearchFactory.getAnalyzer() must be closed by the user or not (my guess is not)
  4. sannegrinovero open a JIRA to close Analyzers at shutdown :)
  5. Support @Inject @Analyzer (the HSearch annotation) Analyzer analyzer; if @Analyzer has no param set, inject the global analyzer, otherwise inject the requested analyzer
  6. SearchFactory and QueryBuilder are the most important wrt injectability, the others would be nice to have
  7. explore the idea of providing CDI Hibernate Search events for backend exceptions, mass indexing end of work etc
  8. let Filter implementations be managed beans like bridges
  9. explore further the idea of a declarative fitlter activation / desactivation by annotating managed beans with @Filter and associate @Filter with a CDI interceptor https://gist.github.com/1049434 One possible implementation is to stick the list of activated filters in a thread local context and let Hibernate Search HSQueryImpl read this TL. The implementation details are still a bit unclear
  10. hardy why is FacetManager an SPI?
  11. let Hardy think about useful injections wrt faceting. Maybe it would make sense to wait until after we have annotation driven / programmatic configuration for facet definitions
  12. lightguard_jp asks on seam-dev where hsearch-cdi should live (brand wise)
  13. lightguard_jp takes the coordinating lead to get thinks started and delegates at will :)


Action items, by person

  1. lightguard_jp
    1. lightguard_jp asks on seam-dev where hsearch-cdi should live (brand wise)
    2. lightguard_jp takes the coordinating lead to get thinks started and delegates at will :)
  2. sannegrinovero
    1. sannegrinovero open a JIRA to close Analyzers at shutdown :)
  3. UNASSIGNED
    1. Support @Inject @QueryBuilder(for=Entity.class, overridesForFields = …) (we can support overridesForFields later)
    2. support @Inject SearchFactory (multiple PUs won't be supported and will require users to write a qualified producer and write the unwrapping code themselves)
    3. Sanne checks if Analyzers provided to users via SearchFactory.getAnalyzer() must be closed by the user or not (my guess is not)
    4. Support @Inject @Analyzer (the HSearch annotation) Analyzer analyzer; if @Analyzer has no param set, inject the global analyzer, otherwise inject the requested analyzer
    5. SearchFactory and QueryBuilder are the most important wrt injectability, the others would be nice to have
    6. explore the idea of providing CDI Hibernate Search events for backend exceptions, mass indexing end of work etc
    7. let Filter implementations be managed beans like bridges
    8. explore further the idea of a declarative fitlter activation / desactivation by annotating managed beans with @Filter and associate @Filter with a CDI interceptor https://gist.github.com/1049434 One possible implementation is to stick the list of activated filters in a thread local context and let Hibernate Search HSQueryImpl read this TL. The implementation details are still a bit unclear
    9. hardy why is FacetManager an SPI?
    10. let Hardy think about useful injections wrt faceting. Maybe it would make sense to wait until after we have annotation driven / programmatic configuration for facet definitions


People present (lines said)

  1. emmanuel (173)
  2. sannegrinovero (76)
  3. lightguard_jp (72)
  4. pmuir (25)
  5. hardy_ (20)
  6. gastaldi (6)
  7. jbott (2)
  8. sebersole (2)
  9. gbadner (1)
  10. jbossbot (1)


Generated by MeetBot 0.1.4.